E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Sunroof error and FIX!



Reply
 
Thread Tools Search this Thread
      07-29-2011, 01:07 PM   #45
YOMERO
Registered
 
Drives: 2006 325i
Join Date: Jul 2011
Location: AZ

Posts: 1
iTrader: (0)

THANX THIS WORKED
YOMERO is offline  
0
Reply With Quote
      09-25-2011, 01:51 PM   #46
isimokov
Private
 
Drives: 2007 E90 328i
Join Date: Jul 2010
Location: Toronto

Posts: 77
iTrader: (1)

I love this board. Thanks. And thank you to Feds for letting us know that the engine has to be on.
isimokov is offline  
0
Reply With Quote
      09-27-2011, 07:24 AM   #47
Tat08
Enlisted Member
 
Drives: E90 325i 2006
Join Date: May 2011
Location: Paraguay

Posts: 32
iTrader: (0)

yes! this worked perfectly, thanks a lot, this forum is really great!
Tat08 is offline  
0
Reply With Quote
      09-27-2011, 10:16 AM   #48
laozfella
Private
 
Drives: 2007 335i
Join Date: May 2007
Location: Rhode Island

Posts: 66
iTrader: (0)

BMW charged me $30 to fix this. wish i saw this earlier.
laozfella is offline  
0
Reply With Quote
      09-28-2011, 09:36 PM   #49
Admir328xiCT
Private First Class
 
Drives: 2007 BMW 328xi
Join Date: Sep 2011
Location: Central Area of CT

Posts: 104
iTrader: (0)

Quote:
Originally Posted by mds82 View Post
Mine did this as well, did the same fix and it worked
Where in Ct r u?
Admir328xiCT is offline  
0
Reply With Quote
      09-29-2011, 01:18 AM   #50
ehhhwik
Brigadier General
 
ehhhwik's Avatar
 
Drives: 09' BMW 335d, 07' BMW E92 328i
Join Date: Oct 2006
Location: Vancouver, BC

Posts: 3,432
iTrader: (5)

wow, i cant believe almost 4 yrs after i created this thread its still being bumped, im glad its helped out so many fellow members
__________________
Current: 09' E90 335d - Titanium Silver/Black Leatherette/Sports Package/6AT Paddle Shift/USB Integration/19" Staggered Breyton GT Gloss Black

Retired: 07' E92 328i (Jet Black)
ehhhwik is offline   Hong Kong
0
Reply With Quote
      02-02-2012, 04:41 PM   #51
lieberb
Registered
 
Drives: '06 325i
Join Date: Feb 2012
Location: Boulder, CO

Posts: 1
iTrader: (0)

Thanks!

This worked great, thank you so much for the info.
lieberb is offline  
0
Reply With Quote
      03-19-2012, 12:05 PM   #52
JBoogie
Private First Class
 
Drives: 2006 BMW 330i 6 speed
Join Date: Jun 2011
Location: Massillon Ohio

Posts: 101
iTrader: (0)

This is why I love forums so much, someone always has the same problem and figures out an easy way and simple way to fix it and shares it with others so we don't have to visit the stealership.

This saved me time and money. Thanks
JBoogie is offline  
0
Reply With Quote
      05-12-2012, 06:16 PM   #53
SyL3nTFoRcE
Private First Class
 
Drives: 318>328i>328i>328ci>328xi
Join Date: Jun 2011
Location: Stamford Ct

Posts: 161
iTrader: (0)

i tried this and it worked but then it stopped working again, tried to reinitialize it again but does not work again anyone with this same problem?
SyL3nTFoRcE is offline  
0
Reply With Quote
      06-02-2012, 10:43 PM   #54
TwinT1addict
Major
 
TwinT1addict's Avatar
 
Drives: 2008 135i
Join Date: Apr 2008
Location: Stamford, CT

Posts: 1,438
iTrader: (13)

Garage List
2008 135i  [3.50]
Send a message via AIM to TwinT1addict
Quote:
Originally Posted by SyL3nTFoRcE
i tried this and it worked but then it stopped working again, tried to reinitialize it again but does not work again anyone with this same problem?
+1
TwinT1addict is offline   United_States
0
Reply With Quote
      08-29-2012, 06:29 PM   #55
bleudyno
Second Lieutenant
 
bleudyno's Avatar
 
Drives: 2010 Melbourne Red X6///M
Join Date: Mar 2009
Location: Fullerton, CA

Posts: 231
iTrader: (2)

Garage List
2010 X6M  [4.75]
2010 X6M  [0.00]
Dude, you are the MAN! My stupid sunroof wouldn't close and was going to take it to a shop for them to look at. What a simple fix! Thanks man!

David
__________________

X6///M Melbourne Red/Merino Black leather MODS: Matte black grill, Tinted head lights, Euro clear side reflectors w/ tint, Tinted white stip on tail lights, 22" Iforged Legacy Convave (Matte black center with Gloss black lip) RPI Race exhaust, Vorsteiner CF front lip, CF rear deck lid spoiler, CF rear diffuser, vented CF race hood, RPI intake scoops UPCOMING MODS: RPI software tune
bleudyno is offline  
0
Reply With Quote
      11-18-2012, 12:23 PM   #56
jettalong
Registered
 
Drives: 2006 325xit
Join Date: Nov 2012
Location: Caledon Ontario

Posts: 1
iTrader: (0)

Thanks for the fix! I thought I had a real problem, I tried initializing the roof and kept getting the fault code. It wasn't until I let the sunshade fully close to complete the cycle that the fault cleared. Thanks again from a new member/ new owner.
jettalong is offline  
0
Reply With Quote
      04-14-2013, 11:36 PM   #57
bmwnubie
New Member
 
Drives: 2008 335XI JET BLACK
Join Date: Feb 2013
Location: NC

Posts: 8
iTrader: (0)

Thanks, I thought I broke my sunroof while coding.
bmwnubie is offline  
0
Reply With Quote
      04-24-2013, 04:23 PM   #58
xtrackdog
Enlisted Member
 
Drives: 2008 335i
Join Date: Dec 2011
Location: Oregon

Posts: 38
iTrader: (0)

Thank you very much. Problem solved in 30 seconds.
xtrackdog is offline  
0
Reply With Quote
      06-29-2013, 08:41 AM   #59
a2p
Registered
 
Drives: 2007 328i
Join Date: Jun 2013
Location: Houston

Posts: 2
iTrader: (0)

It worked for me .. Thanks.
a2p is offline  
0
Reply With Quote
      09-28-2013, 01:13 PM   #60
Apo bek
Registered
 
Drives: E91 320i
Join Date: Nov 2012
Location: Thessaloniki Greece

Posts: 1
iTrader: (0)

This works for me to thanks
Apo bek is offline  
0
Reply With Quote
      10-18-2013, 10:00 PM   #61
mythek
ridiculously slow over dips
 
Drives: 2008 335i Coupe TIAG
Join Date: Jun 2013
Location: Orange County, CA, USA, NA, EARTH.

Posts: 288
iTrader: (4)

omg this method works. i was trying to hardwire my radar detector by piggybacking a power wire from the overhead cubby. after plugging everything in my runroof was malfunctioning.

you saved my ass thank you so much. oh and for my 2008 e92 335i, I had to lock the car. Unlock, then IMMEDIATELY press the runroof (tilt) button and hold it for 30 seconds.
mythek is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:32 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST