E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Major Problem! - Please Help!



Reply
 
Thread Tools Search this Thread
      04-23-2013, 06:46 PM   #1
purp_le28
Private First Class
 
Drives: 2008 BMW 328XI
Join Date: Nov 2012
Location: Memphis

Posts: 115
iTrader: (0)

Major Problem! - Please Help!

Major Issue:

I was cruising down the road and all of a sudden a yellow gear and exclamation mark symbol appear on my dash. My vehicle is a 2008 BMW 328XI. I continued to pull over into a parking lot and shut off the vehicle entirely. I then proceed to turn the vehicle on and shift into reverse and drive and my BMW will not move what so ever.

I have called many different import and German shops around the Memphis, TN area and over the phone they all mention it being electrical, transmission, missing fluids, etc.

I want to hear people's personal experiences and what their causes and cost were.

Thank you!

- David
purp_le28 is offline  
0
Reply With Quote
      04-23-2013, 11:24 PM   #2
purp_le28
Private First Class
 
Drives: 2008 BMW 328XI
Join Date: Nov 2012
Location: Memphis

Posts: 115
iTrader: (0)

Blahhh!
purp_le28 is offline  
0
Reply With Quote
      04-24-2013, 03:03 AM   #3
BillionPa
Second Lieutenant
 
BillionPa's Avatar
 
Drives: 335i
Join Date: Feb 2013
Location: USA

Posts: 288
iTrader: (0)

yellow gear is transmission, you will need a code reader to get the EGS code of the failure, as they said it could be a number of things (wiring harness came off, ground wire broke, internal trans failure, circuit board fried, trans cracked and lost all fluid, etc)
BillionPa is offline  
0
Reply With Quote
      04-24-2013, 07:39 PM   #4
purp_le28
Private First Class
 
Drives: 2008 BMW 328XI
Join Date: Nov 2012
Location: Memphis

Posts: 115
iTrader: (0)

I finally got my vehicle to a local Euro shop. They ran the codes (can't remember them off the top of my head), but it is transmission problems. They could not exactly pin point the error so I am having to take it to BMW tomorrow.

Yesterday I was not able to get it to drive forward or reverse. But after this morning, when my car got towed to the shop, the mechanics got my vehicle to "drive" but not reverse.

So I guess it is a waiting game now to see what BMW says. It won't be until next Tuesday until they can get to my car.

Gosh this sucks!!!

Anyway, my quote from this one local shop is approx $7400 for a new transmission and labor.. FML
purp_le28 is offline  
0
Reply With Quote
      04-25-2013, 06:44 AM   #5
Spitfire007
Second Lieutenant
 
Spitfire007's Avatar
 
Drives: 09 328i Sport 6MT
Join Date: Dec 2011
Location: Baltimore, MD

Posts: 298
iTrader: (0)

Garage List
2009 BMW 328i  [0.00]
could be an old battery.
electrical problems on these cars can confuse the heck out of people.
make sure you have a NEW battery. Not just a charged battery, a NEW battery.
Spitfire007 is offline  
0
Reply With Quote
      04-25-2013, 04:19 PM   #6
elcheapoloco
douchebaggo
 
Drives: stick
Join Date: Oct 2009
Location: CA

Posts: 528
iTrader: (1)

$7400 for a tranny is a tough pill to swallow. Ouch.
elcheapoloco is offline  
0
Reply With Quote
      04-25-2013, 09:42 PM   #7
slider86
Second Lieutenant
 
Drives: 2011 M-Sport 328i xDrive 6MT
Join Date: May 2011
Location: NYC

Posts: 263
iTrader: (1)

No way a tranny on a non-m car is 7,400. That's DCT replacement territory.
slider86 is offline  
0
Reply With Quote
      04-25-2013, 09:52 PM   #8
purp_le28
Private First Class
 
Drives: 2008 BMW 328XI
Join Date: Nov 2012
Location: Memphis

Posts: 115
iTrader: (0)

That is just what some local Euro shop quoted me.

My car was dropped off at Roadshow BMW in Memphis today and they can't get to my vehicle until Tuesday the 30th. We will see what they say. Damn
purp_le28 is offline  
0
Reply With Quote
      04-26-2013, 03:17 PM   #9
Kalidian
Lieutenant
 
Drives: AW '09 E90 328xi
Join Date: Oct 2012
Location: Toronto

Posts: 514
iTrader: (0)

Goddamn that sucks hard. Keep us posted on how things go, OP, and best of luck to you.
Kalidian is offline  
0
Reply With Quote
      04-26-2013, 03:42 PM   #10
GoRomeo
Colonel
 
GoRomeo's Avatar
 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

Posts: 2,197
iTrader: (0)

Garage List
2006 330i  [2.83]
Man this sucks. Did you have any signs where the tranny would slip gears or something? Keep us posted and good luck!
GoRomeo is offline  
0
Reply With Quote
      04-28-2013, 06:32 PM   #11
Casca
Captain
 
Drives: E90 6MT
Join Date: May 2010
Location: California

Posts: 630
iTrader: (0)

This DIY might be relevant to your issues

http://www.e90post.com/forums/showthread.php?t=511799

If it works intermittently and failed with no warning signs, probably something related to wiring.
Casca is offline  
0
Reply With Quote
      04-28-2013, 08:56 PM   #12
purp_le28
Private First Class
 
Drives: 2008 BMW 328XI
Join Date: Nov 2012
Location: Memphis

Posts: 115
iTrader: (0)

I will keep everyone posted when I find the solution. They are supposed to be getting to my vehicle tomorrow, we will see.

I will mention to whomever is checking my car if they can not figure out the problem about the wiring and such. Hopefully that is the issue, it'd be really freaking cheap fix. Although I've had to pay for stupid shop inspection fees, etc.
purp_le28 is offline  
0
Reply With Quote
      05-01-2013, 10:15 AM   #13
purp_le28
Private First Class
 
Drives: 2008 BMW 328XI
Join Date: Nov 2012
Location: Memphis

Posts: 115
iTrader: (0)

Got a call back from BMW. The advisor says that it is either the Mechatronic or some kind of valve inside of the Mechatronic.

Dealership prices.
$1,100 for valve.
$3,400 for Mechatronic.

Anyone ever had this issue?
purp_le28 is offline  
0
Reply With Quote
      05-01-2013, 02:52 PM   #14
bchuong58
Enlisted Member
 
Drives: Black E90
Join Date: May 2011
Location: San Jose, ca

Posts: 40
iTrader: (0)

Quote:
Originally Posted by purp_le28 View Post
Got a call back from BMW. The advisor says that it is either the Mechatronic or some kind of valve inside of the Mechatronic.

Dealership prices.
$1,100 for valve.
$3,400 for Mechatronic.

Anyone ever had this issue?
What is the Fault code number?
bchuong58 is offline   United_States
0
Reply With Quote
      05-01-2013, 02:55 PM   #15
bchuong58
Enlisted Member
 
Drives: Black E90
Join Date: May 2011
Location: San Jose, ca

Posts: 40
iTrader: (0)

Quote:
Originally Posted by purp_le28 View Post
Got a call back from BMW. The advisor says that it is either the Mechatronic or some kind of valve inside of the Mechatronic.

Dealership prices.
$1,100 for valve.
$3,400 for Mechatronic.

Anyone ever had this issue?
As Casca said sometimes it is the wiring or connectors need to be cleaned.
bchuong58 is offline   United_States
0
Reply With Quote
      05-01-2013, 09:03 PM   #16
purp_le28
Private First Class
 
Drives: 2008 BMW 328XI
Join Date: Nov 2012
Location: Memphis

Posts: 115
iTrader: (0)

Quote:
Originally Posted by bchuong58 View Post
What is the Fault code number?
I will need to go up to BMW tomorrow. I was busy all day and couldn't get to them.

My father was the one that went up to BMW and they gave him the options I listed, but the dealership is agreeing that it is just the valve that is causing the problem.

I will update more tomorrow! Such a slow process because I have classes and work. Blah
purp_le28 is offline  
0
Reply With Quote
      05-02-2013, 07:59 AM   #17
CALWATERBOY
Captain
 
CALWATERBOY's Avatar
 
Drives: 2009 E93 N54
Join Date: Jan 2011
Location: San Francisco

Posts: 836
iTrader: (0)

Quote:
Originally Posted by purp_le28 View Post
Major Issue:

I was cruising down the road and all of a sudden a yellow gear and exclamation mark symbol appear on my dash. My vehicle is a 2008 BMW 328XI. I continued to pull over into a parking lot and shut off the vehicle entirely. I then proceed to turn the vehicle on and shift into reverse and drive and my BMW will not move what so ever.

I have called many different import and German shops around the Memphis, TN area and over the phone they all mention it being electrical, transmission, missing fluids, etc.

I want to hear people's personal experiences and what their causes and cost were.

Guessing you have an automatic xmission. Those have a row of solenoids inside, and auto trans ain't rocket science to fix, but noooooooooooooo....BMW won't work on 'em.

They just replace, at HIGH cost. Sonofabeech!

Also, you mentioned the mechatronic [seal]. A commmon enough issue, here are a couple o'procedures. DIY's abound, but maybe you prefer to have it fixed.

ZF's doc

BMW's doc

Also, keep this handy procedure filed away for future use.

Should you change your tranny fluid, take a peek @ this.

______________________________________________
Edit: OK, this is getting stupid fast. The first link above is: w-w-w.b-i-m-m-e-r-b-o-o-s-t.com/content.php?1414-First-high-torque-N54-(335i-135i)-steptronic-transmission-build-completed-by-Level-10-Transmisisons-700-pound-feet-capable

Remove dashes for a valid link.

BUT! Board software replaces b-i-m-m-e-r-b-o-o-s-t [in your mind, remove the dashes - Golly! There's the site!] with *********** every time. 'Why, oh why?' I cry. There is no answer.

.

Last edited by CALWATERBOY; 05-02-2013 at 08:16 AM.
CALWATERBOY is offline  
0
Reply With Quote
      05-03-2013, 02:15 PM   #18
purp_le28
Private First Class
 
Drives: 2008 BMW 328XI
Join Date: Nov 2012
Location: Memphis

Posts: 115
iTrader: (0)

BMW fixed my vehicle. It ended up being the valve in the Mechatronic system!

Total cost : $1,100. Eh, probably should not have cost that much but whatever. It's finally fixed.
purp_le28 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:10 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST