E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > CEL with trouble codes: P2401 P2419 P240A



Reply
 
Thread Tools Search this Thread
      03-11-2013, 09:09 AM   #1
bavaddict
Second Lieutenant
 
Drives: 2008 e92 335i
Join Date: May 2010
Location: East Coast

Posts: 266
iTrader: (0)

CEL with trouble codes: P2401 P2419 P240A

Hello:

Recently my CEL came on and quick OBDII diag showed following DTC's:

P2401 - Evaporative Emission System Leak Detection Pump Control Circuit Low
P2419 - Evaporative Emission System Switching Valve Control Circuit Low
P240A - Evaporative Emission System Leak Detection Pump Heater Control Circuit/Open

Car seems to be behaving nicely regardless of the CEL, unlike CEL for injector/HPFP issues that I have researched so far.

I have searched a bit online at most items pointed to gas cap not being tight which I retightened and then cleared all DTC codes again. All three codes have returned back. Any ideas what may throw this off?

This is a 08 335i with 70k miles and no mods since it was born (and now out of warrantee). Also, i don't have the golf tee mod.

Thanks.

PS: My local shop has me booked in 2 weeks for better diag...but hoping i can get to it before my appointment.

Last edited by bavaddict; 03-11-2013 at 10:20 AM. Reason: added more info.
bavaddict is offline  
0
Reply With Quote
      03-11-2013, 08:05 PM   #2
bavaddict
Second Lieutenant
 
Drives: 2008 e92 335i
Join Date: May 2010
Location: East Coast

Posts: 266
iTrader: (0)

FWIW....I already had the HPFP and all 6 fuel injectors replaced under the recall that was out about a year ago.

Dealer will cover the dianostic if any work associated with these two was the cause....question is if it is even possible that there is a HPFP link here?

Or this could be start of HPFP going faulty slowly surely?
bavaddict is offline  
0
Reply With Quote
      03-11-2013, 10:24 PM   #3
bavaddict
Second Lieutenant
 
Drives: 2008 e92 335i
Join Date: May 2010
Location: East Coast

Posts: 266
iTrader: (0)

bump....
bavaddict is offline  
0
Reply With Quote
      03-15-2013, 02:03 PM   #4
bavaddict
Second Lieutenant
 
Drives: 2008 e92 335i
Join Date: May 2010
Location: East Coast

Posts: 266
iTrader: (0)

No one has had a run-in with any of these codes? Any one?!?!
bavaddict is offline  
0
Reply With Quote
      03-17-2013, 04:09 PM   #5
marks335
Private
 
Drives: 2007 335i
Join Date: Nov 2012
Location: Toronto

Posts: 55
iTrader: (2)

I just got the same 3 codes...hoping for an answer...subscribed.
marks335 is offline   Canada
0
Reply With Quote
      03-18-2013, 04:26 PM   #6
marks335
Private
 
Drives: 2007 335i
Join Date: Nov 2012
Location: Toronto

Posts: 55
iTrader: (2)

Tightened my gas cap and reset the codes...and they are back.
marks335 is offline   Canada
0
Reply With Quote
      03-19-2013, 12:44 PM   #7
bavaddict
Second Lieutenant
 
Drives: 2008 e92 335i
Join Date: May 2010
Location: East Coast

Posts: 266
iTrader: (0)

After much reading and noticing that my mileage (both OB computer and observing km per tank of gas) are screwed up, see below, I definately think something is wrong.

1. Doing 120 - 130 km/hr OBC is showing mileage as 6.5-6.8 L/100 Km (definately used to see 8-9 L/100 Km during morning and evening commute)
2. At the same time I got 200 ~ 250 Km out of half tank of gas (used to get about 300-350 per half tank)

Guess I will have to wait till my appointment. Having said that from my research two common culprits are purge valve and DMTL pump with these codes (althought codes are not identical) and both look fairly easy for a DIY'er.
bavaddict is offline  
0
Reply With Quote
      03-19-2013, 12:45 PM   #8
bavaddict
Second Lieutenant
 
Drives: 2008 e92 335i
Join Date: May 2010
Location: East Coast

Posts: 266
iTrader: (0)

On another note, someone my local BMW Club mentioned that they ran into this issue and the purge valve was stuck and dealer got it opened by testing the EVAP system and performing some diagnostics.
bavaddict is offline  
0
Reply With Quote
      03-26-2013, 05:37 PM   #9
bavaddict
Second Lieutenant
 
Drives: 2008 e92 335i
Join Date: May 2010
Location: East Coast

Posts: 266
iTrader: (0)

FYI....Got diag done via local indy shop and DMTL pump needs replacement. $300 installed! Anyone done DIY DMTL replacement on boosted e92's?
bavaddict is offline  
0
Reply With Quote
      04-08-2013, 01:20 PM   #10
bavaddict
Second Lieutenant
 
Drives: 2008 e92 335i
Join Date: May 2010
Location: East Coast

Posts: 266
iTrader: (0)

FYI.... take a close look at the electrical connector that feeds DMTL pump! Couple of wires were cut hence the DMTL codes. Soldered them back on last week and no issues after 5 days of driving. Hopefully dealer takes back the DMTL pump!

BTW, in my case my Indy mechanic was stupid enough to do just the bare minimum of attaching the diagnostics equipment and not checking further by doing DMTL/EVAP specific testing .... upon which i was told promptly to change the DMTL pump.(Duss Bros in Ottawa - highly eccentric/senile but I went anyway on advise of many here )
bavaddict is offline  
0
Reply With Quote
      04-18-2013, 10:54 PM   #11
Quang604
Registered
 
Drives: 2009 bmw 335i rwd
Join Date: Apr 2013
Location: Toronto

Posts: 2
iTrader: (0)

P2401, p2419, p340a

Hi all,
I just got the same codes,P2401, P2419, and P240a on my 2009 335i. When i stoped the engine, i heard a wierd noise from the back. Is this a DMTL pump problem? How can i check the DMTL pump? The car still has the same power and runs fine.
I would appreciate if you can provide some advices.
Thank you in advance.
Quang604 is offline   Canada
0
Reply With Quote
      04-21-2013, 10:55 PM   #12
bavaddict
Second Lieutenant
 
Drives: 2008 e92 335i
Join Date: May 2010
Location: East Coast

Posts: 266
iTrader: (0)

Quote:
Originally Posted by Quang604 View Post
Hi all,
I just got the same codes,P2401, P2419, and P240a on my 2009 335i. When i stoped the engine, i heard a wierd noise from the back. Is this a DMTL pump problem? How can i check the DMTL pump? The car still has the same power and runs fine.
I would appreciate if you can provide some advices.
Thank you in advance.
See my post above and make sure the connector is properly secured to the DMTL pump and no wires are cut on the connector. To check you will need to take off (at least for I did for my e92 335i) rear driver side fender liner and you should see the pump attached to a black canister.

Assuming above check shows no problem, you may have a better luck by taking the pump out and blowing it off via some air and put it back in and see if that does the trick.

Else you will need to get dealer or indy to do a full diagnostics via GT1 type device and hopefully they can pinpoint if its the pump or general evap leak.

Also, it may be the purge valve located in the engine bay behind the intake (i did'nt have to try this but read/heard via some members here).

Good luck.
bavaddict is offline  
0
Reply With Quote
      04-26-2013, 01:56 PM   #13
Quang604
Registered
 
Drives: 2009 bmw 335i rwd
Join Date: Apr 2013
Location: Toronto

Posts: 2
iTrader: (0)

Hi bavaddict,
Thank you. I will check the connector and the purge valve.
Quang604 is offline   Canada
0
Reply With Quote
      06-06-2014, 09:41 PM   #14
d3l0n
I love the ///M3, but I want 550hp ///M5
 
d3l0n's Avatar
 
Drives: BMW330iE90
Join Date: May 2006
Location: NYC

Posts: 3,279
iTrader: (1)

Garage List
any update? I have p2401, p2419 as well. Replaced the DTML pump and neighboring sensor, still error code.

Last edited by d3l0n; 06-06-2014 at 10:32 PM.
d3l0n is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:57 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST