E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > Blaupunkt Plug'N'Play Amp install.....



Reply
 
Thread Tools Search this Thread
      05-01-2013, 06:45 AM   #397
makkan00
Major General
United Kingdom
115

 
makkan00's Avatar
 
Drives: E91 330D
Join Date: Dec 2011
Location: Essex


Posts: 7,398
iTrader: (48)

Quote:
Originally Posted by gurpswoo1
Perfect, I think I know to order now.

Thanks very much.
Do you know the part number which should be used to connect already existing socket?
__________________
Appreciate 0
      05-01-2013, 01:48 PM   #398
gurpswoo1
Private
0

 
Drives: BMW E92 335d
Join Date: Mar 2013
Location: Warwickshire


Posts: 74
iTrader: (0)

I got part codes from this thread, http://www.e90post.com/forums/showpo...9&postcount=19
Appreciate 0
      05-02-2013, 01:06 AM   #399
makkan00
Major General
United Kingdom
115

 
makkan00's Avatar
 
Drives: E91 330D
Join Date: Dec 2011
Location: Essex


Posts: 7,398
iTrader: (48)

Quote:
Originally Posted by gurpswoo1 View Post
thanks, found them last night as well.
__________________
Appreciate 0
      05-10-2013, 05:03 PM   #400
gurpswoo1
Private
0

 
Drives: BMW E92 335d
Join Date: Mar 2013
Location: Warwickshire


Posts: 74
iTrader: (0)

I just installed the 4 channel 475 amp. However I have a big problem. There hiss when there is no sound. Then when I start car, there is alternator noise when I rev up and down. I have dine the following.

1. Changed ground to direct to battery.
2. Removed the pnp cabled and attached them together. There is no hiss or whine. Perfect.
3. Removed input to amp. Amp switches off so not really a test.
4. Tried another amp. Same problem.

What am I doing wrong. Do I have to connect anything in the harness. I just connected the 5m extention. No power cables or anything. Speakers are stock.

Please help.
Appreciate 0
      05-10-2013, 05:25 PM   #401
gIzzE
Major General
United Kingdom
71

 
gIzzE's Avatar
 
Drives: Mercedes ML and 2.8i Z3
Join Date: Apr 2006
Location: Norfolk, UK.


Posts: 5,154
iTrader: (2)

Have you run the cables up the left hand side of the car and not the right with the battery cable?
Appreciate 0
      05-10-2013, 05:49 PM   #402
gurpswoo1
Private
0

 
Drives: BMW E92 335d
Join Date: Mar 2013
Location: Warwickshire


Posts: 74
iTrader: (0)

Yes I ran them along the left hand side of car. I even ran them across the middle. Same problem.
Appreciate 0
      05-11-2013, 04:55 AM   #403
eardle235
Registered
0

 
Drives: E90 325i M Sport
Join Date: Apr 2013
Location: United Kingdom


Posts: 1
iTrader: (0)

THA555

Quote:
Originally Posted by gurpswoo1 View Post
Wow great thread, really impressed with the all the advice everyone is giving.

However the biggest problem seems to be that the 5 channel amp is no longer available.

What is everyone doing now with the 4 channel amp. Driving the front tweeter and mids with 2 ch's and the other two for subs. Then letting the rear run off the stock HU.

Is that even possible with a e92 LCI?
I have a 5 channel amp that I have just taken out of my E90 325i along with the harness and cables. If anyone is interested make me an offer? Might make your life easier...
Appreciate 0
      05-13-2013, 03:10 AM   #404
gurpswoo1
Private
0

 
Drives: BMW E92 335d
Join Date: Mar 2013
Location: Warwickshire


Posts: 74
iTrader: (0)

OK figured it out. The large connector the original harness connects to was not interfacing correctly. Had to use plyers then engage lock. That reduced the noise by 50%. Then I turned down the gain a little and all good. Now onto speaker install.
Appreciate 0
      05-14-2013, 04:52 PM   #405
Telly Addict
First Lieutenant
United Kingdom
4

 
Telly Addict's Avatar
 
Drives: 2 wheels!
Join Date: Mar 2013
Location: Scotland


Posts: 305
iTrader: (5)

Quote:
Originally Posted by eardle235 View Post
I have a 5 channel amp that I have just taken out of my E90 325i along with the harness and cables. If anyone is interested make me an offer? Might make your life easier...
Is it the Blaupunkt 555? What are you looking for?
Appreciate 0
      05-16-2013, 04:45 AM   #406
Rombedio84
New Member
0

 
Drives: BMW 330i Coupe
Join Date: May 2013
Location: London


Posts: 5
iTrader: (0)

Can this be done on the 6 speaker base system.

Hi Mate,

Great install and nicely detailed pics. I'm just wondering if this can be done on a 6 speaker base system (no amp in boot)? I have the e92 330i (2008) with Sat Nav and I-drive.
Appreciate 0
      05-16-2013, 07:08 AM   #407
gIzzE
Major General
United Kingdom
71

 
gIzzE's Avatar
 
Drives: Mercedes ML and 2.8i Z3
Join Date: Apr 2006
Location: Norfolk, UK.


Posts: 5,154
iTrader: (2)

That is exactly what this is for mate, to upgrade the base system.
Appreciate 0
      05-23-2013, 08:04 AM   #408
Rombedio84
New Member
0

 
Drives: BMW 330i Coupe
Join Date: May 2013
Location: London


Posts: 5
iTrader: (0)

Cheers Gizze
Appreciate 0
      05-29-2013, 10:55 AM   #409
sylonien
Major
United Kingdom
15

 
Drives: M3
Join Date: Apr 2012
Location: Over there


Posts: 1,215
iTrader: (0)

Will this amp work with Hifi audio system?
Or is there a equivelant to power the stock Hifi, 2 subs, 2 mid range front, 2 tweeter front, 2 tweeter back and 2 mid range.

10 speakers in total?
__________________
Appreciate 0
      05-29-2013, 01:45 PM   #410
gIzzE
Major General
United Kingdom
71

 
gIzzE's Avatar
 
Drives: Mercedes ML and 2.8i Z3
Join Date: Apr 2006
Location: Norfolk, UK.


Posts: 5,154
iTrader: (2)

No it won't, it is about the same as the hifi upgrade.
Appreciate 0
      06-01-2013, 07:39 AM   #411
DocD
Private First Class
1

 
Drives: 330d M-Sport E90
Join Date: Apr 2013
Location: Southport UK


Posts: 114
iTrader: (0)

gIzzE

I'm not confident that there is sufficient power available from the radio loom to the amp and would like to run power cables to the battery. If I use the power adaptor supplied for this purpose; will I have to find a remote feed to turn the amp on or is this detected through the high level speaker inputs?
Appreciate 0
      06-01-2013, 08:34 AM   #412
gIzzE
Major General
United Kingdom
71

 
gIzzE's Avatar
 
Drives: Mercedes ML and 2.8i Z3
Join Date: Apr 2006
Location: Norfolk, UK.


Posts: 5,154
iTrader: (2)

Definitely run direct to the battery.

Amp will turn on with the head unit through the speaker wires.
Appreciate 0
      06-01-2013, 09:00 AM   #413
DocD
Private First Class
1

 
Drives: 330d M-Sport E90
Join Date: Apr 2013
Location: Southport UK


Posts: 114
iTrader: (0)

Quote:
Originally Posted by gIzzE View Post
Definitely run direct to the battery.

Amp will turn on with the head unit through the speaker wires.
Fantastic, thanks for the confirmation
Appreciate 0
      06-17-2013, 05:48 PM   #414
Telly Addict
First Lieutenant
United Kingdom
4

 
Telly Addict's Avatar
 
Drives: 2 wheels!
Join Date: Mar 2013
Location: Scotland


Posts: 305
iTrader: (5)

Many thanks for this thread gIzzE, you inspired me to do this upgrade myself. I've just completed tonight and having got the battery drained warning through iDrive, I went for a quick drive to charge the battery - well it turned into a full hour of chilled out driving around Fife! What a transformation to the sound out my car's audio...and that's without changing the under seat subs yet! I used the Ground Zero component set as used by a few other installs on the forum and they are indeed excellent.

I bought the Blaupunkt 555 amp and harness from eardle235 from the post below. Cheers Will!


Quote:
Originally Posted by eardle235 View Post
I have a 5 channel amp that I have just taken out of my E90 325i along with the harness and cables. If anyone is interested make me an offer? Might make your life easier...
Appreciate 0
      06-22-2013, 01:42 PM   #415
Isetta
Enlisted Member
Greece
2

 
Isetta's Avatar
 
Drives: E90
Join Date: Aug 2010
Location: Greece


Posts: 31
iTrader: (0)

Hi guys,

I'm a little confused.
Has anyone tried Blaupunkt THA 475 PnP with the base system?
(Proffessional Headunit, 2 subs, 2 mid range front and 2 mid range back, no stock amp).
Will it work without adding tweeters or any more speakers, even if the result won't be of high fidelity or is it just useless?

Excuse me if I am off topic.

Quote:
Originally Posted by gIzzE View Post
That is exactly what this is for mate, to upgrade the base system.
Appreciate 0
      06-22-2013, 01:46 PM   #416
DocD
Private First Class
1

 
Drives: 330d M-Sport E90
Join Date: Apr 2013
Location: Southport UK


Posts: 114
iTrader: (0)

Quote:
Originally Posted by Isetta View Post
Hi guys,

I'm a little confused.
Has anyone tried Blaupunkt THA 475 PnP with the base system?
(Proffessional Headunit, 2 subs, 2 mid range front and 2 mid range back, no stock amp).
Will it work without adding tweeters or any more speakers, even if the result won't be of high fidelity or is it just useless?

Excuse me if I am off topic.
In a word, yes and it will still be a worthwhile upgrade.
Appreciate 0
      06-22-2013, 04:28 PM   #417
Isetta
Enlisted Member
Greece
2

 
Isetta's Avatar
 
Drives: E90
Join Date: Aug 2010
Location: Greece


Posts: 31
iTrader: (0)

Quote:
Originally Posted by DocD View Post
In a word, yes and it will still be a worthwhile upgrade.
Thanks DocD!
Appreciate 0
      06-23-2013, 12:32 PM   #418
gIzzE
Major General
United Kingdom
71

 
gIzzE's Avatar
 
Drives: Mercedes ML and 2.8i Z3
Join Date: Apr 2006
Location: Norfolk, UK.


Posts: 5,154
iTrader: (2)

Add the tweeters though, it makes a big difference.

With the 475 you will drive the mids (and tweeters if you add them) with front channels and the subs with the rear channels, which means you are not really need in the plug and play harness, which in turn means you may as well buy a 4 channel Pioneer amp for 120.

Unless you just add the 475 and drive the subs and mids with the front and the rears with the rear channels, but that to me seems a waste of time.
Appreciate 0
Reply

Bookmarks

Tags
amp, blaupunkt, diy, tha 475

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:36 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST