E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > **First Time Tuners** Start Here** Official Misfire Thread| Updated!



Reply
 
Thread Tools Search this Thread
      04-12-2013, 12:19 PM   #155
akotten
Major
 
akotten's Avatar
 
Drives: 2007 335xi
Join Date: Mar 2011
Location: Rapid City, SD

Posts: 1,032
iTrader: (2)

Just thought I'd share my misfire experience.

Had a very consistent misfire on Cyl1, even at only 12psi of boost. Swapped Cyl1 & Cyl2 spark plugs and coils, and the misfire followed to Cyl2. Ordered a new coil and a full set of NGK 5992 spark plugs. Should have the issue resolved next week.
__________________
TC Kline S/A | Vorshlag Camber Plates | ///M Bushings & ARB | CP-e DPs | VRSF FMIC | Procede 2.5 w/ OpenFlash | DCI |
akotten is offline  
0
Reply With Quote
      05-08-2013, 03:02 PM   #156
HellsBells
Private First Class
 
Drives: 335xi
Join Date: May 2011
Location: Maryland

Posts: 185
iTrader: (1)

I ruled out coils, replaced the spark plugs.
I knew that my problem was not HPFP or injectors as they were replaced under warranty last year, so that left me with CARBON BUILDUP.

I went to a local shop in Maryland and had them cleaned today via Walnut Blasting service... problem solved.

This should be a must do after 30k miles... I will post pictures later, but they were cruddy.

Before and after pictures attached
Attached Files
File Type: zip IMG_0471a.zip (147.1 KB, 90 views)
File Type: zip IMG_0473a.zip (83.0 KB, 57 views)

Last edited by HellsBells; 05-09-2013 at 01:03 PM.
HellsBells is offline  
0
Reply With Quote
      05-08-2013, 03:22 PM   #157
Dinan_Bimmer
Private First Class
 
Drives: BMW
Join Date: May 2010
Location: NE USA

Posts: 177
iTrader: (4)

whats the deal with the dealers on this do they check this under warranty as well?
__________________
Pete
2009 335i Sedan BMW PK, 19"s, BMW perf Body kit, JB4, CF rear wing, CF Mirror caps
Blue Water Metallic w/Oyster Inside
2009 CTS-V "Eleanor's worst nightmare" Crystal Red w/ Lt Platinum
Dinan_Bimmer is offline  
0
Reply With Quote
      05-11-2013, 10:42 AM   #158
JLiusifer
Enlisted Member
 
Drives: 2007 335i
Join Date: Aug 2012
Location: Minnesota

Posts: 34
iTrader: (0)

Last night I installed my Cobb Accessport and chose the Stage 1 map that requires 91 octane. After the flash I got a CEL with a code of Misfire in Cyl 6.

I searched around the forum and most are saying that I will need to either swap coils with cyl 6 with another cylinder or change out my spark plugs.

My car has 71k and the last time the spark plugs were changed around 45k.

What kind of spark plugs do you recommend? Do I have to stick with BMW parts? What about the coils? Can I just get an off brand from the local auto parts store?

Thanks!
JLiusifer is offline  
0
Reply With Quote
      05-11-2013, 11:40 AM   #159
Dinan_Bimmer
Private First Class
 
Drives: BMW
Join Date: May 2010
Location: NE USA

Posts: 177
iTrader: (4)

well for plugs Advance auto parts carries them, sometimes locally, ZGR6STE2 pt number
__________________
Pete
2009 335i Sedan BMW PK, 19"s, BMW perf Body kit, JB4, CF rear wing, CF Mirror caps
Blue Water Metallic w/Oyster Inside
2009 CTS-V "Eleanor's worst nightmare" Crystal Red w/ Lt Platinum
Dinan_Bimmer is offline  
0
Reply With Quote
      05-11-2013, 12:47 PM   #160
JLiusifer
Enlisted Member
 
Drives: 2007 335i
Join Date: Aug 2012
Location: Minnesota

Posts: 34
iTrader: (0)

Thanks! How about coils? I have a Advance Auto near my house.
JLiusifer is offline  
0
Reply With Quote
      05-11-2013, 08:39 PM   #161
Dinan_Bimmer
Private First Class
 
Drives: BMW
Join Date: May 2010
Location: NE USA

Posts: 177
iTrader: (4)

Quote:
Originally Posted by JLiusifer View Post
Thanks! How about coils? I have a Advance Auto near my house.
they do list 2 kinds of coils, Part No. E1092 is one but both were not in stock at any stores locally for me.
__________________
Pete
2009 335i Sedan BMW PK, 19"s, BMW perf Body kit, JB4, CF rear wing, CF Mirror caps
Blue Water Metallic w/Oyster Inside
2009 CTS-V "Eleanor's worst nightmare" Crystal Red w/ Lt Platinum
Dinan_Bimmer is offline  
0
Reply With Quote
      05-13-2013, 01:10 PM   #162
HellsBells
Private First Class
 
Drives: 335xi
Join Date: May 2011
Location: Maryland

Posts: 185
iTrader: (1)

Quote:
Originally Posted by JLiusifer View Post
Last night I installed my Cobb Accessport and chose the Stage 1 map that requires 91 octane. After the flash I got a CEL with a code of Misfire in Cyl 6.

I searched around the forum and most are saying that I will need to either swap coils with cyl 6 with another cylinder or change out my spark plugs.

My car has 71k and the last time the spark plugs were changed around 45k.

What kind of spark plugs do you recommend? Do I have to stick with BMW parts? What about the coils? Can I just get an off brand from the local auto parts store?

Thanks!
I would change the spark plugs first, it sounds like you need it anyway.
There is any easy way to see if it is the spark plugs versus the coils, you simply move the coils and see if the problem moves with the coils.
That being said, I will bet that it is the plugs and if you have not had your intakes cleaned that it is carbon buildup.

Also, just get the plugs and coils OEM, don't scrimp on these...
HellsBells is offline  
0
Reply With Quote
      05-13-2013, 01:24 PM   #163
Dinan_Bimmer
Private First Class
 
Drives: BMW
Join Date: May 2010
Location: NE USA

Posts: 177
iTrader: (4)

the advance plugs ARE OEM they just dont say BMW on them...
__________________
Pete
2009 335i Sedan BMW PK, 19"s, BMW perf Body kit, JB4, CF rear wing, CF Mirror caps
Blue Water Metallic w/Oyster Inside
2009 CTS-V "Eleanor's worst nightmare" Crystal Red w/ Lt Platinum
Dinan_Bimmer is offline  
0
Reply With Quote
      05-13-2013, 06:46 PM   #164
1nityrider
Private First Class
 
Drives: 2008 335xi
Join Date: Nov 2012
Location: St Paul

Posts: 158
iTrader: (0)

Hi everyone. I will start by saying my car is bone stock 2008 335xi. I bought it at 60k miles. HPFP was done at 35k, some injectors where replaced around 25k. Don't know if or when valve cleaning was done. I started having sputtering/engine shaking and service engine light on around 63k miles. Codes said it was cylinder 6 misfiring. I changed all 6 plug. Around 64.5k miles it happen again. Cylinder 6. I changed the coil with a new one. 65k, again cylinder 6. But this time the SEL light have come on and stayed on. Car drives fine. I have an appointment with the dealer Thursday. Any ideas/suggestions?
1nityrider is offline   United_States
0
Reply With Quote
      05-13-2013, 08:00 PM   #165
Jhalf
Private
 
Drives: 08 335i e92
Join Date: Oct 2010
Location: Fairfax

Posts: 70
iTrader: (0)

Hey guys, I have a very specific problem misfire problem.

I am getting a misfire on cylinder 6 only. I have swapped coils, and changed all plugs to no avail. The car feels and sounds like a cylinder is just not firing. If the misfire code is cleared, it will also come back right away. I need to have carbon cleaning done (66k miles and never been done).

This problem manifested itself on a 90 mile trip. It went from a slight hesitation, to full blown rough idling and service engine soon light in the last 50 miles of that trip.

1) I am assuming it is not the carbon build up causing this because it wouldn't cause catastrophic problems within 50 miles, right? It would take a few weeks, with misfires random at first, and hitting all the cylinders, not just Cylinder 6 like I am experiencing.

2) I am thinking now that it is probably the injector for Cylinder 6, does this sound right?

3) I did install the BMS OCC the day before the trip, but it was such a simple install, and I dont think messing with the PCV valve would cause a misfire right? Maybe I knocked the injector cable loose, when I installed, it since it does get installed right by Cylinder 6.

Anyone got any ideas?
Jhalf is offline  
0
Reply With Quote
      05-13-2013, 08:33 PM   #166
1nityrider
Private First Class
 
Drives: 2008 335xi
Join Date: Nov 2012
Location: St Paul

Posts: 158
iTrader: (0)

Quote:
Originally Posted by Jhalf View Post
Hey guys, I have a very specific problem misfire problem.

I am getting a misfire on cylinder 6 only. I have swapped coils, and changed all plugs to no avail. The car feels and sounds like a cylinder is just not firing. If the misfire code is cleared, it will also come back right away. I need to have carbon cleaning done (66k miles and never been done).

This problem manifested itself on a 90 mile trip. It went from a slight hesitation, to full blown rough idling and service engine soon light in the last 50 miles of that trip.

1) I am assuming it is not the carbon build up causing this because it wouldn't cause catastrophic problems within 50 miles, right? It would take a few weeks, with misfires random at first, and hitting all the cylinders, not just Cylinder 6 like I am experiencing.

2) I am thinking now that it is probably the injector for Cylinder 6, does this sound right?

3) I did install the BMS OCC the day before the trip, but it was such a simple install, and I dont think messing with the PCV valve would cause a misfire right? Maybe I knocked the injector cable loose, when I installed, it since it does get installed right by Cylinder 6.

Anyone got any ideas?
Your problem sounds kinda like mine. I am getting service engine light. Now seen half engine light. I am taking mine in Thursday, my guts it telling me it needs valve cleaning.
1nityrider is offline   United_States
0
Reply With Quote
      05-14-2013, 08:17 AM   #167
Jhalf
Private
 
Drives: 08 335i e92
Join Date: Oct 2010
Location: Fairfax

Posts: 70
iTrader: (0)

Quote:
Originally Posted by 1nityrider View Post
Your problem sounds kinda like mine. I am getting service engine light. Now seen half engine light. I am taking mine in Thursday, my guts it telling me it needs valve cleaning.
Could carbon cleaning problems manifest so quickly though?

Has anyone went from fine to very bad in 50 miles from carbon cleaning?

It can't be an injector though cause I would pull other codes though?
Jhalf is offline  
0
Reply With Quote
      05-16-2013, 07:56 AM   #168
Jhalf
Private
 
Drives: 08 335i e92
Join Date: Oct 2010
Location: Fairfax

Posts: 70
iTrader: (0)

Quote:
Originally Posted by Jhalf View Post
Could carbon cleaning problems manifest so quickly though?

Has anyone went from fine to very bad in 50 miles from carbon cleaning?

It can't be an injector though cause I would pull other codes though?
I took the car into the shop tuesday, and it ended up being a faulty 6 injector.

They replaced the injectors with 6 new part numbers, which are also warrantied separately for two more years.

Car runs like a champ now. I didn't think a completely faulty injector would only cause a misfire code, but I guess it did.
Jhalf is offline  
0
Reply With Quote
      05-16-2013, 08:09 AM   #169
Dinan_Bimmer
Private First Class
 
Drives: BMW
Join Date: May 2010
Location: NE USA

Posts: 177
iTrader: (4)

dealer said mine was the coil, so go figure...
__________________
Pete
2009 335i Sedan BMW PK, 19"s, BMW perf Body kit, JB4, CF rear wing, CF Mirror caps
Blue Water Metallic w/Oyster Inside
2009 CTS-V "Eleanor's worst nightmare" Crystal Red w/ Lt Platinum
Dinan_Bimmer is offline  
0
Reply With Quote
      05-16-2013, 08:11 AM   #170
Rich150001
Private
 
Drives: 07 335I & 09 R6
Join Date: Sep 2011
Location: Arlington (Ballston), Va

Posts: 78
iTrader: (0)

My car is idling rough after throwing a misfire in cylinder 4. I've changed the spark plugs yesterday and will try changing the coilpacks today. The car has 45k miles on it currently. Hopefully it works or I suppose my next steps are to either replace the injectors and/or perform walnut blasting.
Rich150001 is offline  
0
Reply With Quote
      05-16-2013, 11:29 AM   #171
Jhalf
Private
 
Drives: 08 335i e92
Join Date: Oct 2010
Location: Fairfax

Posts: 70
iTrader: (0)

Quote:
Originally Posted by Rich150001 View Post
My car is idling rough after throwing a misfire in cylinder 4. I've changed the spark plugs yesterday and will try changing the coilpacks today. The car has 45k miles on it currently. Hopefully it works or I suppose my next steps are to either replace the injectors and/or perform walnut blasting.
PM me if you need a good SA.
Jhalf is offline  
0
Reply With Quote
      05-16-2013, 03:48 PM   #172
1nityrider
Private First Class
 
Drives: 2008 335xi
Join Date: Nov 2012
Location: St Paul

Posts: 158
iTrader: (0)

Quote:
Originally Posted by Rich150001 View Post
My car is idling rough after throwing a misfire in cylinder 4. I've changed the spark plugs yesterday and will try changing the coilpacks today. The car has 45k miles on it currently. Hopefully it works or I suppose my next steps are to either replace the injectors and/or perform walnut blasting.
I took mine in today and they told me it was the intake vanos and low fuel pressure sensor. I told them to change the low fuel pressure sensor and I will change the vanos myself. I just bought the intake vanos but while waiting I will pull out the vanos and clean it.
1nityrider is offline   United_States
0
Reply With Quote
      05-16-2013, 03:58 PM   #173
fordperf
Private First Class
 
Drives: 2009 335xi LCI
Join Date: Feb 2012
Location: NJ

Posts: 155
iTrader: (0)

great thread! if anyone cares to follow my misfiring story on my 2009 it is here: http://www.e90post.com/forums/showthread.php?t=840983
fordperf is offline  
0
Reply With Quote
      05-16-2013, 09:07 PM   #174
Rich150001
Private
 
Drives: 07 335I & 09 R6
Join Date: Sep 2011
Location: Arlington (Ballston), Va

Posts: 78
iTrader: (0)

I'm pretty happy right now. Replacing the coil for cylinder 4 worked! The car is running great again.
Rich150001 is offline  
0
Reply With Quote
      06-03-2013, 01:22 PM   #175
alexwhittemore
Lieutenant Colonel
 
Drives: 2009 Crimson 328i
Join Date: Oct 2012
Location: Los Angeles

Posts: 1,526
iTrader: (0)

Quote:
Originally Posted by JETBLK335i View Post
Hi all. hope this is the right thread, but can anyone tell me if this chart looks ok?

im running proceed REV 2.5 and DCI.

im going to replace the spark plugs as a starting point, but i am throwing the following codes

CD87, 29CD, 29CF, 29CC, CDA7
My apologies for the thread revival, but how did you switch inpa to english? My technical German is nicht so heiße.
__________________
alexwhittemore is offline  
0
Reply With Quote
      06-24-2013, 04:08 PM   #176
BlackonRed
Registered
 
Drives: 2007 Black on Red E93
Join Date: Jun 2013
Location: Long Beach

Posts: 1
iTrader: (0)

I had a missfire issue running stage 2 with the Cobb Accessport 6 months ago. I changed the appropriate coil and it fixed the problem.
BlackonRed is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:59 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST