E90Post
 


PYSPEED
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > squealing or popping noise from rear brakes



Reply
 
Thread Tools Search this Thread
      05-10-2013, 07:06 AM   #1
geko29
Second Lieutenant
 
Drives: 2011 335d
Join Date: May 2012
Location: Illinois, USA

Posts: 247
iTrader: (2)

squealing or popping noise from rear brakes

Last night I picked up my wife from the airport, and on the way home, picked up a new noise. It was a loud shrieking noise from the right rear wheel. Based on last night and this morning's drives, it appears to happen most frequently at high speed (over 50mph), very low speed (when coming to a stop or starting from one) and when the suspension is unloaded (when making a right turn).

I'm not rubbing the fender or the shock/springs with the wheels, there's plenty of brake caliper clearance (running 19s), and the outboard pad has about half its material left. The retention clips look to be square and in the right place. I have had the "service due in 800 miles or in July 2014" for the rear brakes on the OBC since I bought the car roughly 8,000 miles ago, but it hasn't decremented, so I haven't paid attention.

One other bit I noticed this morning is when the car's parked, if I rock it gently forward and back, I hear the screech in both directions. This leaves me with two theories: 1) the pads are sticking, though I don't know why that'd also make noise at high speed, or 2) I got a rock stuck between the rotor and the rotor guard plate last night, and it's grinding on the rotor.

The only reason I think of the latter is that there was pretty nasty road construction around the airport last night, and I hit quite a few bad bumps and threw up a bunch of gravel.

Anybody got any ideas, or run into this before?
__________________
geko29 is offline  
0
Reply With Quote
      05-17-2013, 08:31 AM   #2
geko29
Second Lieutenant
 
Drives: 2011 335d
Join Date: May 2012
Location: Illinois, USA

Posts: 247
iTrader: (2)

Found the problem later that same day. Was flexing the rotor dust shield back to see if maybe it was contacting somewhere, heard something fall out, rocked the car, no screech.

Been a week since then, no more noise. I'm assuming it was a rock stuck between the dust shield and the rotor that was grinding.
__________________
geko29 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:12 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST