E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > Problems after washing engine



Reply
 
Thread Tools Search this Thread
      05-17-2013, 08:28 PM   #1
E90305
Second Lieutenant
 
Drives: 335i
Join Date: Feb 2009
Location: coral springs

Posts: 202
iTrader: (2)

Problems after washing engine

hey guys just bought the car 10 days ago , finally got to give her a good cleaning i washed the engine sprayed it down started the car was fine dryed it off and now service engine light is on and in limp mode . have no idea whats wrong im new to bmw and would like some insite if anyone has had this problem. thanks
its a 2008 335i with jb+ mod
E90305 is offline  
0
Reply With Quote
      05-17-2013, 08:32 PM   #2
dylim
Second Lieutenant
 
Drives: 328xi
Join Date: Mar 2012
Location: bay area

Posts: 240
iTrader: (3)

how did you wash it? did you cover the electronics/alternator etc? What code does the dash show?
dylim is offline  
0
Reply With Quote
      05-17-2013, 08:33 PM   #3
E90305
Second Lieutenant
 
Drives: 335i
Join Date: Feb 2009
Location: coral springs

Posts: 202
iTrader: (2)

yes i covered elec parts . it shows service engine soon light then goes to half engine light and says power reduced on my navi
E90305 is offline  
0
Reply With Quote
      05-17-2013, 09:13 PM   #4
litxus
Second Lieutenant
 
Drives: 09 E90 335i sedan
Join Date: Jan 2013
Location: North burbs, IL

Posts: 285
iTrader: (1)

I guess the question you need to ask is how did you wash the car? Did you use a pressure washer and hosed down everywhere? You need to be careful with that as you might short wires modules etc... I guess best would be to just blast with air gun everywhere to make sure you got all the water out and plug and blast with air any connections that could of got water.
litxus is offline  
0
Reply With Quote
      05-17-2013, 09:13 PM   #5
SHEEDI
Lieutenant Colonel
 
SHEEDI's Avatar
 
Drives: 2009 335i - Sport PKG
Join Date: Jun 2009
Location: NY

Posts: 1,644
iTrader: (0)

Garage List
2009 BMW 335i  [4.67]
can somebody take pics and mark parts to be covered in red, I am not sure what parts to cover and where they are. please post some pics

Thanks
__________________
SHEEDI is offline   United_States
0
Reply With Quote
      05-17-2013, 09:17 PM   #6
litxus
Second Lieutenant
 
Drives: 09 E90 335i sedan
Join Date: Jan 2013
Location: North burbs, IL

Posts: 285
iTrader: (1)

Quote:
Originally Posted by SHEEDI View Post
can somebody take pics and mark parts to be covered in red, I am not sure what parts to cover and where they are. please post some pics

Thanks
Sheed, I guess just use common sense and cover any electrical wiring / connections. Probably would be best to check with detail experts.
litxus is offline  
0
Reply With Quote
      05-17-2013, 11:59 PM   #7
E90305
Second Lieutenant
 
Drives: 335i
Join Date: Feb 2009
Location: coral springs

Posts: 202
iTrader: (2)

Hey guys I guess it was just a sensor my neighbor (just my luck ) is a mech at bmw so was very helpful lol he scanned at and it said was a intake sensor , he cleared it and all better probly a wet sensor .. Thank god
E90305 is offline  
0
Reply With Quote
      05-18-2013, 02:12 AM   #8
abrahambeckers
New Member
 
Drives: ALTO car
Join Date: May 2013
Location: india

Posts: 21
iTrader: (0)

I washed car with this engine wash spray bottle. I sprayed this on the engine and then let it sit for 10min and washed it with a garden that did not have a lot of pressure. Then I gave the car an entire 12 hours to dry up I washed car some time so car engine is easily worked.
__________________

Last edited by abrahambeckers; 05-28-2013 at 02:56 AM.
abrahambeckers is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:28 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST