E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Rain sensor & light sensor



Reply
 
Thread Tools Search this Thread
      05-24-2013, 10:00 PM   #1
Mr.Rnow
*_*809*_*
 
Mr.Rnow's Avatar
 
Drives: BMW E9x
Join Date: Apr 2013
Location: NYC & NJ

Posts: 104
iTrader: (0)

Rain sensor & light sensor

My rain sensor when crazy if i turn on my automatic wiper they start wiping air cause there is no rain....lol

And they lights wont turn off automatic when sun is out whats the problem?????
Mr.Rnow is offline   No_Country
0
Reply With Quote
      05-24-2013, 10:08 PM   #2
mike3000fl
Eleven Bravo
 
mike3000fl's Avatar
 
Drives: 06 330i
Join Date: Feb 2010
Location: ft bragg

Posts: 2,173
iTrader: (0)

Quote:
Originally Posted by Ktav0360 View Post
My rain sensor when crazy if i turn on my automatic wiper they start wiping air cause there is no rain....lol

And they lights wont turn off automatic when sun is out whats the problem?????
Problem sensor yes they issue have but go they do Ensure sensor they when dark.
__________________
2006 330i - Jet Black - 19" E46 M3 wheels - HR Sport - 199,000 Miles...

mike3000fl is offline  
0
Reply With Quote
      05-24-2013, 10:29 PM   #3
Mr.Rnow
*_*809*_*
 
Mr.Rnow's Avatar
 
Drives: BMW E9x
Join Date: Apr 2013
Location: NYC & NJ

Posts: 104
iTrader: (0)

Quote:
Originally Posted by mike3000fl
Quote:
Originally Posted by Ktav0360 View Post
My rain sensor when crazy if i turn on my automatic wiper they start wiping air cause there is no rain....lol

And they lights wont turn off automatic when sun is out whats the problem?????
Problem sensor yes they issue have but go they do Ensure sensor they when dark.
Do you know how much it cost to fix this?
Mr.Rnow is offline   No_Country
0
Reply With Quote
      05-24-2013, 10:37 PM   #4
VTECaddict
Where'd my VTEC go?
 
VTECaddict's Avatar
 
Drives: 06 330i 6MT
Join Date: Mar 2009
Location: Bakersfield, CA

Posts: 4,619
iTrader: (4)

When you press the A button, the wipers will wipe once no matter what. If it keeps wiping after that when there is no rain then there is a sensor problem.

For the headlights, how bright is it and how long is it in the sunlight before it turns off? Or does it never turn off in the sun? Make sure the switch is on A. And make sure you're not confusing DRLs with headlights. If you have DRLs turned on, they will be on whenever the main headlights are off.
__________________
AW/Terra | ZSP | ZPP | ZCW | iDrive | CA
Mods: BC BR | OEM Blacklines | M-tech rear | custom dual exhaust | M3 steering wheel | BMW SSK | ZHP shift knob | BMW Performance rep spoiler
Varrstoen ES1 19x9.5+20 Front, 19x11+25 rear
VTECaddict is offline  
0
Reply With Quote
      05-25-2013, 11:19 AM   #5
Viktimize
First Lieutenant
 
Drives: 2007 335i, 2002 325i
Join Date: Apr 2013
Location: Edmonton, Alberta, Canada

Posts: 375
iTrader: (0)

Quote:
Originally Posted by VTECaddict View Post
When you press the A button, the wipers will wipe once no matter what. If it keeps wiping after that when there is no rain then there is a sensor problem.

OR you have too much bugs on the windshield over the sensor, or it's just too dirty. First things first, do what's easy and cheap, clean the windshield where the sensor is. The sensor just send out light and looks for distortion, that causes the wipers to go. A lot of things can cause light distortion other than rain.
Viktimize is offline   Canada
0
Reply With Quote
      05-25-2013, 03:38 PM   #6
Mr.Rnow
*_*809*_*
 
Mr.Rnow's Avatar
 
Drives: BMW E9x
Join Date: Apr 2013
Location: NYC & NJ

Posts: 104
iTrader: (0)

Never turns off and they wiper at first they did wipe once and now no they keep wiping...

My drl are off the low beam are on always never turn of unless i turn the car off of course or the switch to 0 rather that ON
Quote:
Originally Posted by VTECaddict View Post
When you press the A button, the wipers will wipe once no matter what. If it keeps wiping after that when there is no rain then there is a sensor problem.

For the headlights, how bright is it and how long is it in the sunlight before it turns off? Or does it never turn off in the sun? Make sure the switch is on A. And make sure you're not confusing DRLs with headlights. If you have DRLs turned on, they will be on whenever the main headlights are off.
Mr.Rnow is offline   No_Country
0
Reply With Quote
      05-25-2013, 03:51 PM   #7
Dark_Knight_335
Came to the N55 Darkside
 
Dark_Knight_335's Avatar
 
Drives: 2011 335 E93 M-Sport
Join Date: May 2010
Location: NY/NJ

Posts: 10,360
iTrader: (27)

That damn rain sensor is useless, along with the useless speed rotator dial- which does absolute jack shit.
It's almost as bad as that stupid seatbelt Butler :
Dark_Knight_335 is offline   United_States
0
Reply With Quote
      05-26-2013, 02:31 AM   #8
SharkBait
Second Lieutenant
 
Drives: 2010 E92 335i
Join Date: Jan 2013
Location: Lost Angeles

Posts: 297
iTrader: (0)

Garage List
Quote:
Originally Posted by Ktav0360 View Post
Never turns off and they wiper at first they did wipe once and now no they keep wiping...

My drl are off the low beam are on always never turn of unless i turn the car off of course or the switch to 0 rather that ON
What the are you speak huh is the confusing language much.
SharkBait is offline  
0
Reply With Quote
      05-26-2013, 02:56 AM   #9
w2830
Private
 
Drives: 2008 E92 335I
Join Date: Dec 2012
Location: Canada

Posts: 65
iTrader: (0)

Quote:
Originally Posted by Dark_Knight_335 View Post
That damn rain sensor is useless, along with the useless speed rotator dial- which does absolute jack shit.
It's almost as bad as that stupid seatbelt Butler :

If you know how to code the car.you can turn the wiper into manual mode with four speed settings. I know which code it is if anyone interested.
w2830 is offline  
0
Reply With Quote
      05-26-2013, 06:21 PM   #10
simonsingh
Private
 
Drives: 325i e92, 2xe36
Join Date: Aug 2010
Location: Birmingham, UK

Posts: 88
iTrader: (0)

When did you change your wipers last? Apparently according the handbook they should be changed every 6 months, and cold weather can reduce their functionality.

I always notice that when I change my blades that the rain sensor works perfectly!
simonsingh is offline   United Kingdom
0
Reply With Quote
      05-26-2013, 07:45 PM   #11
Mr.Rnow
*_*809*_*
 
Mr.Rnow's Avatar
 
Drives: BMW E9x
Join Date: Apr 2013
Location: NYC & NJ

Posts: 104
iTrader: (0)

I going to have a year with the car in august i have not change my wiper blades
Quote:
Originally Posted by simonsingh View Post
When did you change your wipers last? Apparently according the handbook they should be changed every 6 months, and cold weather can reduce their functionality.

I always notice that when I change my blades that the rain sensor works perfectly!
Mr.Rnow is offline   No_Country
0
Reply With Quote
      08-08-2013, 06:52 PM   #12
charmin
New Member
 
charmin's Avatar
 
Drives: 320i M-Sport June 2009
Join Date: Sep 2012
Location: Hampshire UK

Posts: 20
iTrader: (0)

Quote:
Originally Posted by w2830 View Post
If you know how to code the car.you can turn the wiper into manual mode with four speed settings. I know which code it is if anyone interested.
Hi, yes I'd be interested in coding this, I use NCS and always looking for new codes...

Thanks
charmin is offline   United Kingdom
0
Reply With Quote
      12-20-2013, 10:56 PM   #13
Augster
Master Gunner
 
Drives: 2008 335i Sport
Join Date: Aug 2013
Location: Sandy Eggo

Posts: 384
iTrader: (0)

Garage List
Quote:
Originally Posted by w2830 View Post
If you know how to code the car.you can turn the wiper into manual mode with four speed settings. I know which code it is if anyone interested.
I'm interested in these codes.

My windshield wiper system is absolutely screwed up: the intermittent adjustment dial absolutely has no effect. It only responds to vehicle speed. If stopped, the wipers rest; if moving, the wipers move at a constant rate, the speed of which is determined by how many "clicks" I push the lever up.

Now, my condensation sensor appears to have been tampered with by the previous owner as it is not enclosed in the plastic T-shaped device but instead was stuck to the windshield with some thick, rubbery adhesive which no longer works thus the sensor just hangs loosely inside the mirror trim shell.

I'm not sure if this sensor has anything to do with my wiper issues (I don't think so, if it only checks for "condensation" to prevent wiper operation when there is no actual rain), or if the sensor embedded in the windshield has failed.

Regardless, I have a crack in the windshield so it's getting replaced, along with a new condensation sensor. But just in case neither of those resolves the issue, I'd rather just switch to "manual" mode; don't really need the "rain sensing" feature here in SoCal...

Hence, the codes por favor!
__________________
2008 335i Alpine White Sport Sedan AT | Avant Garde M364 Staggered 19"
Augster is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:47 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST