E90Post
 


VIBE Motorsports
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > bluetooth problem



Reply
 
Thread Tools Search this Thread
      06-01-2013, 07:45 AM   #1
mikeoz
Private First Class
 
Drives: bmw 335i
Join Date: Sep 2011
Location: cambs

Posts: 170
iTrader: (1)

bluetooth problem

Hi
I have a samsung galaxy s3 which pairs to my 07 e90 but the contactsbin the address book do not show on the idrive?
You can make calls but non addresses show, you must ring holding the phone then you can use the handsfree etc..
Any ideas why the contacts will not show?
Thanks
mikeoz is offline  
0
Reply With Quote
      06-01-2013, 12:17 PM   #2
Telly Addict
First Lieutenant
 
Telly Addict's Avatar
 
Drives: 2 wheels!
Join Date: Mar 2013
Location: Scotland

Posts: 305
iTrader: (5)

+1

I have the same phone/issue, is it an S3 thing or same for all phones?
Telly Addict is offline   United Kingdom
0
Reply With Quote
      06-02-2013, 07:11 AM   #3
mikeoz
Private First Class
 
Drives: bmw 335i
Join Date: Sep 2011
Location: cambs

Posts: 170
iTrader: (1)

Try this finally worked it out.
I found that you firstly need to make sure that the car can access the phone book. I did this by completing the pairing between car and phone as normal. Once this is done turn off the Bluetooth on the phone in the drop down menu from the home screen. The car then disconnects, then turn it back on and you'll get a pop up saying connecting. Once it connects then another popup asks for permission to access the phone. Check the box and hit yes.Now, to get the contact on the idrive you need to edit each individual contact and assign it to the group 'My Contacts'. (it may work with other groups i haven't tried)All my contacts were 'Not assigned' to a group so therefor not synced to the car.Once this is done, turn off the Bluetooth like above and turn on again and the car connects and you should see your contacts appear.I hope this works for you............
mikeoz is offline  
0
Reply With Quote
      06-02-2013, 12:21 PM   #4
Telly Addict
First Lieutenant
 
Telly Addict's Avatar
 
Drives: 2 wheels!
Join Date: Mar 2013
Location: Scotland

Posts: 305
iTrader: (5)

Edit each contact?? I have hundreds! Bleedin 'ell, that's going to take some time... well done for working it out though!
Telly Addict is offline   United Kingdom
0
Reply With Quote
      06-02-2013, 02:50 PM   #5
IanS100
Colonel
 
IanS100's Avatar
 
Drives: 320d LCI M Sport Plus
Join Date: Nov 2011
Location: Southport UK

Posts: 2,582
iTrader: (0)

Quote:
Originally Posted by Telly Addict View Post
Edit each contact?? I have hundreds! Bleedin 'ell, that's going to take some time... well done for working it out though!
I'm fairly sure if you select "all contacts" you can assign them to a group all in one go, pretty sure I've done it using Firefox.
IanS100 is offline   United Kingdom
0
Reply With Quote
      06-02-2013, 06:23 PM   #6
Telly Addict
First Lieutenant
 
Telly Addict's Avatar
 
Drives: 2 wheels!
Join Date: Mar 2013
Location: Scotland

Posts: 305
iTrader: (5)

Ah ok, we'll that would be a lot better.
Telly Addict is offline   United Kingdom
0
Reply With Quote
      06-03-2013, 09:16 AM   #7
Richardlkay
Private First Class
 
Richardlkay's Avatar
 
Drives: E90 320d M Sport
Join Date: Aug 2008
Location: Chorley, Lancashire

Posts: 115
iTrader: (0)

I had a similar issue with my Nexus 4. In the end, I rooted the phone and installed a custom ROM and hey presto, full contact sync and never fails to connect.
__________________
Rick - E90 320d M Sport|Sparkling Graphite|Grey Dakota Leather|Bluetooth|iPod/USB Connectivity|18" M Sport Alloys|Sun Protection glass

Richardlkay is offline   United Kingdom
0
Reply With Quote
      06-03-2013, 09:38 AM   #8
IanS100
Colonel
 
IanS100's Avatar
 
Drives: 320d LCI M Sport Plus
Join Date: Nov 2011
Location: Southport UK

Posts: 2,582
iTrader: (0)

I have over 300 contact names, all of then in "Contacts" only about 20 in "My Contacts" but they all show up on iDrive

To check out the Group theory, I added some new contacts but didn't assign them to ANY group. In Contacts under the Group Field on the SGS3 it states "Not Assigned" but they still showed up on the iDrive.

The only thing I found with a previous phone, an HTC, having lots of Contact "Notes" stopped them updating but I do have brief notes on many of the contacts & they haven't been affected.
IanS100 is offline   United Kingdom
0
Reply With Quote
      06-03-2013, 09:52 AM   #9
mikeoz
Private First Class
 
Drives: bmw 335i
Join Date: Sep 2011
Location: cambs

Posts: 170
iTrader: (1)

There seems to be different solutions for different people.
All I can say is that was the only way my phone showed up the contactsn on the idrive.
Had tried all other ideas suggested with no luck.
mikeoz is offline  
0
Reply With Quote
      06-03-2013, 02:33 PM   #10
IanS100
Colonel
 
IanS100's Avatar
 
Drives: 320d LCI M Sport Plus
Join Date: Nov 2011
Location: Southport UK

Posts: 2,582
iTrader: (0)

It may seem a bit drastic but it may be worth trying a factory reset & start again
IanS100 is offline   United Kingdom
0
Reply With Quote
      06-03-2013, 02:56 PM   #11
windymissile
Lieutenant
 
Drives: 335i M Sport
Join Date: Apr 2013
Location: UK

Posts: 554
iTrader: (0)

I have had similar dramas with my S3. I deleted the "pairing" from both sides and started again. Works now. Although every time I connect it takes a little time to load the contacts.

WM
windymissile is offline  
0
Reply With Quote
      06-03-2013, 05:30 PM   #12
IanS100
Colonel
 
IanS100's Avatar
 
Drives: 320d LCI M Sport Plus
Join Date: Nov 2011
Location: Southport UK

Posts: 2,582
iTrader: (0)

Quote:
Originally Posted by windymissile View Post
I have had similar dramas with my S3. I deleted the "pairing" from both sides and started again. Works now. Although every time I connect it takes a little time to load the contacts.

WM
My S3 is the same, loads the contacts every time which takes a while for 300+ The HTC was the worst though, that updated the contacts every few minutes
IanS100 is offline   United Kingdom
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:33 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST