E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Issues: Shaking at idle, white smoke at idle and acceleration, violent shaking



Reply
 
Thread Tools Search this Thread
      06-16-2013, 11:32 PM   #1
eamon
Captain
eamon's Avatar
32
Rep
790
Posts

 
Drives: 09 e92 335i, 2010 328i (sold)
Join Date: Oct 2010
Location: Dallas

iTrader: (0)

Arrow Issues: Shaking at idle, white smoke at idle and acceleration, violent shaking

Hey guys

Recently, about a couple months ago, I noticed my car having rough starts.
Felt like the power was there, but the car would start jerking (like hiccups) even while reversing for about a minute or two. After a minute of driving it seems to stop.

I didn't think much of the situation until a couple weeks ago when I noticed a little bit of smoke coming out of my tailpipes even before the car fully warmed up. The smoke has worsened and I can see it at night in my rearview when I give it gas if there is a car behind me with their lights shining.

And most recently, I left my car idling for 15 minutes and it started shaking violently and a "service engine soon" light came on, almost felt like it was spitting or cutting out power every couple seconds. As soon as I went to drive it continued jerking for 5 minutes. I had tried turning it on and off.

What could the problem be?

I had sparkplugs, oil, and basic maintenance completed only a few thousand miles ago.

Edit:
Extra details- Mods- Vishnu tune on map 1 and muffler delete, that is all
No codes except for the time my car idled for 15 min
__________________
black/black/black e92 loaded
Instagram: _eamon_

Last edited by eamon; 06-17-2013 at 12:37 AM.
Appreciate 0
      06-17-2013, 09:41 AM   #2
rismo
Captain
16
Rep
841
Posts

 
Drives: BMW E92 335
Join Date: Jul 2008
Location: Europe

iTrader: (0)

Shaking -> Either a dying HPFP or injectors/plugs/coils
Fumes -> Turbo's might be leaking but could also be caused by gasket issues around your engine.
As you have fumes during acceleration the chance is there that is caused by your turbo's.

What kind of oil do you use? I have had issues in the past by using BMW certified but too thin oil (0w30 and 0w40) and after using 5w40 again my smoke issues went away.
Also check if you have either white-is or black fumes and if you have oil residu around/in your exhaust tips.
half burned oil = white-is
burned = black BUT if "pure" black oil is dripping of your exhaust this could indicate that oil is leaking after your cylinders -> Possible turbo seals.

Anyway, dealer/mechanic time.... but check your oil type!
__________________
BMW 335 E92 08 - Full options - RIP
BMW 335 E92 09 - Full options - DKG - Procede Rev 3 - Vishnu Meth and Chargepipe - Forge Diverter Valves - Vishnu Flex Fuel Kit- AR Catless DP - Afe Intake - Helix IC - Ar Oil Cooler - PPK Water Cooler - M3 Suspension - JRZ RS1 Shocks - Eibach Pro Springs - Drexler LSD - BMW IS Exhaust - EBC Yellow Brake Pads - Stainless Steel Brake Lines - M101 Wheels - Michelin PSS - M-Tech Body - M-Strutbar
Appreciate 0
      06-17-2013, 10:39 AM   #3
Jeff@TopGearSolutions
BimmerPost Supporting Vendor
Jeff@TopGearSolutions's Avatar
United_States
246
Rep
18,427
Posts


 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

iTrader: (32)

Send a message via AIM to Jeff@TopGearSolutions
If you throw a Service engine soon light or any CEL you have codes. Not all generic scanners or code readers can read them though.

We are all just guessing but it sounds fuel related. Injectors, HPFP or LPFP.
Appreciate 0
      06-17-2013, 02:24 PM   #4
eamon
Captain
eamon's Avatar
32
Rep
790
Posts

 
Drives: 09 e92 335i, 2010 328i (sold)
Join Date: Oct 2010
Location: Dallas

iTrader: (0)

Quote:
Originally Posted by rismo View Post
Shaking -> Either a dying HPFP or injectors/plugs/coils
Fumes -> Turbo's might be leaking but could also be caused by gasket issues around your engine.
As you have fumes during acceleration the chance is there that is caused by your turbo's.

What kind of oil do you use? I have had issues in the past by using BMW certified but too thin oil (0w30 and 0w40) and after using 5w40 again my smoke issues went away.
Also check if you have either white-is or black fumes and if you have oil residu around/in your exhaust tips.
half burned oil = white-is
burned = black BUT if "pure" black oil is dripping of your exhaust this could indicate that oil is leaking after your cylinders -> Possible turbo seals.

Anyway, dealer/mechanic time.... but check your oil type!
I've been taking it to the dealer for oil changes as its still under warranty at 47k miles. I thought it was 5w-30 oil though. I also had my hpfp replaced less than 10k miles ago.
What do you mean by white"-is?"
I can't tell if the fumes are white or greyish but the exhaust tips are completely black inside and pretty dirty on the outside.
I also noticed a very slight clicking or tapping sound coming from around the car, not sure if its relevant.
Appreciate 0
      06-17-2013, 02:25 PM   #5
eamon
Captain
eamon's Avatar
32
Rep
790
Posts

 
Drives: 09 e92 335i, 2010 328i (sold)
Join Date: Oct 2010
Location: Dallas

iTrader: (0)

Quote:
Originally Posted by Jeff@TopGearSolutions View Post
If you throw a Service engine soon light or any CEL you have codes. Not all generic scanners or code readers can read them though.

We are all just guessing but it sounds fuel related. Injectors, HPFP or LPFP.
I have a PROcede tune on, I'm not sure, but I think it automatically clears the codes.
I also had my hpfp replaced just a few thousand miles ago after getting long cranks, I think.
Appreciate 0
      06-17-2013, 10:01 PM   #6
j1gilles
Lieutenant
j1gilles's Avatar
United_States
5
Rep
522
Posts

 
Drives: 2009 335xi
Join Date: Feb 2013
Location: Chicago

iTrader: (0)

Its infector(s) probably.... Scan it
__________________
ASE master tech (many moons ago)335xi- JB4 G5 iso/e30 Wedge flash/Custom meth/Borla mids/Custom x-pipe/DCI/ER charge pipe/Dual Ebay BOV's/Alpina B3 flash/Paddle shifter retro fit
Appreciate 0
      06-18-2013, 06:08 AM   #7
rismo
Captain
16
Rep
841
Posts

 
Drives: BMW E92 335
Join Date: Jul 2008
Location: Europe

iTrader: (0)

Quote:
Originally Posted by eamon View Post
I have a PROcede tune on, I'm not sure, but I think it automatically clears the codes.
I also had my hpfp replaced just a few thousand miles ago after getting long cranks, I think.
Procede will not clear engine issues, only tuner codes.
__________________
BMW 335 E92 08 - Full options - RIP
BMW 335 E92 09 - Full options - DKG - Procede Rev 3 - Vishnu Meth and Chargepipe - Forge Diverter Valves - Vishnu Flex Fuel Kit- AR Catless DP - Afe Intake - Helix IC - Ar Oil Cooler - PPK Water Cooler - M3 Suspension - JRZ RS1 Shocks - Eibach Pro Springs - Drexler LSD - BMW IS Exhaust - EBC Yellow Brake Pads - Stainless Steel Brake Lines - M101 Wheels - Michelin PSS - M-Tech Body - M-Strutbar
Appreciate 0
      06-19-2013, 11:32 AM   #8
eamon
Captain
eamon's Avatar
32
Rep
790
Posts

 
Drives: 09 e92 335i, 2010 328i (sold)
Join Date: Oct 2010
Location: Dallas

iTrader: (0)

bump
__________________
black/black/black e92 loaded
Instagram: _eamon_
Appreciate 0
      06-19-2013, 08:15 PM   #9
rismo
Captain
16
Rep
841
Posts

 
Drives: BMW E92 335
Join Date: Jul 2008
Location: Europe

iTrader: (0)

answers are given: Injectors, plugs,coils, but in case you have already replaced the HPFP, could be your injectors..
Have you inspected your plugs?
__________________
BMW 335 E92 08 - Full options - RIP
BMW 335 E92 09 - Full options - DKG - Procede Rev 3 - Vishnu Meth and Chargepipe - Forge Diverter Valves - Vishnu Flex Fuel Kit- AR Catless DP - Afe Intake - Helix IC - Ar Oil Cooler - PPK Water Cooler - M3 Suspension - JRZ RS1 Shocks - Eibach Pro Springs - Drexler LSD - BMW IS Exhaust - EBC Yellow Brake Pads - Stainless Steel Brake Lines - M101 Wheels - Michelin PSS - M-Tech Body - M-Strutbar
Appreciate 0
      06-19-2013, 09:29 PM   #10
eamon
Captain
eamon's Avatar
32
Rep
790
Posts

 
Drives: 09 e92 335i, 2010 328i (sold)
Join Date: Oct 2010
Location: Dallas

iTrader: (0)

Quote:
Originally Posted by rismo View Post
answers are given: Injectors, plugs,coils, but in case you have already replaced the HPFP, could be your injectors..
Have you inspected your plugs?
I'm thinking it is either turbo or injector related.
Plugs were replaced 2k miles ago.
I was kind of wondering if it would be a full turbo replacement or just the seals.

The only thing that worried me was when a tech I ran into told me it could be the seals for the cylinders which would be considered as a head job and take 20+ hours to fix. Going to take it in the next couple weeks.
__________________
black/black/black e92 loaded
Instagram: _eamon_
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:34 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST