E90Post
 


 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Australia > Anyone had their water pump die?



Reply
 
Thread Tools Search this Thread
      06-19-2013, 09:25 AM   #1
R3N
Private First Class
 
Drives: None
Join Date: Aug 2012
Location: Perth, Australia

Posts: 162
iTrader: (0)

Anyone had their water pump die?

Think mine just did tonight. Car is an 08 335i. Would have been 5 minutes into my trip and on the freeway doing 100, noticed car wasn't accelerating and got an engine overheat error message on the iDrive. Pulled over and shut off the engine. Left it for about 10-15 minutes and restarted. Cooland temp climbed from 100'C to 120'C pretty quick whiskt idling so shut it off again and got a tow truck.

I assume that the water pump has shat itself. Also, ambient air temp was about 12'C tonight.
R3N is offline   Australia
0
Reply With Quote
      06-19-2013, 05:22 PM   #2
drjekl
Captain
 
Drives: E92 335i
Join Date: Jan 2013
Location: Oz

Posts: 785
iTrader: (0)

Yeah it's a ccommon issue, do a search on here is a thread on it where cars are only a few years old and suffer from a failed pump (seems as common as the fuel pumps )
drjekl is offline  
0
Reply With Quote
      06-19-2013, 07:47 PM   #3
Zen
Lieutenant
 
Drives: E92 335i
Join Date: Nov 2008
Location: Sydney Aus

Posts: 586
iTrader: (0)

If you could hear the fan running overdrive while outside and inside your car then your waterpump had died.
__________________
08' E92 335I
Black Sapphire Metallic | M-Sport | GT-CS 19" Matte Anthracite | BMW Perf. Exhaust | JB4 | AR Design Catless DP | R1 Concepts Cross-drilled & Slotted Rotors | aFe DCI | ER Chargepipe with Forge DV | ER FMIC
Zen is offline   Australia
0
Reply With Quote
      06-19-2013, 10:11 PM   #4
Stuart@BMRAutowerkes
BimmerPost Supporting Vendor

 
Stuart@BMRAutowerkes's Avatar
 
Drives: a black car
Join Date: Sep 2010
Location: Sydney

Posts: 4,797
iTrader: (3)

I've sold a few waterpumps, pretty common maintenance item
Stuart@BMRAutowerkes is online now  
0
Reply With Quote
      06-19-2013, 10:47 PM   #5
dscOFF_funON
Private First Class
 
dscOFF_funON's Avatar
 
Drives: '08 335 Jet Black
Join Date: Jan 2013
Location: Atlanta, GA

Posts: 139
iTrader: (1)

Garage List
2008 BMW 335i  [0.00]
Same car with same symptoms, and it was the water pump. Read on here it was a good idea to replace thermostat with pump so had the dealership do both. Extended warranty covered pump but tstat was out of pocket. And yes, the fan was extremely loud, you can't mistake that.
dscOFF_funON is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:56 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST