E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > All-Wheel-Drive (Xi / xDrive) Talk > knocking noise Please Help



Reply
 
Thread Tools Search this Thread
      06-22-2013, 10:39 AM   #1
Tim603
Captain
 
Tim603's Avatar
 
Drives: 2007 328xi coupe
Join Date: Feb 2012
Location: Manchester Nh

Posts: 984
iTrader: (3)

Question knocking noise Please Help

Hey so out of nowhere i started hearing this knocking/ clicking noise while driving around town. When I accelerate i hear it click/knock and the same thing when i come to a stop or go over a big bump or something. It seems that when the inertia pulls the car back or pushes it forward, something in the suspension knocks.

Does this sound like a possible bushing/control arm/ tie rod problem?

Have any of you guys experienced this before? Im at about 120k miles.

Thanks for any input
__________________
Tim603 is offline   United_States
0
Reply With Quote
      06-22-2013, 06:22 PM   #2
lowcartel
Cat Wearing Glasses In Space
 
Drives: 06 325Xi Touring
Join Date: May 2013
Location: Mooresville

Posts: 62
iTrader: (0)

Garage List
I think I'm going through exactly what you're talking about. I'm taking my car to a shop on monday, I'll let you know what they tell me!
lowcartel is offline   United_States
0
Reply With Quote
      06-24-2013, 03:04 PM   #3
Tim603
Captain
 
Tim603's Avatar
 
Drives: 2007 328xi coupe
Join Date: Feb 2012
Location: Manchester Nh

Posts: 984
iTrader: (3)

Quote:
Originally Posted by lowcartel View Post
I think I'm going through exactly what you're talking about. I'm taking my car to a shop on monday, I'll let you know what they tell me!
Sounds good man, any update on what the problem is?
__________________
Tim603 is offline   United_States
0
Reply With Quote
      06-25-2013, 08:51 AM   #4
JaysBlueE92
Mr. Monaco
 
JaysBlueE92's Avatar
 
Drives: Slow..
Join Date: Sep 2008
Location: New Jersey

Posts: 3,973
iTrader: (9)

Garage List
2007 E92  [2.50]
sounds like sway bar end links
__________________
JaysBlueE92 is offline   United_States
0
Reply With Quote
      06-25-2013, 10:00 AM   #5
lowcartel
Cat Wearing Glasses In Space
 
Drives: 06 325Xi Touring
Join Date: May 2013
Location: Mooresville

Posts: 62
iTrader: (0)

Garage List
Quote:
Originally Posted by Tim603 View Post
Sounds good man, any update on what the problem is?
Have you done anything to your suspension lately?
lowcartel is offline   United_States
0
Reply With Quote
      06-25-2013, 06:56 PM   #6
Tim603
Captain
 
Tim603's Avatar
 
Drives: 2007 328xi coupe
Join Date: Feb 2012
Location: Manchester Nh

Posts: 984
iTrader: (3)

Quote:
Originally Posted by JaysBlueE92 View Post
sounds like sway bar end links
hmm okay if it is indeed that i hope its not too hard to replace.

Quote:
Originally Posted by lowcartel View Post
Have you done anything to your suspension lately?
I put KW V1 coil overs in probably like 8000 miles ago so if it was that i would imagine i would've started hearing it right away. What did your shop say?
__________________
Tim603 is offline   United_States
0
Reply With Quote
      06-26-2013, 09:44 AM   #7
AWD Addict
Chief Executive
 
AWD Addict's Avatar
 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

Posts: 2,483
iTrader: (1)

Garage List
2008 335xi  [0.00]
I have the same exact sound. Happens when rolling slowly over small bumps, or shifting the weight of the car in a stop/start.
AWD Addict is offline  
0
Reply With Quote
      06-26-2013, 10:38 AM   #8
Tim603
Captain
 
Tim603's Avatar
 
Drives: 2007 328xi coupe
Join Date: Feb 2012
Location: Manchester Nh

Posts: 984
iTrader: (3)

Quote:
Originally Posted by AWD Addict View Post
I have the same exact sound. Happens when rolling slowly over small bumps, or shifting the weight of the car in a stop/start.
isnt it so annoying, what do you think it could be?
__________________
Tim603 is offline   United_States
0
Reply With Quote
      06-26-2013, 10:47 AM   #9
akotten
Major
 
akotten's Avatar
 
Drives: 2007 335xi
Join Date: Mar 2011
Location: Rapid City, SD

Posts: 1,039
iTrader: (2)

I had a similar problem once. It ended up being the strut bar bolts not being torqued correctly. Mostly the big center one. Maybe something to check quick.
__________________
TC Kline S/A | Vorshlag Camber Plates | ///M Bushings & ARB | CP-e DPs | VRSF FMIC | Procede 2.5 w/ OpenFlash | DCI |
akotten is offline  
0
Reply With Quote
      06-26-2013, 10:53 AM   #10
Tim603
Captain
 
Tim603's Avatar
 
Drives: 2007 328xi coupe
Join Date: Feb 2012
Location: Manchester Nh

Posts: 984
iTrader: (3)

Quote:
Originally Posted by akotten View Post
I had a similar problem once. It ended up being the strut bar bolts not being torqued correctly. Mostly the big center one. Maybe something to check quick.
Really the strut bar huh? You dont mean the sway bars right? I put in a ecs tuning CF strut bar so I guess it could be that, I will check it out.
__________________
Tim603 is offline   United_States
0
Reply With Quote
      06-26-2013, 11:03 AM   #11
akotten
Major
 
akotten's Avatar
 
Drives: 2007 335xi
Join Date: Mar 2011
Location: Rapid City, SD

Posts: 1,039
iTrader: (2)

Quote:
Originally Posted by Tim603 View Post
Really the strut bar huh? You dont mean the sway bars right? I put in a ecs tuning CF strut bar so I guess it could be that, I will check it out.
Yeah, you could hear something "click" going over bumps, or when stressing the suspension at odd angles out of a driveway, for example.
__________________
TC Kline S/A | Vorshlag Camber Plates | ///M Bushings & ARB | CP-e DPs | VRSF FMIC | Procede 2.5 w/ OpenFlash | DCI |
akotten is offline  
0
Reply With Quote
      06-26-2013, 06:18 PM   #12
Tim603
Captain
 
Tim603's Avatar
 
Drives: 2007 328xi coupe
Join Date: Feb 2012
Location: Manchester Nh

Posts: 984
iTrader: (3)

Quote:
Originally Posted by akotten View Post
Yeah, you could hear something "click" going over bumps, or when stressing the suspension at odd angles out of a driveway, for example.
So I brought it to the dealer (at no charge thankfully) and they checked out my sway bar end links and they said they are nice and tight so thats not the problem, strut bar is also nice and tight so its not that. They said it could by my engine mount bushings but without spending some time diagnosing it its really hard to tell......great so thats gonna cost me $130 just to figure it out.
__________________
Tim603 is offline   United_States
0
Reply With Quote
      06-26-2013, 11:53 PM   #13
akotten
Major
 
akotten's Avatar
 
Drives: 2007 335xi
Join Date: Mar 2011
Location: Rapid City, SD

Posts: 1,039
iTrader: (2)

Quote:
Originally Posted by Tim603 View Post
So I brought it to the dealer (at no charge thankfully) and they checked out my sway bar end links and they said they are nice and tight so thats not the problem, strut bar is also nice and tight so its not that. They said it could by my engine mount bushings but without spending some time diagnosing it its really hard to tell......great so thats gonna cost me $130 just to figure it out.
Engine mounts? Already? That seems unlikely. What's your mileage?
__________________
TC Kline S/A | Vorshlag Camber Plates | ///M Bushings & ARB | CP-e DPs | VRSF FMIC | Procede 2.5 w/ OpenFlash | DCI |
akotten is offline  
0
Reply With Quote
      06-27-2013, 06:26 AM   #14
Doyle
Hellafunctional
 
Drives: 335xi
Join Date: Nov 2010
Location: N/A

Posts: 426
iTrader: (2)

Wheel hub bearings?
__________________
Go: Cobb S2+, Big Tom FMIC, CP-E DP & DCI, Royal Muffler, AR OC
Turn: TC Kline/Swift SA, Vorshlag Plates, UUC Front Bar, H&R M3 Rear Bar, VAC endlinks & spacers, Forgeline 18x9.5/NT05 265 Square
Stop: Endless MX72, Stoptech Rotors/Lines, Motul RBF600
Doyle is offline  
0
Reply With Quote
      06-27-2013, 01:37 PM   #15
Tim603
Captain
 
Tim603's Avatar
 
Drives: 2007 328xi coupe
Join Date: Feb 2012
Location: Manchester Nh

Posts: 984
iTrader: (3)

Quote:
Originally Posted by akotten View Post
Engine mounts? Already? That seems unlikely. What's your mileage?
121k

Quote:
Originally Posted by Doyle View Post
Wheel hub bearings?
if it was that I feel like I would hear it all the time, this only happens on occasion at slow speeds and also i noticed when in the morning when i havent driven my car all night i dont hear it untill i start driving it a bit.....mysterious i may just have to pay bmw to figure it out
__________________
Tim603 is offline   United_States
0
Reply With Quote
      06-27-2013, 02:03 PM   #16
akotten
Major
 
akotten's Avatar
 
Drives: 2007 335xi
Join Date: Mar 2011
Location: Rapid City, SD

Posts: 1,039
iTrader: (2)

Quote:
Originally Posted by Tim603 View Post
121k



if it was that I feel like I would hear it all the time, this only happens on occasion at slow speeds and also i noticed when in the morning when i havent driven my car all night i dont hear it untill i start driving it a bit.....mysterious i may just have to pay bmw to figure it out
Can you try to isolate where the noise is coming from? For example, front right corner, front left corner, front center, etc. Perhaps it is suspension related still.
__________________
TC Kline S/A | Vorshlag Camber Plates | ///M Bushings & ARB | CP-e DPs | VRSF FMIC | Procede 2.5 w/ OpenFlash | DCI |
akotten is offline  
0
Reply With Quote
      06-27-2013, 02:15 PM   #17
ajsalida
Lieutenant Colonel
 
ajsalida's Avatar
 
Drives: 95 M3, 02 R1150GSA, 09 335xi
Join Date: Aug 2010
Location: SW USA

Posts: 1,669
iTrader: (2)

With that kind of mileage and conditions you describe I would also look at main driveshaft(s), guibo, u-joints etc. in addition to CV joints.
ajsalida is offline  
0
Reply With Quote
      06-27-2013, 02:45 PM   #18
dbltakegs3
Private First Class
 
Drives: 2007 335i sedan a22
Join Date: Nov 2008
Location: Chi, IL

Posts: 137
iTrader: (1)

Garage List
2007 BMW 335i  [0.00]
Knocking

I'm haveing the same issue and its bothering the shit out of me. Let us know what you find out. I have Pss9 Coilovers.

I had a shop look at it, and they made me change my thruster/contorl arms and it still was not the problem. They are now saying its the upper strut mount.
dbltakegs3 is offline  
0
Reply With Quote
      06-27-2013, 04:21 PM   #19
Tim603
Captain
 
Tim603's Avatar
 
Drives: 2007 328xi coupe
Join Date: Feb 2012
Location: Manchester Nh

Posts: 984
iTrader: (3)

Quote:
Originally Posted by akotten View Post
Can you try to isolate where the noise is coming from? For example, front right corner, front left corner, front center, etc. Perhaps it is suspension related still.
Kind of hard to tell but I will try. For starters I can feel it in the floorboards, maybe up front

Quote:
Originally Posted by ajsalida View Post
With that kind of mileage and conditions you describe I would also look at main driveshaft(s), guibo, u-joints etc. in addition to CV joints.
I Replaced the clutch about 2k miles ago and the guibo and driveshafts are fine. I guess it could be the CV joints, not to sure about the U joints.

Quote:
Originally Posted by dbltakegs3 View Post
I'm haveing the same issue and its bothering the shit out of me. Let us know what you find out. I have Pss9 Coilovers.

I had a shop look at it, and they made me change my thruster/contorl arms and it still was not the problem. They are now saying its the upper strut mount.
I guess it could be the strut mount, kind of makes sense. I am bringing it into bmw in a few weeks if I cant figure it out, but either way I will keep you guys updated
__________________
Tim603 is offline   United_States
0
Reply With Quote
      07-08-2013, 04:43 PM   #20
AWD Addict
Chief Executive
 
AWD Addict's Avatar
 
Drives: 2008 335xi 6spd Coupe
Join Date: Dec 2007
Location: Boston

Posts: 2,483
iTrader: (1)

Garage List
2008 335xi  [0.00]
Quote:
Originally Posted by akotten View Post
Engine mounts? Already? That seems unlikely. What's your mileage?
Mine's definitely not engine mounts (and it doesn't sound like your's is either).

I think it's front end related. Ball joints, tie rod ends, something like that.
AWD Addict is offline  
0
Reply With Quote
      07-08-2013, 04:52 PM   #21
ajsalida
Lieutenant Colonel
 
ajsalida's Avatar
 
Drives: 95 M3, 02 R1150GSA, 09 335xi
Join Date: Aug 2010
Location: SW USA

Posts: 1,669
iTrader: (2)

I saw this video the other day, someone posted it up for diagnosing front end issues, maybe will help

ajsalida is offline  
0
Reply With Quote
      07-08-2013, 05:32 PM   #22
phozenstone
Brigadier General
 
phozenstone's Avatar
 
Drives: 2007 E92 Montego Blue
Join Date: Apr 2007
Location: NY

Posts: 4,858
iTrader: (71)

Quote:
Originally Posted by akotten View Post
I had a similar problem once. It ended up being the strut bar bolts not being torqued correctly. Mostly the big center one. Maybe something to check quick.
I have the same issue with a creaking in the firewall due to the large center strut bar bolt. Unfortunately I cannot find the right torx size to retorque it
__________________
E92 Xdrive / Montego Blue / M3 Black Novillo Leather / OEM 351M 19" Wheels / Mtech Rear w/ IS Diffuser / Aero Lip / LCI Tailights / M3 Steering Wheel w/Paddles / 40% Huper Optik / Lux V3 / 4300K HID Fogs / Dynavin N6 / 3 Stage Intake Manifold / Magnaflow Dual Exhaust Conversion 4" Tips / K&N Filter w/ charcoal delete / Active Autowerke Stage 2 Tune / KW V1 Coilovers / BMW Performance Strut Bar
phozenstone is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:52 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST