E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > E91 330i Box/Power Cutting Out



Reply
 
Thread Tools Search this Thread
      05-15-2013, 08:30 AM   #1
Swervin_Mervin
New Member
0
Rep
7
Posts

 
Drives: E91 330i
Join Date: May 2013
Location: UK

iTrader: (0)

E91 330i Box/Power Cutting Out

Hi all, been directed here with my problem and haven't found anything via search so here goes:

Had my 2006 E91 330i now since early Dec 2012 but it's developed a very annoying and potentially dangerous problem. At low speeds the 'box (or something else) seems to get confused and on application of the throttle it cuts all power dead!

Last week as I went to pull out of a layby I tried 4 times to set off. Foot off brake, car creeps, press throttle and it stops dead!

Local Indy previously reset a few things and it seemed to help but I can't keep having everything reset every month, so anyone any idea what's going on?

It's pretty serious when you're almost half out of a layby with a 44t Artic bearing down on you, or partway into a roundabout!
Appreciate 0
      05-15-2013, 09:59 AM   #2
ska///235i
***** noob
ska///235i's Avatar
United_States
193
Rep
9,206
Posts

 
Drives: M235i
Join Date: Sep 2005
Location: Boston

iTrader: (32)

Garage List
2006 325xi  [0.00]
Maybe Eccentric Shaft Sensor...pretty common on 2006 330s

http://www.e90post.com/forums/showthread.php?t=814611
Appreciate 0
      05-15-2013, 12:59 PM   #3
BoogeyMan'sBMW
Major
BoogeyMan'sBMW's Avatar
Bangladesh
18
Rep
1,380
Posts

 
Drives: SLOW
Join Date: Jun 2009
Location: Queens NY

iTrader: (3)

Can you be a bit more specific? Does the car/engine turn off or is the throttle just becoming unresponsive?
Appreciate 0
      05-15-2013, 03:27 PM   #4
Swervin_Mervin
New Member
0
Rep
7
Posts

 
Drives: E91 330i
Join Date: May 2013
Location: UK

iTrader: (0)

Engine doesn't shut off, no. It's almost like a severe Traction Control cutting in and just cutting all power. When I lifted back off the throttle it picked up drive again and started creeping.

This has only happened once from standstill I would say. Previously it's manifested itself on low speed turns at junctions (not sure what gear in would be in but my guess would be low speed in 2nd). In those instances it was a brief cut of power/drive and then it seemed to right itself and kick back in.

It happens maybe once every 1-2 weeks, so not on every journey.
Appreciate 0
      05-15-2013, 11:37 PM   #5
nate5ks
Captain
United_States
8
Rep
620
Posts

 
Drives: 2006 BMW 330xi
Join Date: Nov 2011
Location: Jacksonville Beach, FL

iTrader: (0)

Did the Indy mechanic scan for codes?
Appreciate 0
      05-16-2013, 04:06 AM   #6
Swervin_Mervin
New Member
0
Rep
7
Posts

 
Drives: E91 330i
Join Date: May 2013
Location: UK

iTrader: (0)

He did and I don't remember anything worth mentioning coming up. I seem to recall something about the Footwell Control Module but I'm sure that was something to do with it needing updating.

I'm dropping it in next week for them to hook it up and see if any codes come up.
Appreciate 0
      05-16-2013, 10:27 PM   #7
nate5ks
Captain
United_States
8
Rep
620
Posts

 
Drives: 2006 BMW 330xi
Join Date: Nov 2011
Location: Jacksonville Beach, FL

iTrader: (0)

Your FRM has nothing to do with this. It may need a DME software update.
Appreciate 0
      06-05-2013, 06:09 PM   #8
Swervin_Mervin
New Member
0
Rep
7
Posts

 
Drives: E91 330i
Join Date: May 2013
Location: UK

iTrader: (0)

Ok, quick update.

No fault codes. Only a couple of minor updates required e.g. PDC

The problem hadn't re-occurred at all though...until tonight. Went to enter a roundabout and bam, dead stop. So had to abort that entry and booted it at the next opportunity and slithered round like a lunatic!
Appreciate 0
      06-13-2013, 07:02 AM   #9
shotoverhill
New Member
0
Rep
9
Posts

 
Drives: E90 330i M Sport Saloon
Join Date: Apr 2013
Location: NW London

iTrader: (1)

This is exactly what has happened to me, mine is a May 2007 E90 Saloon 330i - any luck finding a solution?

Quote:
Originally Posted by Swervin_Mervin View Post
Engine doesn't shut off, no. It's almost like a severe Traction Control cutting in and just cutting all power. When I lifted back off the throttle it picked up drive again and started creeping.

This has only happened once from standstill I would say. Previously it's manifested itself on low speed turns at junctions (not sure what gear in would be in but my guess would be low speed in 2nd). In those instances it was a brief cut of power/drive and then it seemed to right itself and kick back in.

It happens maybe once every 1-2 weeks, so not on every journey.
Appreciate 0
      07-01-2013, 06:23 AM   #10
Swervin_Mervin
New Member
0
Rep
7
Posts

 
Drives: E91 330i
Join Date: May 2013
Location: UK

iTrader: (0)

None whatsoever so far chap!

Just done 2000mi in France and had it on a couple of occasions coming off roundabouts. Thankfully no one behind me!

Someone did suggest a tear in the MAF hose so I'm going to check that out myself. Otherwise could maybe just be a dodgy sensor that's on its way out but not enough to yet throw a fault?
Appreciate 0
      07-08-2013, 06:39 AM   #11
shotoverhill
New Member
0
Rep
9
Posts

 
Drives: E90 330i M Sport Saloon
Join Date: Apr 2013
Location: NW London

iTrader: (1)

I've been running Shell V Power and it has improved matters, at least I think so, but not eliminated altogether. If find a fault I'll post here to let you know, otherwise fingers crossed it doesn't happen turning right from a junction in front of fast approaching traffic.

Quote:
Originally Posted by Swervin_Mervin View Post
None whatsoever so far chap!

Just done 2000mi in France and had it on a couple of occasions coming off roundabouts. Thankfully no one behind me!

Someone did suggest a tear in the MAF hose so I'm going to check that out myself. Otherwise could maybe just be a dodgy sensor that's on its way out but not enough to yet throw a fault?
Appreciate 0
      07-08-2013, 07:01 PM   #12
StealYourFace
Major
United_States
15
Rep
1,183
Posts

 
Drives: 2006 330i sport
Join Date: Jul 2009
Location: Shakedown Street, Buffalo NY

iTrader: (1)

Does just the engine die, or does it lose all electrical power?
__________________
330i ~ BMW Perf. Susp. ~ M3 Front susp ~ BMW Perf Exhaust ~ 3.38 lsd ~ SF71 Alf CSL reps ~ Pilot Super Sports ~ AA Tune ~ 335is front brakes ~ over 150,000 miles hardly broken in! WTB: e93 M3 Front Sway Bar
Appreciate 0
      07-09-2013, 02:46 AM   #13
shotoverhill
New Member
0
Rep
9
Posts

 
Drives: E90 330i M Sport Saloon
Join Date: Apr 2013
Location: NW London

iTrader: (1)

Quote:
Originally Posted by StealYourFace View Post
Does just the engine die, or does it lose all electrical power?
Engine fails to respond, revs stay at tickover, almost like a severe and temporary 'limp home mode' which lasts for just a few seconds. Electrical power seems fine.

I'm still not sure if it's the engine or gearbox?
Appreciate 0
      07-09-2013, 03:54 AM   #14
Swervin_Mervin
New Member
0
Rep
7
Posts

 
Drives: E91 330i
Join Date: May 2013
Location: UK

iTrader: (0)

Yep, same here. It's like a severe Traction Control cutting in and generally (for me) only happens when the car is properly warmed up
Appreciate 0
      07-09-2013, 11:28 AM   #15
smellthebeans
Lieutenant Colonel
smellthebeans's Avatar
United_States
19
Rep
1,518
Posts

 
Drives: LPCs
Join Date: Dec 2006
Location: California Central Coast

iTrader: (2)

Garage List
2011 328i Coupe  [0.00]
1990 325i  [0.00]
Vanos sensors?

__________________
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:25 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST