E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > DIY [VIDEO] Repair DS Mode, Sport Mode on Steptronic Shifter



Reply
 
Thread Tools Search this Thread
      05-20-2013, 12:14 AM   #1
mike-y
just another bmw douche bag
United_States
77
Rep
3,576
Posts

Drives: 1.9L of fury
Join Date: Nov 2008
Location: Los Angeles, CA

iTrader: (4)

DIY [VIDEO] Repair DS Mode, Sport Mode on Steptronic Shifter

This is the SECOND time my DS went out on my car, so I bought a used shift assembly to swap mine out with.

While I was examining the spare shifter, I found out a way to extend the wire loom, and get you a lot more play to make repairs. Not only that, relocating the wire loom relieves a lot of the stress the wires would normally see when going in and out of DS operation. So hopefully, they won't break again!

I show how to do this on my spare shifter, but you can do everything from inside the car (I also did it on my existing shifter pretty easily while inside the car).

You'll need

- T30 Torx bit
- T9 Torx bit
- Flathead screwdriver.

I don't show the actual wire splicing, as pretty much everyone knows how to do that. But once you have the wire loom out, repairing the broken wires is a piece of cake.


Enjoy!

Appreciate 0
      05-29-2013, 10:54 AM   #2
trellis
27 Times
trellis's Avatar
1
Rep
91
Posts

Drives: e90 335i
Join Date: May 2011
Location: nj

iTrader: (0)

Thank you for making this video I'm going to attempt to repair mine tonight
__________________
JB+
Appreciate 0
      05-29-2013, 03:45 PM   #3
mlifxs
Diamond Geezer
mlifxs's Avatar
96
Rep
2,327
Posts

Drives: Jet Black 2007 328i Saloon
Join Date: Nov 2007
Location: Florida

iTrader: (6)

Garage List
Thanks, I've fixed mine once but fully expect it to fail in the future. I'll keep your video handy
__________________
AA Stage 2 - M3 control Arms FR - BMW PS2 - Dinan springs - APEX EC-7 - H&R front swaybar - Whiteline subframe inserts
Appreciate 0
      05-30-2013, 10:10 AM   #4
Imthatguy
Enlisted Member
United_States
1
Rep
41
Posts

Drives: 07 335i Coupe
Join Date: May 2013
Location: Mississippi Coast

iTrader: (0)

Garage List
Thanks for this great vid. Will be fixing this on mine soon.
Appreciate 0
      06-24-2013, 08:52 AM   #5
BMW86
Major General
Australia
198
Rep
9,163
Posts

Drives: CLA45 AMG Macan S
Join Date: Jul 2008
Location: Australia

iTrader: (0)

Thanks for the DIY video. The plastic cover that comes off the assembly is white not black on the E82. Mines all fixed now
Appreciate 0
      06-26-2013, 10:24 PM   #6
woodpecka
Major
woodpecka's Avatar
Canada
19
Rep
1,029
Posts

Drives: E91
Join Date: May 2010
Location: Montreal

iTrader: (2)

great diy!
Appreciate 0
      07-03-2013, 12:54 PM   #7
JaysBlueE92
Mr. Monaco
JaysBlueE92's Avatar
United_States
66
Rep
4,116
Posts

Drives: Slow..
Join Date: Sep 2008
Location: New Jersey

iTrader: (9)

Garage List
2007 E92  [2.50]
this was a huuuuuge help. I had the white wire problem many others experienced but all is good now thanks!
__________________
Appreciate 0
      07-10-2013, 10:26 PM   #8
pedrobmw
New Member
pedrobmw's Avatar
0
Rep
9
Posts

Drives: 2007 BMW 328xi
Join Date: Jul 2013
Location: Western MA

iTrader: (0)

Angry HELP! Yellow Exclamation in Gear symbol after DS Shifter Fix

Hi Mike-y,

Thanks so much for posting your video on how to repair the DS/Steptronic Shifter on an E90. I have a 2007 328xi and had the DS mode die on me (1 week after my CPO warranty expired, and BMW wouldn't fix it!). After reading all of the instructions from a previous post, and incorporating your modification about freeing up the wire loop to give it more slack, I thought I was good to go.

I opened the shifter console and discovered that 4 of 8 wires were completely severed, and the other 4 all had impending fractures where the insulation had been breached. I soldered and shrink-tubed all 8 wires, but I made the mistake of accidentally bumping my key back into the ignition slot (I didn't try to start the car), and the dashboard lights came on, with a yellow exclamation point in a notched circle. I immediately removed the key, completed the repairs, and reconnected everything. However, when I restarted the car, the same error appears, and I cannot move the gear shifter out of Park. Doh!

Have you come across this error in your efforts to repair and replace your shifter? If so, is there a way for me to clear it? My suspicion is that the error occured because the car ran some diagnostics when I bumped the key, with the wiring harnesses all disconnected, resulting in a fault code. I would have hoped that reconnecting everything and restarting the car would have cleared the fault, but I guess not. Any ideas???

Anyone with first-hand knowlege, please respond ASAP, as my car is dead in my garage right now...

Thanks,
pedrobmw
Appreciate 0
      07-11-2013, 09:12 AM   #9
pedrobmw
New Member
pedrobmw's Avatar
0
Rep
9
Posts

Drives: 2007 BMW 328xi
Join Date: Jul 2013
Location: Western MA

iTrader: (0)

Smile SOLVED: Yellow Exclamation Error after DS Mode Shifter Repair

After a sleepless night thinking that I had fried the electronic transmission circuits, I remembered a quick statement that Mike-y made in his video. This is important for anyone trying to perform his additional step of moving out the solenoid panel to remove the cable from the tortuous path that created the kinking and pressure points that ultimately caused the wires to break in the first place. This step was not included in the original fix by Tommiexboi (http://www.e90post.com/forums/showth...=447680&page=2), but is important at preventing future stress on the wires.

At 4:23 in Mike-y's video above, he states "After that's done, be sure that this post is still in the right spot." This is very important, and not as easy to see when the shifter is still attached to the car. As it turns out, if the pin in front of the solenoid is not placed around the post (as seen in the video), the solenoid cannot disengage the shift-lock, and the gear shifter will be stuck in Park. Also, the transmission control circuit will show the dreaded Yellow Exclamation Point in a Gear Symbol (circle with irregular border) error when starting the car.

After my soldering and shrink tubing work, I thought I had fried my transmission circuit, or at least created an error that I would have the dealer reset (which would have been impossible, as my car was stuck in Park!). However, after removing the center console again and removing the side panel from the shifter assembly, I was able to see that the solenoid pin was not around the post. Once I correctly positioned the pin (by rotating it 90 degrees coaxially), closed the side panel, and reconnected the wiring harnesses, the error cleared itself!

Here are the before and after pics, showing that 4 of the 8 wires were completely severed (VISIBLE ONLY AFTER REMOVING THE SIDE PANEL), and the other 4 wires all had insulation breaches (seen after removing the sticky black tape). I ended up soldering all 8 wires and shrink-tubing them, as none of the connections looked reliable. Because of Mike-y's trick of freeing the wire loop from the side panel track, there was enough slack on the connector end of the cut wires to directly solder them to the ends connected to the shifter. There was no need to splice any intervening wire! After soldering and shrink-tubing the joints, I grouped the wires with some electrical tape, and routed the cluster to the back and right of the shifter assembly. There was plenty of slack, to prevent future stress on the wires, I hope!

Hope this help, and thanks to both Tommiexboi and Mike-y for their fantastic work!

cheers,
pedrobmw
Attached Images
  
Appreciate 0
      07-17-2013, 07:30 PM   #10
mike-y
just another bmw douche bag
United_States
77
Rep
3,576
Posts

Drives: 1.9L of fury
Join Date: Nov 2008
Location: Los Angeles, CA

iTrader: (4)

Nice Pedro! Glad it worked out for ya.
Appreciate 0
      07-17-2013, 08:03 PM   #11
DUI Elite
///M at Heart
DUI Elite's Avatar
36
Rep
1,868
Posts

Drives: 06 SGM E90, 15 BSM E84
Join Date: Jan 2011
Location: Chicago, IL

iTrader: (4)

My DS and Manual mode work, but they seem glitchy at times. ex: Delay in shifting or the car ignores when I click up or down. Another ex: the car shifts for me when I have not clicked in either direction (nor am I near redline or heavy load).

What are the symptoms of the wires being damaged or stressed? I've done nearly 50k miles of manual mode driving and didn't even realize these wires could break.
__________________

| 3-IM | AA Headers | Eurocharged Stage-3 | BMW PI |
Appreciate 0
      07-18-2013, 11:10 AM   #12
mike-y
just another bmw douche bag
United_States
77
Rep
3,576
Posts

Drives: 1.9L of fury
Join Date: Nov 2008
Location: Los Angeles, CA

iTrader: (4)

Those are the same symptoms I had before I lost DS mode completely. Mostly, I'd go into manual mode and downshift to 3rd gear to merge on the freeway, and after a few seconds, it would upshift by itself back to 5th or 6th gear.
Appreciate 0
      07-18-2013, 12:15 PM   #13
DUI Elite
///M at Heart
DUI Elite's Avatar
36
Rep
1,868
Posts

Drives: 06 SGM E90, 15 BSM E84
Join Date: Jan 2011
Location: Chicago, IL

iTrader: (4)

Hmm I'll have to pull apart my console to check it out then.

Thanks for the reply. Feel like I learn something new on this car every day, even 7 years later.
__________________

| 3-IM | AA Headers | Eurocharged Stage-3 | BMW PI |
Appreciate 0
      07-19-2013, 04:13 PM   #14
EvlShiftrE92
Lieutenant Colonel
Nicaragua
49
Rep
1,568
Posts

Drives: 😈 2016/17 M2 😈
Join Date: Sep 2010
Location: Fontana Cali Speedway

iTrader: (4)

My car won't downshift thnx for the video simple fix but my wires are all good I did relieve stress to the wires by running them across but my car still won't downshift could it be a fuse any help apreciate it I want my baby to downshift
Appreciate 0
      07-23-2013, 07:44 PM   #15
EvlShiftrE92
Lieutenant Colonel
Nicaragua
49
Rep
1,568
Posts

Drives: 😈 2016/17 M2 😈
Join Date: Sep 2010
Location: Fontana Cali Speedway

iTrader: (4)

Stupid wire was broken inside lol problem fixed love the downshifts
Appreciate 0
      07-31-2013, 05:17 PM   #16
WhiteonWheat
Second Lieutenant
WhiteonWheat's Avatar
4
Rep
233
Posts

Drives: 2011 335i (AW e90 LCI)
Join Date: Feb 2011
Location: Atlanta

iTrader: (2)

So, this is what I've been experiencing with Manual Mode. I shift down and it will hold the gear, but JERKS some and then seems to go into a HIGHER gear without me telling it to. Is this what you guys 'deem' as a DS about to go out? If so - JEEZE..I have a 2011 e90 LCI with 16,700 some odd miles. Let me know what you guys think! Thanks! -WoW
Appreciate 0
      07-31-2013, 11:40 PM   #17
mike-y
just another bmw douche bag
United_States
77
Rep
3,576
Posts

Drives: 1.9L of fury
Join Date: Nov 2008
Location: Los Angeles, CA

iTrader: (4)

yep! well, not sure about the jerking part, but if it's shifting on it's own, that's a good sign that there is one (or more) broken wires.

There are like 7 or 8 wires in there, so symptoms may vary depending on which ones are broken.
Appreciate 0
      08-01-2013, 09:02 AM   #18
pedrobmw
New Member
pedrobmw's Avatar
0
Rep
9
Posts

Drives: 2007 BMW 328xi
Join Date: Jul 2013
Location: Western MA

iTrader: (0)

I agree with Mike-y. Probably a partial fracture that is intermittently making contact. Also known as a make-or-break connection. Given that it's a 2011 car, you should still be under warranty. I would just have them take a look at the shifter assembly. (Although, more likely, they will just replace the whole thing because they get paid by BMW to do the work.)

There are actually 10 wires, in groups of 8 and 2. The 2 wires (white and grey) that run FORWARD, toward the solenoid, don't appear to be under as much stress as the other 8, because they don't get stretched when one shifts into DS mode.

Good luck!
Appreciate 0
      08-15-2013, 11:20 PM   #19
JTWCT
Private First Class
JTWCT's Avatar
Taiwan
1
Rep
151
Posts

Drives: 09 328xi E92, 14 Cayenne GTS
Join Date: Dec 2011
Location: Fairfield County, Connecticut

iTrader: (3)

I think that a switch inside my steptronic shifter is broken... When I wiggled the shifter knob before in DS it would work. Also, when I wiggle the shifter know in P, R, N, or D the light that changes would turn on/off.
The DS mode would also work when I'm shifting halfway from D to DS but when it clicks in, DS turns off (see 0:05 of this video)

I took a look at it and there are no wires broken, however, now the DS doesn't work even when I shift and wiggle the knob around.

Could this be a broken switch inside?
Appreciate 0
      08-15-2013, 11:28 PM   #20
pedrobmw
New Member
pedrobmw's Avatar
0
Rep
9
Posts

Drives: 2007 BMW 328xi
Join Date: Jul 2013
Location: Western MA

iTrader: (0)

It might be a broken switch. But in your video, the light for the Steptronic DS mode briefly flashed on when you moved the shifter to the left. I think you have an intermittent contact, either from a fractured wire, or a broken shifter.

You didn't mention what model year your E90 is. Hopefully, it's covered under warranty. If not, I would take another look at the wires, specifically UNDER the black electrical tape that holds them together. I didn't see any breakages in my own car until I removed the wiring assembly from beneath the plastic cover, and then removed the black tape. This seems to be a common experience.

Good luck.



Quote:
Originally Posted by JTWCT View Post
I think that a switch inside my steptronic shifter is broken... When I wiggled the shifter knob before in DS it would work. Also, when I wiggle the shifter know in P, R, N, or D the light that changes would turn on/off.
The DS mode would also work when I'm shifting halfway from D to DS but when it clicks in, DS turns off (see 0:05 of this video)

I took a look at it and there are no wires broken, however, now the DS doesn't work even when I shift and wiggle the knob around.

Could this be a broken switch inside?
Appreciate 0
      08-15-2013, 11:35 PM   #21
JTWCT
Private First Class
JTWCT's Avatar
Taiwan
1
Rep
151
Posts

Drives: 09 328xi E92, 14 Cayenne GTS
Join Date: Dec 2011
Location: Fairfield County, Connecticut

iTrader: (3)

Thanks for the response. I have a 2008 BMW 328xi E92, so it's out of warranty. I inspected the wires and there's no broken wire to be seen or under the plastic wiring assembly. What do you mean by a broken shifter?



Quote:
Originally Posted by pedrobmw View Post
It might be a broken switch. But in your video, the light for the Steptronic DS mode briefly flashed on when you moved the shifter to the left. I think you have an intermittent contact, either from a fractured wire, or a broken shifter.

You didn't mention what model year your E90 is. Hopefully, it's covered under warranty. If not, I would take another look at the wires, specifically UNDER the black electrical tape that holds them together. I didn't see any breakages in my own car until I removed the wiring assembly from beneath the plastic cover, and then removed the black tape. This seems to be a common experience.

Good luck.
Appreciate 0
      08-15-2013, 11:53 PM   #22
pedrobmw
New Member
pedrobmw's Avatar
0
Rep
9
Posts

Drives: 2007 BMW 328xi
Join Date: Jul 2013
Location: Western MA

iTrader: (0)

If you're certain that it's not the wires, (That is, you've removed all the black electrical tape after the wiring harness has been pulled free from the black plastic and the electrical insulation around the wires is all intact, and there are no fractured wires), then I suppose it's possible that the shifter mechanism itself might be damaged. It is a mechanical part, after all, and might just be worn out or damaged. I don't think I'd be willing to try to take that apart, though, to fix it. Maybe Mike-y can weigh in on this one.

My dealer wanted to charge me $1000-$1100 for parts and labor to replace the shifter assembly, so I would make sure that you have exhausted other options before you spring for it.



Quote:
Originally Posted by JTWCT View Post
Thanks for the response. I have a 2008 BMW 328xi E92, so it's out of warranty. I inspected the wires and there's no broken wire to be seen or under the plastic wiring assembly. What do you mean by a broken shifter?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:15 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST