E90Post
 


VIBE Motorsports
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > SES light came on, got these codes



Reply
 
Thread Tools Search this Thread
      07-29-2013, 07:03 AM   #1
AndyR83
Major
43

 
AndyR83's Avatar
 
Drives: E92 335i FBO
Join Date: Oct 2011
Location: PA


Posts: 1,025
iTrader: (5)

SES light came on, got these codes

Last night my service engine soon light came on while driving home. My car has been FBO for about 9 months, with no new or recently changed performance mods since that time. Performance feels normal to me (no limp mode.)

Codes I read off of my JB4:
30
Just those two digits. When I set the JB4 to read codes it goes to 3, then 0, then the turn signals blink twice. I'm guessing this may not even be a code, just something related to theJB4. Sorry, no USB cable (yes, I know, I am bad and I should feel bad.)

2F6C
This appears to be because of the "golf tee mod" which was done over a year ago. Probably not new.

2C77
2C78

These both seem exhaust related according to my searches. I have catless dp's but I've had them installed since last August and have never seen these codes before today.

Any advice?

Thanks in advance. I have searched on this topic, but none of the situations I encountered seem to match my own (spontaneous SES light with no new mods recently)

Last edited by AndyR83; 07-29-2013 at 08:55 AM.
Appreciate 0
      07-29-2013, 07:31 AM   #2
Markyd83
Captain
23

 
Markyd83's Avatar
 
Drives: 335i coupe
Join Date: Apr 2010
Location: Chicago


Posts: 917
iTrader: (2)

Ill ask a stupid question but did you accidentally turn off auto clear?

Do you have the dp fix installed?

Mine has done that once in a while and then disappeared after a little more driving.
Appreciate 0
      07-29-2013, 08:05 AM   #3
TexE90
Banned
5

 
Drives: 2007 335i E90
Join Date: Nov 2012
Location: United States


Posts: 135
iTrader: (1)

The 30 "code" just means you have three codes stored.
Appreciate 0
      07-29-2013, 08:53 AM   #4
AndyR83
Major
43

 
AndyR83's Avatar
 
Drives: E92 335i FBO
Join Date: Oct 2011
Location: PA


Posts: 1,025
iTrader: (5)

Quote:
Originally Posted by Markyd83 View Post
Ill ask a stupid question but did you accidentally turn off auto clear?

Do you have the dp fix installed?

Mine has done that once in a while and then disappeared after a little more driving.
I was wondering about that after I got to work this morning. I can't imagine doing that by accident, but I was thinking I should go back in and verify that autoclear is in fact enabled.

I cleared the codes manually before driving to work this morning, and the light didn't come on during my approximately 25 mile commute.


Quote:
Originally Posted by TexE90
The 30 "code" just means you have three codes stored.
Great to know, thanks!
Appreciate 0
      07-29-2013, 03:47 PM   #5
Markyd83
Captain
23

 
Markyd83's Avatar
 
Drives: 335i coupe
Join Date: Apr 2010
Location: Chicago


Posts: 917
iTrader: (2)

Quote:
Originally Posted by AndyR83
Quote:
Originally Posted by Markyd83 View Post
Ill ask a stupid question but did you accidentally turn off auto clear?

Do you have the dp fix installed?

Mine has done that once in a while and then disappeared after a little more driving.
I was wondering about that after I got to work this morning. I can't imagine doing that by accident, but I was thinking I should go back in and verify that autoclear is in fact enabled.

I cleared the codes manually before driving to work this morning, and the light didn't come on during my approximately 25 mile commute.


Quote:
Originally Posted by TexE90
The 30 "code" just means you have three codes stored.
Great to know, thanks!
I wouldn't worry unless it reoccurs again. My car throws random codes once in a while and never again does it
Appreciate 0
      07-29-2013, 09:19 PM   #6
nc1mike
New Member
United_States
0

 
Drives: Red e90 335i Sport
Join Date: Apr 2012
Location: Granite Bay, CA.


Posts: 23
iTrader: (0)

Quote:
Originally Posted by AndyR83 View Post
Last night my service engine soon light came on while driving home. My car has been FBO for about 9 months, with no new or recently changed performance mods since that time. Performance feels normal to me (no limp mode.)

Codes I read off of my JB4:
30
Just those two digits. When I set the JB4 to read codes it goes to 3, then 0, then the turn signals blink twice. I'm guessing this may not even be a code, just something related to theJB4. Sorry, no USB cable (yes, I know, I am bad and I should feel bad.)

2F6C
This appears to be because of the "golf tee mod" which was done over a year ago. Probably not new.

2C77
2C78

These both seem exhaust related according to my searches. I have catless dp's but I've had them installed since last August and have never seen these codes before today.

Any advice?

Thanks in advance. I have searched on this topic, but none of the situations I encountered seem to match my own (spontaneous SES light with no new mods recently)
My car did exactly the same thing for a week then wham, engine fan on super extra high..Water pump failure.. Car wouldn't leave a code prior just occasionaly flash SES SES then go clear..
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:54 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST