E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > Engine reduce power fault 335i



Reply
 
Thread Tools Search this Thread
      08-01-2013, 12:01 PM   #1
mikeoz
Private First Class
 
Drives: bmw 335i
Join Date: Sep 2011
Location: cambs

Posts: 170
iTrader: (1)

Engine reduce power fault 335i

Hi
I have the reduce power symbol on again. I have had this before and they changed out the ignition coils they also mentioned it could be a seluniod?
Any one had this before have had all the ignition coils change in the last 2yrs so not sure what it could be this time??
Thanks
Mike
mikeoz is offline  
0
Reply With Quote
      08-01-2013, 12:13 PM   #2
Phil325i
Major
 
Phil325i's Avatar
 
Drives: E92 325i MSport Coupe
Join Date: Apr 2012
Location: UK South East

Posts: 1,093
iTrader: (0)

Garage List
Get someone to read your fault codes.
__________________
E92 pre-LCI 325i - Ohlins R&T; H&R spacers; M3 strut brace; Meyle HD droplinks; BMS clutch stop; BMS CDV; RE g/box mounts; Saikoumichi OCC; K&N; Cyba scoops; RM intake hose; BMW Perf Exhaust; M3 rear spoiler; LED Angels; BMW Perf black grille; CSL reps; SSDD carbon diffuser; Monster Wrap black roof
Phil325i is offline   United Kingdom
0
Reply With Quote
      08-01-2013, 12:30 PM   #3
mikeoz
Private First Class
 
Drives: bmw 335i
Join Date: Sep 2011
Location: cambs

Posts: 170
iTrader: (1)

Yes have done all that, car been at bmw a few times and they never seem sure...just wondering if any 1 else has had this?
mikeoz is offline  
0
Reply With Quote
      08-01-2013, 01:54 PM   #4
omaragha
Lieutenant Colonel
 
Drives: 335i DCT E93
Join Date: Mar 2009
Location: Windsor, UK

Posts: 1,827
iTrader: (4)

Yes, I have mate but I am running a JB4 - is your car modded ?

As per Phil you need to read the codes to find out whats the issue mate, only then can you pin point the fault. I am presuming you have the half engine yellow symbol ?

My diagnosis was related to a fecked charge pipe, you need to read the codes pal.
__________________
Engine Mods: JB4 G5 ISO, Wedge Flash, BMS DCI, ETS FMIC, ER CP, AR Catless DP's, BMS OCC, BMS Cowel filters & Forge DV's.
Running Gear Mods: Graphite Atomic CSL's, Birds B3 Suspension, Stoptech Grooved Rotors & Yellow Stuff pads.
Cosmetic: Performance Grill and Diffuser, Carbon Badges, Carbon Interior
omaragha is offline   United Kingdom
0
Reply With Quote
      08-01-2013, 02:07 PM   #5
mikeoz
Private First Class
 
Drives: bmw 335i
Join Date: Sep 2011
Location: cambs

Posts: 170
iTrader: (1)

Hi
Yes has emaps remap on it. And yes has the half yellow symbol. ?.Thats intresting tho...when I have previously had a similar problem the light goes off the next day but pings on again when cars hot and under hard acceleration. ?..
mikeoz is offline  
0
Reply With Quote
      08-03-2013, 06:36 PM   #6
m1bjr
LSD - No, you're not seeing things
 
m1bjr's Avatar
 
Drives: RS250 CUP
Join Date: Mar 2010
Location: Somerset UK

Posts: 3,313
iTrader: (4)

Send a message via MSN to m1bjr
HPFP getting weak?

A common one (and probably the solenoids they mention) are the cam positioners.
The cam timing (inlet and exhaust camshafts) are variable and controlled each by a solenoid and a high pressure oil feed.
(So there are two to go wrong , and they do, normally the oil galleries clog up inside)

When the cams are not where the computer expects them to be at any given time, you get a limp mode.
An error code is stored and its pretty accurate this one.
Often stop the engine, and start immediately and it clears....

There are a dozen other things however than can do it
__________________
m1bjr is offline   United Kingdom
0
Reply With Quote
      08-04-2013, 01:50 AM   #7
DanTheManc
Lieutenant
 
Drives: M135i
Join Date: Apr 2012
Location: Manchester

Posts: 404
iTrader: (1)

Quote:
Originally Posted by mikeoz View Post
Hi
Yes has emaps remap on it. And yes has the half yellow symbol. ?.Thats intresting tho...when I have previously had a similar problem the light goes off the next day but pings on again when cars hot and under hard acceleration. ?..
If hard acceleration is causing the car to go into reduced power mode, I'd guess it's a VANOS solenoid. That's just a guess though, you need to find out the fault codes.

If it is your VANOS solenoid (your car has two of these) then it's a cheap fix. I think the part is only 60ish from a Bmw dealer.
DanTheManc is offline  
0
Reply With Quote
      08-04-2013, 06:10 AM   #8
mikeoz
Private First Class
 
Drives: bmw 335i
Join Date: Sep 2011
Location: cambs

Posts: 170
iTrader: (1)

Hi
Thanks guys good advice. Car is under warranty so cost should not be a problem.
I have also heard about the solenoid vanos issue and of course the HPFP. They did say the last time that if it happened again they would look at changing both solenoids having replaced the ignition coils.

It does reset when car is switched off so may well be this.

Goes in on Tues so seen what happens.
mikeoz is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:37 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST