E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > 2007 335i iDrive and iPhone 4 Problems



Reply
 
Thread Tools Search this Thread
      08-29-2013, 10:37 AM   #1
bimmerdavid335
First Lieutenant
 
bimmerdavid335's Avatar
 
Drives: 2007 335i
Join Date: Mar 2013
Location: Sherwood, OR

Posts: 313
iTrader: (0)

2007 335i iDrive and iPhone 4 Problems

Hey all,

I did some searching and can't find anything related to my specific problem. I have a 2007 335i with iDrive and the iPod integration cable in the center console. When I connect the iPHone, it starts to come up, says reading device, then just quits. No error message or anything on the screen, and the phone shows that it is charging so I assume the connection is good.

Any ideas?
bimmerdavid335 is offline   United_States
0
Reply With Quote
      08-30-2013, 10:42 AM   #2
bimmerdavid335
First Lieutenant
 
bimmerdavid335's Avatar
 
Drives: 2007 335i
Join Date: Mar 2013
Location: Sherwood, OR

Posts: 313
iTrader: (0)

Bump... Any ideas?
bimmerdavid335 is offline   United_States
0
Reply With Quote
      08-30-2013, 09:21 PM   #3
tturbolife
Captain
 
tturbolife's Avatar
 
Drives: 07 335i e92 Jet Black
Join Date: May 2013
Location: Houston, Texas

Posts: 604
iTrader: (1)

Garage List
Quote:
Originally Posted by bimmerdavid335 View Post
Hey all,

I did some searching and can't find anything related to my specific problem. I have a 2007 335i with iDrive and the iPod integration cable in the center console. When I connect the iPHone, it starts to come up, says reading device, then just quits. No error message or anything on the screen, and the phone shows that it is charging so I assume the connection is good.

Any ideas?
do you know anyone with another ipod/iphone you can test with it?
__________________
2007 335i E92:
JZW Tune | Alpina B3 Flash | Orion V2.5 | Black Kidney/Mesh Grills/Window Trim | CSL Spoiler | V1 | 6000K HID Headlights/Fogs | Painted Reflectors | BMS Intake | CSL Style Wheels | CIC iDrive | M3 Steering Wheel | N55 Exhaust | Aero Lip | Combox/6NR
tturbolife is offline   United_States
0
Reply With Quote
      08-31-2013, 01:33 AM   #4
bimmerdavid335
First Lieutenant
 
bimmerdavid335's Avatar
 
Drives: 2007 335i
Join Date: Mar 2013
Location: Sherwood, OR

Posts: 313
iTrader: (0)

Quote:
Originally Posted by derekwilkinson View Post
do you know anyone with another ipod/iphone you can test with it?
I was about to update the thread. I took my old iPhone 3G out there and it worked fine. So I know the cable and everything is working ok... Now it's a phone issue. Wonder if the iOS version on the iPhone 4 is too high for my version of iDrive?
bimmerdavid335 is offline   United_States
0
Reply With Quote
      08-31-2013, 03:59 AM   #5
tony20009
Brigadier General
 
tony20009's Avatar
 
Drives: BMW 335i - Coupe
Join Date: Jun 2009
Location: Washington, DC

Posts: 4,381
iTrader: (0)

Theoretically the IP4 should work, but I think the IP4 is newer tech than your car's iDrive. It may be that you need a software update? Have you asked your BMW SA about this?

My F10 has the iDrive that followed the one in the '07 cars and my E92 doesn't have iDrive. FWIW, I had no problems with the IP4 on the newer iDrive in the F10 and it works fine in my E92, displaying my contacts without issue.

Good luck and all the best.
__________________
Cheers,
Tony

------------------------------------------------------------------------------------------
'07, e92 335i, Sparkling Graphite, Coral Leather, Aluminum, 6-speed
tony20009 is offline   United_States
0
Reply With Quote
      08-31-2013, 08:51 AM   #6
RallyRcrr
Lieutenant
 
Drives: 2007 BMW 335xi
Join Date: Apr 2009
Location: Tacoma, WA

Posts: 414
iTrader: (8)

I have an iphone 4 and 4s, and both have worked without any issues on the lastest firmware update. Have you tried removing the bluetooth settings from both the car and the phone?
RallyRcrr is offline   United_States
0
Reply With Quote
      08-31-2013, 10:16 PM   #7
bimmerdavid335
First Lieutenant
 
bimmerdavid335's Avatar
 
Drives: 2007 335i
Join Date: Mar 2013
Location: Sherwood, OR

Posts: 313
iTrader: (0)

Quote:
Originally Posted by tony20009 View Post
Theoretically the IP4 should work, but I think the IP4 is newer tech than your car's iDrive. It may be that you need a software update? Have you asked your BMW SA about this?

My F10 has the iDrive that followed the one in the '07 cars and my E92 doesn't have iDrive. FWIW, I had no problems with the IP4 on the newer iDrive in the F10 and it works fine in my E92, displaying my contacts without issue.

Good luck and all the best.
I haven't tried a software update yet... My car was in a couple months ago for the battery recall, would they have checked the software version then?

Quote:
Originally Posted by RallyRcrr View Post
I have an iphone 4 and 4s, and both have worked without any issues on the lastest firmware update. Have you tried removing the bluetooth settings from both the car and the phone?
I'm not trying over bluetooth, this is with the ipod dongle in the console, plugged into aux and the usb adapter.
bimmerdavid335 is offline   United_States
0
Reply With Quote
      08-31-2013, 10:49 PM   #8
tony20009
Brigadier General
 
tony20009's Avatar
 
Drives: BMW 335i - Coupe
Join Date: Jun 2009
Location: Washington, DC

Posts: 4,381
iTrader: (0)

Quote:
Originally Posted by bimmerdavid335 View Post
I haven't tried a software update yet... My car was in a couple months ago for the battery recall, would they have checked the software version then?...
If you didn't ask them to, most likely not.

They are in business and aren't going to go looking for trouble, after all. Service advisor is the title the guys you'll see at the BMW store have, but in their case, the word more accurately refers to them "advising" or telling you what they are going to do. They aren't acting like advisors to the President and making it a point to explore all angles of the situation -- you car -- and have contingencies for and address whatever might need fixing.

Of course, if they can find something that needs fixing and you pretty much have to fix it either now or later, they'll tell you about that because it's a revenue generating opportunity for the BMW store. Your nav's software isn't such a thing, but they'll be happy to update it for you if you mention it to them and charge you too if it's not a BMW-provided, free update...
__________________
Cheers,
Tony

------------------------------------------------------------------------------------------
'07, e92 335i, Sparkling Graphite, Coral Leather, Aluminum, 6-speed
tony20009 is offline   United_States
0
Reply With Quote
      09-02-2013, 08:18 PM   #9
tturbolife
Captain
 
tturbolife's Avatar
 
Drives: 07 335i e92 Jet Black
Join Date: May 2013
Location: Houston, Texas

Posts: 604
iTrader: (1)

Garage List
Make sure you have the latest software on your iPhone. If that doesn't work I'd try restoring the device
__________________
2007 335i E92:
JZW Tune | Alpina B3 Flash | Orion V2.5 | Black Kidney/Mesh Grills/Window Trim | CSL Spoiler | V1 | 6000K HID Headlights/Fogs | Painted Reflectors | BMS Intake | CSL Style Wheels | CIC iDrive | M3 Steering Wheel | N55 Exhaust | Aero Lip | Combox/6NR
tturbolife is offline   United_States
0
Reply With Quote
      09-04-2013, 12:43 AM   #10
bimmerdavid335
First Lieutenant
 
bimmerdavid335's Avatar
 
Drives: 2007 335i
Join Date: Mar 2013
Location: Sherwood, OR

Posts: 313
iTrader: (0)

Quote:
Originally Posted by derekwilkinson View Post
Make sure you have the latest software on your iPhone. If that doesn't work I'd try restoring the device
I think the problem is that the iOS version on the phone is too high and imcompatible. My 3G worked fine and is 4.X something.
bimmerdavid335 is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:05 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST