E90Post
 


PYSPEED
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > [Video Guide] Full BMW Coding Setup



Reply
 
Thread Tools Search this Thread
      08-13-2013, 10:44 PM   #111
TTurbo335
Second Lieutenant
 
TTurbo335's Avatar
 
Drives: BMW 335i
Join Date: Nov 2012
Location: So Cal

Posts: 204
iTrader: (2)

I am trying to read airbag module to double check cable is talking with car. I get this error message
Attached Images
 
TTurbo335 is offline   United_States
0
Reply With Quote
      08-15-2013, 10:38 AM   #112
hatton
Private First Class
 
hatton's Avatar
 
Drives: 2008 335i Coupe
Join Date: Jul 2013
Location: Zionsville IN/Ames IA

Posts: 112
iTrader: (0)

The resources.rar link has a pass on it?
hatton is offline   United_States
0
Reply With Quote
      08-15-2013, 10:44 AM   #113
jc_bmw
Private First Class
 
Drives: 2009 BMW 328i E90
Join Date: Jun 2013
Location: Markham, Ontario

Posts: 180
iTrader: (1)

Quote:
Originally Posted by hatton View Post
The resources.rar link has a pass on it?
E90
jc_bmw is offline   Canada
0
Reply With Quote
      08-15-2013, 11:31 AM   #114
hatton
Private First Class
 
hatton's Avatar
 
Drives: 2008 335i Coupe
Join Date: Jul 2013
Location: Zionsville IN/Ames IA

Posts: 112
iTrader: (0)

I also get this error: C:\EC-APPS\INPA\sgdat\MRS5.ipo(1) : error I300: Error opening object file

Already copied contents from:
C:\Users\Kyle Hatton\Desktop\Extracted Files Code\SP-daten v50.2 E89\ecu

To:
C:\EC-APPS\INPA\SGDAT

Deleted everything in SGDAT first.
hatton is offline   United_States
0
Reply With Quote
      08-15-2013, 12:11 PM   #115
BMW..
Lieutenant
 
Drives: E46 M3 /E90
Join Date: May 2013
Location: Boca Raton FL

Posts: 491
iTrader: (0)

Quote:
Originally Posted by hatton
I also get this error: C:\EC-APPS\INPA\sgdat\MRS5.ipo(1) : error I300: Error opening object file

Already copied contents from:
C:\Users\Kyle Hatton\Desktop\Extracted Files Code\SP-daten v50.2 E89\ecu

To:
C:\EC-APPS\INPA\SGDAT

Deleted everything in SGDAT first.
I added the sgdat folder in the OP
__________________
Mystic Blue E90
Phoenix Yellow E46
BMW.. is offline  
0
Reply With Quote
      08-16-2013, 02:53 PM   #116
hatton
Private First Class
 
hatton's Avatar
 
Drives: 2008 335i Coupe
Join Date: Jul 2013
Location: Zionsville IN/Ames IA

Posts: 112
iTrader: (0)

Did the alpina flash successfully. But when I loaded NCS Expert to try and code some things like key dong delete, the only profile available to load is ""default". Also the context menus are still all in german even after copying and pasting the new english .txt file.
hatton is offline   United_States
0
Reply With Quote
      08-25-2013, 07:36 AM   #117
Augster
Master Gunner
 
Drives: 2008 335i Sport
Join Date: Aug 2013
Location: Sandy Eggo

Posts: 372
iTrader: (0)

Garage List
I already did the 64bit BMW Standard Tools 2.12 install and English fix but the 5.06 INPA update I got wiped out my SP-Daten files and didn't know how to update with the full v89 version I found, but this video tutorial and it's BMW Coding Tool (which I was completely unaware existed and was needed but wasn't included nor mentioned anywhere I sourced the software and tutorials) is what finally got me a fully functional INPA package to work on my E90!

Many thanks
Augster is online now  
0
Reply With Quote
      08-25-2013, 09:45 AM   #118
BMW..
Lieutenant
 
Drives: E46 M3 /E90
Join Date: May 2013
Location: Boca Raton FL

Posts: 491
iTrader: (0)

Quote:
Originally Posted by Augster
I already did the 64bit BMW Standard Tools 2.12 install and English fix but the 5.06 INPA update I got wiped out my SP-Daten files and didn't know how to update with the full v89 version I found, but this video tutorial and it's BMW Coding Tool (which I was completely unaware existed and was needed but wasn't included nor mentioned anywhere I sourced the software and tutorials) is what finally got me a fully functional INPA package to work on my E90!

Many thanks
Glad to help!
__________________
Mystic Blue E90
Phoenix Yellow E46
BMW.. is offline  
0
Reply With Quote
      09-04-2013, 09:57 PM   #119
grantwoodOK
New Member
 
Drives: 2011 M3
Join Date: Aug 2013
Location: Edmond, OK

Posts: 5
iTrader: (0)

Quote:
Originally Posted by Marz11 View Post
I am trying to read airbag module to double check cable is talking with car. I get this error message
Anyone have a fix for this? I'm getting the same error after trying a clean install 3 times...


Last edited by grantwoodOK; 09-04-2013 at 10:05 PM.
grantwoodOK is offline   United_States
0
Reply With Quote
      09-04-2013, 10:00 PM   #120
TTurbo335
Second Lieutenant
 
TTurbo335's Avatar
 
Drives: BMW 335i
Join Date: Nov 2012
Location: So Cal

Posts: 204
iTrader: (2)

Quote:
Originally Posted by grantwoodOK View Post
Anyone have a fix for this? I'm getting the same error after trying a clean install 3 times...

basically for me.. INPA works, NCS Expert works. But the airbag step part doesn't. haha SKIP IT FTW or someone
TTurbo335 is offline   United_States
0
Reply With Quote
      09-05-2013, 04:00 AM   #121
cyrano
Banned
 
Drives: E61 530XD chipped
Join Date: Apr 2011
Location: Poland

Posts: 145
iTrader: (0)

Sorry but i assume you can read... It says you have different module of airbag that inpa is set up, try to enter airbags through entering e60/airbags or just update INPA
cyrano is offline   Poland
0
Reply With Quote
      09-05-2013, 06:41 AM   #122
grantwoodOK
New Member
 
Drives: 2011 M3
Join Date: Aug 2013
Location: Edmond, OK

Posts: 5
iTrader: (0)

Quote:
Originally Posted by cyrano View Post
Sorry but i assume you can read... It says you have different module of airbag that inpa is set up, try to enter airbags through entering e60/airbags or just update INPA
I'm using the latest files for INPA according to the first post. The car's an E93 so now I'm confused by your statement about.

Anyone else care to chime in?
grantwoodOK is offline   United_States
0
Reply With Quote
      09-05-2013, 06:55 AM   #123
cyrano
Banned
 
Drives: E61 530XD chipped
Join Date: Apr 2011
Location: Poland

Posts: 145
iTrader: (0)

Dont be confused just do what i tell... Try to do it what i wrote, in inpa choose e60 instead of e90 and then in table choose :



Are you sure you have proper new inpa ?? :

cyrano is offline   Poland
0
Reply With Quote
      09-05-2013, 08:11 AM   #124
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,254
iTrader: (5)

Send a message via Yahoo to cn555ic
I don't think too many people have the version you have!
cn555ic is offline   United_States
0
Reply With Quote
      09-05-2013, 08:50 AM   #125
grantwoodOK
New Member
 
Drives: 2011 M3
Join Date: Aug 2013
Location: Edmond, OK

Posts: 5
iTrader: (0)

Quote:
Originally Posted by cyrano View Post
Dont be confused just do what i tell... Try to do it what i wrote, in inpa choose e60 instead of e90 and then in table choose :


Are you sure you have proper new inpa ?? :
I have the INPA that's provided in the first post. If this isn't the latest please let me know when I can get it
grantwoodOK is offline   United_States
0
Reply With Quote
      09-05-2013, 02:03 PM   #126
cyrano
Banned
 
Drives: E61 530XD chipped
Join Date: Apr 2011
Location: Poland

Posts: 145
iTrader: (0)

Sorry i can't from - obvious reason.

Why not try to connect throuht E60 as i wrote before, im 75% sure ther will be right module to connect
cyrano is offline   Poland
0
Reply With Quote
      09-05-2013, 05:48 PM   #127
grantwoodOK
New Member
 
Drives: 2011 M3
Join Date: Aug 2013
Location: Edmond, OK

Posts: 5
iTrader: (0)

Quote:
Originally Posted by cyrano View Post
Sorry i can't from - obvious reason.

Why not try to connect throuht E60 as i wrote before, im 75% sure ther will be right module to connect
Tried it and it gave an error about missing module.

I then tried another module besides airbag and got the "Versions Do Not Match. Malfunction Possible ."
grantwoodOK is offline   United_States
0
Reply With Quote
      09-06-2013, 01:55 AM   #128
cyrano
Banned
 
Drives: E61 530XD chipped
Join Date: Apr 2011
Location: Poland

Posts: 145
iTrader: (0)

Quote:
Originally Posted by grantwoodOK View Post
I then tried another module besides airbag and got the "Versions Do Not Match. Malfunction Possible ."
Acctualy that was good module... just press ok and thats it you can read errors etc. version do not match its just small difference in INPA files and your software version nothing to worry about

Quote:
Originally Posted by cn555ic View Post
I don't think too many people have the version you have!
Well...
cyrano is offline   Poland
0
Reply With Quote
      09-17-2013, 10:27 AM   #129
nahyt
Enlisted Member
 
nahyt's Avatar
 
Drives: 2007 e92 335i
Join Date: Nov 2012
Location: Montreal, Qc

Posts: 49
iTrader: (0)

Garage List
2007 e92 335i  [5.00]
I don't know if I'm doing this right but last night I tried to code and I couldn't get it, it was as if it was coding the default settings. On one of the DIY guides I was following it says that you have to load the .MAN file from Load Profile but it was never there. I am able to get the TRC file, change the MAN file but can't get it written to the car Anyone want to point me in the right direction?

These are the steps I used more or less:
1. Load NCSExpert.
2. Load Profile and select Manipulate
4. F3 (ZCS/FA f .ECU)
5. Choose E89 (for the E9X)
6. Select CAS
7. F6 (BACK)
8. F4 (Process ECU)
9. Get the .TRC file in the Work Folder, Change it to .MAN
10. Change .MAN file using NotePad and save
11.Open NCSExpert and change job to SG_Codieren
12. If I remember correctly F3

All it does is recode the default settings, thanks for any help its much appreciated!
nahyt is online now   Canada
0
Reply With Quote
      09-17-2013, 01:25 PM   #130
Augster
Master Gunner
 
Drives: 2008 335i Sport
Join Date: Aug 2013
Location: Sandy Eggo

Posts: 372
iTrader: (0)

Garage List
Quote:
Originally Posted by nahyt View Post
I don't know if I'm doing this right but last night I tried to code and I couldn't get it, it was as if it was coding the default settings. On one of the DIY guides I was following it says that you have to load the .MAN file from Load Profile but it was never there.
I'm just starting off with playing around with INPA/NCS Expert, but I believe the "Load Profil" instruction is to load one of the User Profiles that is floating around the 'net. The User Profile is the permissions granted to that user to access features of NCS Expert; the default User Profile included with NCS Expert is very limited and you will not be able to accomplish the coding that is detailed in many DIY's.

The common User Profiles referenced here and there, may be "expert", "expertmode", "expertmodeMAN", "Man", and "revtors".

If you used the commonly available "INPA_502_Updated.rar" installer, this should have installed the necessary custom User Profiles to start coding. If not, then scour the internet, and once you locate and download these necessary profiles, place them in the "PFL" directory of NCS Expert.

Also, if you are using the 64-bit compatible version of NCS Expert that is installed with BMW Standard Tools 2.12, the profile formats have changed and you must locate v3 User Profiles to use with the 64-bit NCS Expert, such as "Fisterprofile".
Augster is online now  
0
Reply With Quote
      09-17-2013, 02:57 PM   #131
nahyt
Enlisted Member
 
nahyt's Avatar
 
Drives: 2007 e92 335i
Join Date: Nov 2012
Location: Montreal, Qc

Posts: 49
iTrader: (0)

Garage List
2007 e92 335i  [5.00]
Quote:
Originally Posted by Augster View Post
I'm just starting off with playing around with INPA/NCS Expert, but I believe the "Load Profil" instruction is to load one of the User Profiles that is floating around the 'net. The User Profile is the permissions granted to that user to access features of NCS Expert; the default User Profile included with NCS Expert is very limited and you will not be able to accomplish the coding that is detailed in many DIY's.

The common User Profiles referenced here and there, may be "expert", "expertmode", "expertmodeMAN", "Man", and "revtors".

If you used the commonly available "INPA_502_Updated.rar" installer, this should have installed the necessary custom User Profiles to start coding. If not, then scour the internet, and once you locate and download these necessary profiles, place them in the "PFL" directory of NCS Expert.

Also, if you are using the 64-bit compatible version of NCS Expert that is installed with BMW Standard Tools 2.12, the profile formats have changed and you must locate v3 User Profiles to use with the 64-bit NCS Expert, such as "Fisterprofile".
I've tried it on 2 separate laptops, one was 64-bit the other was 32-bit, I used the manipulate profile rather than the expert mode profile. Should I have used expert mode instead? Also could I use the new user profiles (Fisterprofile) even with a 32-bit system? And if it helps I used the tutorial on the first post to set up ncsexpert
nahyt is online now   Canada
0
Reply With Quote
      09-17-2013, 03:03 PM   #132
Augster
Master Gunner
 
Drives: 2008 335i Sport
Join Date: Aug 2013
Location: Sandy Eggo

Posts: 372
iTrader: (0)

Garage List
Quote:
Originally Posted by nahyt View Post
I've tried it on 2 separate laptops, one was 64-bit the other was 32-bit, I used the manipulate profile rather than the expert mode profile. Should I have used expert mode instead?
I believe you need a "hacked" version of the NCS Expert in order to create and modify User Profiles, from what I've read.

"expert mode" is a custom User Profile that you must locate on the 'net if it wasn't installed with NCS Expert.

Quote:
Originally Posted by nahyt View Post
Also could I use the new user profiles (Fisterprofile) even with a 32-bit system? And if it helps I used the tutorial on the first post to set up ncsexpert
The v3 User Profiles should work with either 32-bit or 64-bit of the 64-bit compatible version of NCS Expert. I doubt they would work with any previous versions of NCS Expert as they would utilize the v2 format.
Augster is online now  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:52 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST