E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Stumbling RPMs, No service lights, whistling sound



Reply
 
Thread Tools Search this Thread
      09-19-2013, 09:43 AM   #1
Smashbrown
New Member
United_States
0
Rep
9
Posts

 
Drives: 2007 e90 328xi sedan
Join Date: Feb 2007
Location: NJ

iTrader: (0)

Stumbling RPMs, No service lights, whistling sound

Alright. I've been chasing this problem for almost a year already. I think I'm getting close to a solution but hopefully someone here can give some insight.

The problem does not happen all the time. It's been running fine for months but in the past week the car's been exposed to 2 extremely humid days, followed by a heavy rain and now a string of cold (<50 degrees) in that order.

I drive mostly highway (40 mile commute to work) averaging 65-75MPH. I will sometimes feel a 'bump' or a rev which usually indicates that I've induced the problem which I won't see until there's no compression in the engine aka low speed. This really sucks when I have to traverse through a hilly neighborhood (6 speed MT) or have to pull in anywhere! This is also always accompanied by a whistle. Also, most of my driving is around 7/8am and 4-8PM.

Symptoms:
Stumbling RPM
Erratic idle at low speed
Whistle
Power loss

Things I've done:
Plugs/Coils
Valve cover gasket
Inspected Air filter components and replaced filter.

Findings. none! I'm thinking this is a PCV/CCV/Oil separator issue. It's not throwing codes but in the rare instance it does, by the time I can get it somewhere, it clears up (there were some cam sensor alerts but those are getting replaced).

I can't find any in depth postings on the N52 PCV/CCV/Oil separator. I called a few places including the dealerships and I'm getting conflicting info. sort of. I guess I need someone to explain it this to me with vocabulary I can comprehend.

example: The PCV is built into the valve cover. OK but I've seen PCV service kits out there for this engine. What does that mean? I can change the hoses and connectors but does that fix the issue? I wouldn't think so.

Then I see all these vids and postings of PCV replacements for a bunch of other models!!

I got some good info from some of the vendors especially ECS Tuning. I just want to see if anyone else has gone through this or has anything to contribute.
Appreciate 0
      09-19-2013, 10:08 AM   #2
karlp
Private First Class
1
Rep
116
Posts

 
Drives: 325i SE
Join Date: Sep 2013
Location: Hull

iTrader: (0)

Get the Vanos inlet checked as this can become sticky and upset the timing throwing the cylinders out of sync.
see here dude
http://www.e90post.com/forums/showthread.php?t=486201
Appreciate 0
      09-19-2013, 10:35 AM   #3
Smashbrown
New Member
United_States
0
Rep
9
Posts

 
Drives: 2007 e90 328xi sedan
Join Date: Feb 2007
Location: NJ

iTrader: (0)

I did come across that post previously. That will be next! Thanks for that.
Appreciate 0
      09-19-2013, 11:22 AM   #4
frankg11
Private
0
Rep
58
Posts

 
Drives: 2012 335is
Join Date: Sep 2012
Location: Seattle

iTrader: (0)

Don't forget the Mas air sensor. I just had mine go out...
Appreciate 0
      09-19-2013, 09:09 PM   #5
VTECaddict
Where'd my VTEC go?
VTECaddict's Avatar
47
Rep
4,628
Posts

 
Drives: 06 330i 6MT
Join Date: Mar 2009
Location: Bakersfield, CA

iTrader: (4)

Check the eccentric shaft sensor.
__________________
AW/Terra | ZSP | ZPP | ZCW | iDrive | CA
Mods: BC BR | OEM Blacklines | M-tech rear | custom dual exhaust | M3 steering wheel | BMW SSK | ZHP shift knob | BMW Performance rep spoiler
Varrstoen ES1 19x9.5+20 Front, 19x11+25 rear
Appreciate 0
      09-19-2013, 09:24 PM   #6
YGazis109
Yiannis Gazis
YGazis109's Avatar
United_States
4
Rep
484
Posts

 
Drives: 2007 328xi
Join Date: Jul 2012
Location: Somers, CT

iTrader: (1)

Garage List
2007 BMW 328xi  [5.00]
I have the exact same thing happening to my car it is really annoying...I was getting a loud whistle noise 3-4 times with power loss a couple weeks ago, but that seemed to go away...but I still have the studder or stumble at low rpms...this happens especially when I get in traffic and need to slowly accelerate and goes away once my car picks up more speed...
Appreciate 0
      09-20-2013, 07:38 AM   #7
Smashbrown
New Member
United_States
0
Rep
9
Posts

 
Drives: 2007 e90 328xi sedan
Join Date: Feb 2007
Location: NJ

iTrader: (0)

I'm replacing the cam sensors and installing the pcv maintenance kit (all from ECS Tuning) today. I'll post with the results after the weekend. The hardest part about all this is that there weren't any codes being thrown out (It happens maybe 1 out of 10 times and triggers a faulty cam sensor code) and it randomly happens, but has been happening more with the climate change.

stay tuned...
Appreciate 0
      09-20-2013, 04:21 PM   #8
Smashbrown
New Member
United_States
0
Rep
9
Posts

 
Drives: 2007 e90 328xi sedan
Join Date: Feb 2007
Location: NJ

iTrader: (0)

Update*

Parts replaced:

both cam sensors and pcv maintenance kit.

environment: low humidity, 75 degrees, low humidity (61%).

Right away felt the power i was missing. It is a nice day and this usually acts up after a hard rain, cold temp or high humidity. It's supposed to rain this weekend so i'll post another update next week. Unfortunately, I do not have a before video as an example but here's a picture of the 90 degree connector that was replaced for a location reference for any one else with a similar problem. The rest of the kit is just a replacement hose.

http://www.ecstuning.com/BMW-E90-328...Pcv/ES2682266/
Attached Images
  
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:12 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST