E90Post
 


VIBE Motorsports
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Vehicle electronics failure?



Reply
 
Thread Tools Search this Thread
      09-21-2013, 06:56 PM   #1
alexx03
Lieutenant
4
Rep
426
Posts

 
Drives: 2007 BMW 335I
Join Date: Jun 2012
Location: Vaughan

iTrader: (2)

Vehicle electronics failure?

so i was driving today and the ABS light,DSC light(as if you were holding it tho,all systems off) and the light that comes on when you raise your e-brake came on in yellow.(6MT)
i got to a friends house and checked the manual and it says vehicle electronics failure....
the weird thing is that it all keeps going on and off, it did it like 4-5 times now.

i tried to search up something but i got mixed solutions. 1 thread said they unplugged the battery for 20 minutes and all was good, another said it was a rear wheel bearing that has some sensors on it,another said they had to replace the entire battery and the worst story was one about some 2400$ ABS pump!!
any help would be greatly appreciated!
i just lowered my car on BC coilovers and got an alignment yesterday if that helps.


EDIT

now im confused....in the manual it says when you have a red car on a lift and then the ABS light,DSC light(as if you were holding it tho,all systems off) and the light that comes on when you raise your e-brake came on in yellow(6MT) on your dash it is vehicle electronics failure.

but then it also says when you have the ABS light on where the red car on the lift would be with the ABS light,DSC light(as if you were holding it tho,all systems off) and the light that comes on when you raise your e-brake came on in yellow(6MT) BUT ALSO the flat tire monitor light comes up on the dash that it could be driver stability control systems including ABS,Xdrive, and flat tire monitor have failed.

the problem is that the exact configuration of lights i have on is not in the manual, i have the ABS light in the center screen(where the red cor on lift would be) and on the dash i only have ABS,DSC light(all functions off symbol,circle and triangle with !) and the e-brake light in yellow. no flat tire monitor light. the flat tire monitor light only shows up when i go through the check control menu with the BC stalk on the left side.

im seriously confused now,sorry for the long ass posts but im trying to give the best detail possible so i can get some help and try myself before going to a shop or worst the STEALERship

car is a 07 335i e92 FBO JB4 if it helps!
Appreciate 0
      09-21-2013, 07:17 PM   #2
ctuna
Brigadier General
45
Rep
4,338
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

The first thing to check battery voltage and alternator voltage

The first thing to check battery voltage and alternator voltage.

If you are still on your stock battery you are probably due for one.
Low voltage and current will cause the electronics to go nuts.
Appreciate 0
      09-21-2013, 07:50 PM   #3
alexx03
Lieutenant
4
Rep
426
Posts

 
Drives: 2007 BMW 335I
Join Date: Jun 2012
Location: Vaughan

iTrader: (2)

Quote:
Originally Posted by ctuna View Post
The first thing to check battery voltage and alternator voltage.

If you are still on your stock battery you are probably due for one.
Low voltage and current will cause the electronics to go nuts.
okay i will see if any friends have voltmeter or something to check that with.
and yes i am still on the factory battery of an 01/07 build date car
Appreciate 0
      09-21-2013, 08:28 PM   #4
ctuna
Brigadier General
45
Rep
4,338
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

If the battery reads low put a charge on it.

If the battery reads low put a charge on it.
Before you change it out to
verify that is your problem.

https://wiki.bentleypublishers.com/d...mentArea=true#

As you can see from the above error code list the same symbols can have
multiple meanings.
If you disconnect the battery you may get some errors that will go away once you drive the car about a block.

Last edited by ctuna; 09-22-2013 at 12:18 AM.
Appreciate 0
      09-22-2013, 09:15 AM   #5
alexx03
Lieutenant
4
Rep
426
Posts

 
Drives: 2007 BMW 335I
Join Date: Jun 2012
Location: Vaughan

iTrader: (2)

Quote:
Originally Posted by ctuna View Post
If the battery reads low put a charge on it.
Before you change it out to
verify that is your problem.

https://wiki.bentleypublishers.com/d...mentArea=true#

As you can see from the above error code list the same symbols can have
multiple meanings.
If you disconnect the battery you may get some errors that will go away once you drive the car about a block.
awesome thanks for the help!
Appreciate 0
      09-23-2013, 11:00 PM   #6
alexx03
Lieutenant
4
Rep
426
Posts

 
Drives: 2007 BMW 335I
Join Date: Jun 2012
Location: Vaughan

iTrader: (2)

speed sensor
Appreciate 0
      09-23-2013, 11:24 PM   #7
ctuna
Brigadier General
45
Rep
4,338
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

More explanation please.

More explanation please.
Appreciate 0
      09-23-2013, 11:37 PM   #8
alexx03
Lieutenant
4
Rep
426
Posts

 
Drives: 2007 BMW 335I
Join Date: Jun 2012
Location: Vaughan

iTrader: (2)

checked the battery voltage and it was fine, went to my mechanic and he plugged in his computer and it showed hard codes for front right wheel speed sensor. ran a test while driving the car showing the 4 wheel speed sensors and the front right read nothing.
part should arrive tomorrow, ill swap it out and see if it fixes it.
Appreciate 0
      09-24-2013, 01:23 AM   #9
ctuna
Brigadier General
45
Rep
4,338
Posts

 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

Good job

Good job
Appreciate 0
      09-24-2013, 07:24 AM   #10
alexx03
Lieutenant
4
Rep
426
Posts

 
Drives: 2007 BMW 335I
Join Date: Jun 2012
Location: Vaughan

iTrader: (2)

Quote:
Originally Posted by ctuna View Post
Good job
thanks for the help again man
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:29 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST