E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > All-Wheel-Drive (Xi / xDrive) Talk > Error Codes- Limp Mode



Reply
 
Thread Tools Search this Thread
      10-01-2013, 09:09 PM   #1
JRP
New Member
 
Drives: 2006 BMW 325 xi
Join Date: Jan 2011
Location: New York

Posts: 23
iTrader: (0)

Error Codes- Limp Mode

I received the following error codes on my E90 325 xi-
P0442
P1056
P1030
P1561

Plus the car goes into limp mode, when it decides to. Car is not reliable now.

I just had the dealer change the valvetronic motor and eccentric shaft sensor, per dealer diagnostics, and it cost me over $1600! The suggested a new gas cap too, and forgot to install it (but I paid for one!) That there just turned me off too. All this was suppose to take care of the car going into limp mode, lack of power, and sometimes; not even starting up.

The car is still having the same problems as it went in for. I am not happy. I have not talk to dealer yet because All they want to do is charge $90 every time they plug the OBD scanner in to it and tell me a code. I feel the dealer is just playing parts changer at this point. Any suggestions on what I should do for a next step? I can do pretty much take on any DIY project. I have a full blown shop on our farm. Just needed a little guidance. Thanks. Jon
JRP is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:51 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST