E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > All-Wheel-Drive (Xi / xDrive) Talk > 4x4, brake light on.



Reply
 
Thread Tools Search this Thread
      07-05-2013, 11:47 AM   #1
Monstah
Registered
 
Drives: 328xi
Join Date: Apr 2013
Location: RI

Posts: 4
iTrader: (0)

4x4, brake light on.

My 328xi just recently hit 70k I bought it used with no warranty. About a couple weeks ago when backing out, 3 lights illuminated on my dash. I searched on here and found a tread saying to turn the wheel to the left all the way then to the right. After doing that the light went away and my car drove fine for weeks. Until yesterday, when backing out I heard a pop. Then all the lights came on immediately, tried clearing it using the trick from before but it stayed on this time. I drove the car and the lights went off, stayed off for most of the day. But this morning once I started it up, all the lights came back on. I read something about the servo motor going but it seems intermediate.

The light doesn't stay on, leading me to believe it might be something else? I also saw some people say it could be the battery, I do have an aftermarket amp and deck hooked up. I checked and all the connections are tight. But could that possibly be it? Any help would be appreciated.
Monstah is offline  
0
Reply With Quote
      07-05-2013, 11:54 AM   #2
Monstah
Registered
 
Drives: 328xi
Join Date: Apr 2013
Location: RI

Posts: 4
iTrader: (0)

All the lights went off after driving my car down the street. Not sure what to make of this.
Monstah is offline  
0
Reply With Quote
      10-09-2013, 03:17 PM   #3
HueyT09
New Member
 
HueyT09's Avatar
 
Drives: 2006 E90 330xi
Join Date: Sep 2013
Location: Gatineau

Posts: 9
iTrader: (0)

I had those light too.. it was really dangerous for me cause my engine was kinda shutting down but not completely, it was just bugging while im driving. It was identicaly the same situation as you .. On and OFF and after couple days my battery light came on (red, it means it was weak and low of energie) .. the shitty thing about it was because it was a brand new OEM battery from dealer that I installed myself after watching couple youtube video... I thought my alternator had some problem.. but then I decided to retight every connection on the battery and those lights are gone.. never came back..
__________________
330xi e90/ AFE Pro5R CIA / AA stage 2 tune / obx catless headers / Megan lowering springs
HueyT09 is offline   Canada
0
Reply With Quote
      10-09-2013, 04:34 PM   #4
pits200
Lieutenant Colonel
 
Drives: 09 335i X-Drive Black Sapphire
Join Date: Mar 2010
Location: Pittsburgh

Posts: 1,838
iTrader: (0)

Could be a short with the battery, I'd assume you'd get a low voltage warning about this but if your car is close to 5 years old it is possible that it is time for a new battery.
pits200 is online now   United_States
0
Reply With Quote
      10-14-2013, 07:04 PM   #5
7thgen
Registered
 
Drives: 328i xdrive
Join Date: May 2013
Location: Toronto

Posts: 4
iTrader: (0)

I had the same problem for the past 3 weeks. light goes on and off. when I reverse I head a poping noise. I brought it back to the dealership and got the transfer case replaced.
7thgen is offline  
0
Reply With Quote
      10-15-2013, 11:11 PM   #6
Jeffman
First Lieutenant
 
Jeffman's Avatar
 
Drives: 2008 335xi E90
Join Date: Jul 2010
Location: Somewhere in America

Posts: 372
iTrader: (1)

Garage List
Fwiw, Mike Miller of BMWCCA Roundel fame recommends changing the transfer case oil every 30 K miles.
Jeffman is offline  
0
Reply With Quote
      10-23-2013, 08:58 PM   #7
Spandexder
New Member
 
Drives: 335xi
Join Date: Feb 2011
Location: Chicago

Posts: 12
iTrader: (0)

OP, I had the same problem. Cost me $1,500 yesterday to have Bill Jacobs BMW replace the transfer case motor. My advice, go to an independent garage and save yourself $500, advice I should have taken myself...
__________________
Silver 2007 335xi
Spandexder is offline   United_States
0
Reply With Quote
      10-29-2013, 07:03 PM   #8
SG335Xi
Private
 
SG335Xi's Avatar
 
Drives: 2008 SG 335Xi
Join Date: Mar 2011
Location: Minnesota

Posts: 57
iTrader: (2)

This exact thing happened to me when I swapped my battery - it went away after about 2 minutes of driving...
SG335Xi is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:52 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST