E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > Help. AbS lights on after rear bearing replacement.



Reply
 
Thread Tools Search this Thread
      10-10-2013, 09:33 PM   #1
2008_335i_coupe
Lieutenant
 
2008_335i_coupe's Avatar
 
Drives: 2008 335i Coupe, Apline White
Join Date: May 2007
Location: austin, tx

Posts: 537
iTrader: (7)

Help. AbS lights on after rear bearing replacement.

Help
My abs lights and brake light is on the dash after my rear passenger side wheel bearing replacement.
I thought it was abs sensor and replaced and it is still on.
I bought a timken bearing and installed it with the black side facing inward.
2008_335i_coupe is offline   United_States
0
Reply With Quote
      10-12-2013, 09:57 PM   #2
2008_335i_coupe
Lieutenant
 
2008_335i_coupe's Avatar
 
Drives: 2008 335i Coupe, Apline White
Join Date: May 2007
Location: austin, tx

Posts: 537
iTrader: (7)

TTT...
2008_335i_coupe is offline   United_States
0
Reply With Quote
      10-15-2013, 07:38 PM   #3
2008_335i_coupe
Lieutenant
 
2008_335i_coupe's Avatar
 
Drives: 2008 335i Coupe, Apline White
Join Date: May 2007
Location: austin, tx

Posts: 537
iTrader: (7)

Anyone??
I have searched high and low online.
2008_335i_coupe is offline   United_States
0
Reply With Quote
      10-16-2013, 09:01 AM   #4
StealYourFace
Major
 
Drives: 2006 330i sport
Join Date: Jul 2009
Location: Shakedown Street, Buffalo NY

Posts: 1,023
iTrader: (1)

Same thing happened to me last year. I bought the part from pep boys (was the oem supplier). Changed the sensor, still had the issue. Got another new bearing from bmw, problem solved.

I know, the last thing you want to do is take that thing apart again
__________________
330i ~ BMW Perf. Susp. ~ M3 Front susp ~ BMW Perf Exhaust ~ 3.38 lsd ~ SF71 Alf CSL reps ~ Pilot Super Sports ~ AA Tune ~ 335is front brakes WTB: e93 M3 Front Sway Bar
StealYourFace is offline   United_States
0
Reply With Quote
      10-19-2013, 01:30 PM   #5
2008_335i_coupe
Lieutenant
 
2008_335i_coupe's Avatar
 
Drives: 2008 335i Coupe, Apline White
Join Date: May 2007
Location: austin, tx

Posts: 537
iTrader: (7)

Crap. I didn't want to have to do that.
The bearing did say *** on it which is OEM.
2008_335i_coupe is offline   United_States
0
Reply With Quote
      10-19-2013, 02:18 PM   #6
Casca
Captain
 
Drives: E90 6MT
Join Date: May 2010
Location: California

Posts: 616
iTrader: (0)

Did you get a Timkin or a F@G? Sure it isn't the problem either way. Black end, red end....I am not sure which end goes in first, but am pretty sure it does matter since the "pulse ring" for the ABS sensor to read RPM is only on one side.

I see F@G uses a red end for the pulse ring side and that needs to face out...not sure what Timkin does. (haven't done bearings yet myself, so no hands on experience)

edit:
Ok, would seem the red side is just a seal and the black side is the magnet. All pics I see of F.A.G. bearings shows the spindle with the red of the bearing just behind it, so would assume the sensor picks up the magnet on the backside....so maybe you put it in backwords if you put the black part in first. Not exactly sure, just guessing. Take a look at where the ABS sensor is, if possible put a screw tip near your bearing and see if you can feel the magnet. Check on your other side to compare.

Last edited by Casca; 10-19-2013 at 03:27 PM.
Casca is offline  
0
Reply With Quote
      10-20-2013, 08:12 AM   #7
StealYourFace
Major
 
Drives: 2006 330i sport
Join Date: Jul 2009
Location: Shakedown Street, Buffalo NY

Posts: 1,023
iTrader: (1)

The bad ones I got were f.a.g. (they should consider a new name for their company). My guess was that I got one for an e46 330i instead of an e90, since I have a 2006, just a guess though. But I looked the part number up on their website and it was indeed the correct part number.

Long and the short, but it from the dealer.

Here's the rub.... with my cca discount, the part was cheaper at the dealer than schlep boys. :mad:
__________________
330i ~ BMW Perf. Susp. ~ M3 Front susp ~ BMW Perf Exhaust ~ 3.38 lsd ~ SF71 Alf CSL reps ~ Pilot Super Sports ~ AA Tune ~ 335is front brakes WTB: e93 M3 Front Sway Bar
StealYourFace is offline   United_States
0
Reply With Quote
      10-20-2013, 09:40 AM   #8
essex_lad
Captain
 
essex_lad's Avatar
 
Drives: E92 325i Msport Highline
Join Date: Jun 2013
Location: Essex

Posts: 698
iTrader: (0)

the sensors were plugged back in weren't they before stressing about it?
essex_lad is offline  
0
Reply With Quote
      11-05-2013, 01:15 PM   #9
2008_335i_coupe
Lieutenant
 
2008_335i_coupe's Avatar
 
Drives: 2008 335i Coupe, Apline White
Join Date: May 2007
Location: austin, tx

Posts: 537
iTrader: (7)

I have replaced the sensor and checked then connections.
One I am checking again is to make sure no anti-seize compound is in the sensor hole on the bearing.
If that doesn't work I am replacing the bearing again.
2008_335i_coupe is offline   United_States
0
Reply With Quote
      12-07-2013, 11:22 AM   #10
Casca
Captain
 
Drives: E90 6MT
Join Date: May 2010
Location: California

Posts: 616
iTrader: (0)

This is the thread that had me worried about if I was putting my bearings in correctly. F.A.G does say red side out, but the OP here did that and had problems so that caused a lot of doubt for me. And then I couldn't really find info that was conclusive for BMW's. So I did the same direction as 2008_335i_coupe did and no problems. Everything worked great. Red side out, black side next to the ABS sensor for an F.A.G bearing



I don't know what went wrong with the OP's ABS light, but if he had an F.A.G bearing and pressed it with black side next to the sensor and red side out, that isn't the problem.

I did notice that even though I pressed it in far enough to be able to get the c-clip in the groove, looking at the back side, there was still more space for the bearing to be pressed farther. So I pressed until the bearing actually bitted up against the lip.
Casca is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:47 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST