E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > DIY - Replacing Camshaft VANOS Solenoid



Reply
 
Thread Tools Search this Thread
      10-29-2013, 02:37 PM   #177
bigdaddycane
I even mod my cereal
bigdaddycane's Avatar
United_States
53
Rep
2,873
Posts

Drives: 2011 ZCP DCT M3
Join Date: Aug 2009
Location: Northern Va

iTrader: (44)

Garage List
Take the snorkel off, it's TWO screws and will give you more room to work. Check the links listed/shown above as the solenoids are very similar between the N52 and N54 motors. Yes, compressed air and carb cleaner will get the solenoids cleaned out.
__________________
2011 Mineral White M3 ZCP
Paint Correct, Opticoat, Ventureshield and some CF and an intake
Appreciate 0
      10-30-2013, 11:36 PM   #178
Black Bimmer
Private
1
Rep
61
Posts

Drives: 2008 335 coupe
Join Date: Jun 2008
Location: LA

iTrader: (0)

Just got limp mode and pulled code 2A87. FYI, looks like California has a 7 year 70,000mi warranty on emissions components. The "VANOS adjustment unit" is specifically called out as being covered in the BMW warranty book. See Pg 42:
http://www.irvinebmw.com/usr/theme/i...es_English.pdf

Will try my luck at the dealer.

Last edited by Black Bimmer; 10-30-2013 at 11:45 PM.
Appreciate 0
      11-10-2013, 10:14 AM   #179
Dackelone
European Editor
Dackelone's Avatar
Germany
4001
Rep
20,480
Posts

Drives: N54 e82
Join Date: Feb 2010
Location: Bayern, Germany

iTrader: (1)

Here is a good DIY video on replacing the vanos sensors...

Appreciate 0
      01-25-2014, 12:26 AM   #180
bimmertt
Lieutenant Colonel
bimmertt's Avatar
38
Rep
1,710
Posts

Drives: 2007 e92 335i
Join Date: Nov 2008
Location: Earth

iTrader: (7)

Well, I just did what I thought would be the inevitable and I dropped the hex bolt for the upper solenoid. On the n52 z4, you are essentially working blind in getting the bolt out/back in.

Will I experience any problems while driving? The solenoid seems pretty snug.

Now to determine if it is worth getting the car in the air to remove the undercover and hunt for the bolt (didn't hear it drop) or just find a dealership that carries it...
Appreciate 0
      01-25-2014, 01:33 AM   #181
bigdaddycane
I even mod my cereal
bigdaddycane's Avatar
United_States
53
Rep
2,873
Posts

Drives: 2011 ZCP DCT M3
Join Date: Aug 2009
Location: Northern Va

iTrader: (44)

Garage List
get the new bolt at the least. Id jack up the front and pull the under panel off or get a good light and make sure its not sitting on a pulley or drive belt.
__________________
2011 Mineral White M3 ZCP
Paint Correct, Opticoat, Ventureshield and some CF and an intake
Appreciate 0
      01-25-2014, 12:56 PM   #182
ska///235i
***** noob
ska///235i's Avatar
United_States
499
Rep
10,280
Posts

Drives: 325xi>M235i>428GCx Mspor
Join Date: Sep 2005
Location: Boston

iTrader: (34)

Garage List
2006 325xi  [0.00]
Use a magnetic pickup stick and search around....i wouldnt drive it without the solenoid bolted on
__________________
2006 325xi (Sold)
2014 M235I (Current)
2015 428xi Gran Coupe (STB)
Appreciate 0
      01-30-2014, 04:47 PM   #183
ice_nyne
Perpetual Kickdown Mode
ice_nyne's Avatar
United_States
0
Rep
39
Posts

Drives: 2011 N51 M Sport
Join Date: Aug 2008
Location: So Cal

iTrader: (0)

Gonna attempt it this weekend. I am getting codes pointing to either the Vanos Solenoid of the Eccentric Sensor. I'll try a heavy cleaning of the solenoids and change the coils while I'm in there, see what happens.

Appreciate the write-up!
Appreciate 0
      01-30-2014, 09:41 PM   #184
ska///235i
***** noob
ska///235i's Avatar
United_States
499
Rep
10,280
Posts

Drives: 325xi>M235i>428GCx Mspor
Join Date: Sep 2005
Location: Boston

iTrader: (34)

Garage List
2006 325xi  [0.00]
Quote:
Originally Posted by ice_nyne
Gonna attempt it this weekend. I am getting codes pointing to either the Vanos Solenoid of the Eccentric Sensor. I'll try a heavy cleaning of the solenoids and change the coils while I'm in there, see what happens.

Appreciate the write-up!
Change the spark plugs too
__________________
2006 325xi (Sold)
2014 M235I (Current)
2015 428xi Gran Coupe (STB)
Appreciate 0
      02-03-2014, 12:52 AM   #185
ice_nyne
Perpetual Kickdown Mode
ice_nyne's Avatar
United_States
0
Rep
39
Posts

Drives: 2011 N51 M Sport
Join Date: Aug 2008
Location: So Cal

iTrader: (0)

Quote:
Originally Posted by ska325xi View Post
Change the spark plugs too
Did that a few weeks back along with an oil change.

Finished the solenoid cleaning earlier today and swapped the intake and exhaust locations as suggested. Very easy to do. Thanks for the write up.
Appreciate 0
      02-06-2014, 05:05 PM   #186
wanna325i
Private First Class
3
Rep
127
Posts

Drives: E92 335i
Join Date: Mar 2005
Location: Lauderhill ,FL

iTrader: (2)

Swap them and clean them. Still getting the same P0015 code. After some more time searching, some say replace the Crankshaft Sensor.

What should I do?
__________________
08 E92 335i AW/blk.
SP,PP ,CA and auto
10 C300 blk/blk P2 and NAV
Appreciate 0
      02-08-2014, 03:23 PM   #187
Efthreeoh
Major General
United_States
867
Rep
6,889
Posts

Drives: E90 & Z4 Coupe
Join Date: May 2012
Location: MARLAND

iTrader: (0)

Quote:
Originally Posted by bimmertt View Post
Well, I just did what I thought would be the inevitable and I dropped the hex bolt for the upper solenoid. On the n52 z4, you are essentially working blind in getting the bolt out/back in.

Will I experience any problems while driving? The solenoid seems pretty snug.

Now to determine if it is worth getting the car in the air to remove the undercover and hunt for the bolt (didn't hear it drop) or just find a dealership that carries it...
Hex bolt M6X12-8.8ZNNIV 2ea. P/N 07119905524 $0.25

Any M6 x 12 bolt would do.
Appreciate 0
      03-16-2014, 12:53 PM   #188
wanna325i
Private First Class
3
Rep
127
Posts

Drives: E92 335i
Join Date: Mar 2005
Location: Lauderhill ,FL

iTrader: (2)

Quote:
Originally Posted by wanna325i View Post
Swap them and clean them. Still getting the same P0015 code. After some more time searching, some say replace the Crankshaft Sensor.

What should I do?
i replace my exhaust camshaft sensor, clean m valves, clean those solenoid again swap them around. still showing 00015 code. Do i have to replace those two solenoid? Plugs??

thanks
__________________
08 E92 335i AW/blk.
SP,PP ,CA and auto
10 C300 blk/blk P2 and NAV
Appreciate 0
      03-16-2014, 04:55 PM   #189
ska///235i
***** noob
ska///235i's Avatar
United_States
499
Rep
10,280
Posts

Drives: 325xi>M235i>428GCx Mspor
Join Date: Sep 2005
Location: Boston

iTrader: (34)

Garage List
2006 325xi  [0.00]
Quote:
Originally Posted by wanna325i
Quote:
Originally Posted by wanna325i View Post
Swap them and clean them. Still getting the same P0015 code. After some more time searching, some say replace the Crankshaft Sensor.

What should I do?
i replace my exhaust camshaft sensor, clean m valves, clean those solenoid again swap them around. still showing 00015 code. Do i have to replace those two solenoid? Plugs??

thanks
Whats the 15 code you talk about? Thats too generic
__________________
2006 325xi (Sold)
2014 M235I (Current)
2015 428xi Gran Coupe (STB)
Appreciate 0
      03-17-2014, 01:11 AM   #190
wanna325i
Private First Class
3
Rep
127
Posts

Drives: E92 335i
Join Date: Mar 2005
Location: Lauderhill ,FL

iTrader: (2)

Quote:
Originally Posted by ska325xi View Post
Whats the 15 code you talk about? Thats too generic
It is P0015 code from a OBD2 reader, still waiting on my IPNA from mail.
__________________
08 E92 335i AW/blk.
SP,PP ,CA and auto
10 C300 blk/blk P2 and NAV
Appreciate 0
      03-17-2014, 08:09 AM   #191
ska///235i
***** noob
ska///235i's Avatar
United_States
499
Rep
10,280
Posts

Drives: 325xi>M235i>428GCx Mspor
Join Date: Sep 2005
Location: Boston

iTrader: (34)

Garage List
2006 325xi  [0.00]
Quote:
Originally Posted by wanna325i
Quote:
Originally Posted by ska325xi View Post
Whats the 15 code you talk about? Thats too generic
It is P0015 code from a OBD2 reader, still waiting on my IPNA from mail.
Havent follow your post so not sure whats going on with your car...get it scanned
__________________
2006 325xi (Sold)
2014 M235I (Current)
2015 428xi Gran Coupe (STB)
Appreciate 0
      04-07-2014, 01:55 AM   #192
e91 335i
New Member
1
Rep
10
Posts

Drives: BMW e91 335i
Join Date: May 2012
Location: Finland

iTrader: (0)

Hi guys, I have had the same solenoid problem. I changed both solenoid and oil. Still, I have these codes present

First I only had 2a87 and I changed the exhaust solenoid. The car worked a while but then the same code started appearing again. I swapped the (new) solenoid to inteke side and bought a new solenoid to the exhaust side. I changed the oil at the same time. Now the car gave 2a82 intake code. After driving a couple of days the 2a87 is present again but not 2a82 wtf!? The code appears almost immediately when I cold start the car. After driving a while, I restart the car and the 2a87 appears only occasionally.

Do you guys thinks it's the bearing ledges or what? The car has high miles (160 000). What is the part number of those ledges? Any change of doing this repair yourself?
Appreciate 0
      04-12-2014, 06:15 PM   #193
Zero_09
Captain
Canada
18
Rep
622
Posts

Drives: 07 E90, 2011 E90
Join Date: Jul 2012
Location: =

iTrader: (1)

I had these codes before

2A98,1,Crankshaft-inlet camshaft, correlation
2A43,1,Valvetronic, thermal overload protection: warning threshold
2A82,8,VANOS intake

So I decided to do this DIY and swap the intake and exhaust solenoid. It was pretty simple. I didn't have to take anything out as both of the solenoids was accessible to me on my 07 328i.

Started the car and the idle was a bit on the high side at first. It settle down to 600rpm a bit after. Let it run for a bit and shut it off. A few mins later I started it up again and got CEL.

I checked the connectors again and the top intake solenoid was loose so I fixed that. Started it again and got a half engine check list. Turned it off and went to get my cable to see whats up using the BMWLogger.

2A98,1,Crankshaft-inlet camshaft, correlation
2A43,1,Valvetronic, thermal overload protection: warning threshold
2A82,8,VANOS intake

So I cleared the codes and DME with the BMWLogger software. Tried it again and now I got this

2CFB,1,Throttle-valve adaptation value
2D09,4,Throttle valve.

What a mess. Not sure what I did wrong but the car was running fine before but once in a while I get a CEL and the symptoms describe in the OP so I thought I'd tried an easy fix first.

Anyone know what I did wrong here?
Appreciate 0
      04-21-2014, 06:28 PM   #194
nick380
Private First Class
United_States
10
Rep
155
Posts

Drives: 2007 BMW 335i
Join Date: Oct 2013
Location: California

iTrader: (1)

Just did this last weekend and wow what a difference in acceleration! No more limp mode, no more lights...my baby is all clean now, on the inside and the outside

2007 335i.
Appreciate 0
      04-23-2014, 11:12 PM   #195
StealthFish
Private First Class
United_States
7
Rep
176
Posts

Drives: 435i Gran Coupe
Join Date: Feb 2012
Location: Houston, TX

iTrader: (1)

Quote:
Originally Posted by Zero_09 View Post
I had these codes before

2A98,1,Crankshaft-inlet camshaft, correlation
2A43,1,Valvetronic, thermal overload protection: warning threshold
2A82,8,VANOS intake

So I decided to do this DIY and swap the intake and exhaust solenoid. It was pretty simple. I didn't have to take anything out as both of the solenoids was accessible to me on my 07 328i.
I have gotten code P2A98 as well as P3100. Code P2A98 is the same as yours and I cannot find many people who have had this code. Can anyone tell me if this will fix the problem? I cannot find anything on code P2A98. I think it can be the crankshaft instead of the camshaft although I would liek it to be the camshaft VANOS as those are easier to get to and replace or clean.

Help, anyone?
Appreciate 0
      05-22-2014, 08:25 AM   #196
Vishnu
Private
3
Rep
54
Posts

Drives: 335i
Join Date: Sep 2010
Location: Toronto

iTrader: (0)

I get limp mode sometimes on hard acceleration on the highway... There are no codes that are thrown up.. That I can tell..
If I turn off the car and back on everything is fine..
Is this a solenoid problem?
Appreciate 0
      05-28-2014, 08:26 AM   #197
lacortedaniel
Registered
0
Rep
3
Posts

Drives: 2006 bmw 325i
Join Date: May 2014
Location: iowa

iTrader: (0)

Garage List
2006 BMW 325i  [0.00]
I have a cheapo code reader but it read camshaft position sensor, and after reading some more I found this and thought what the hay, replaced both the camshapft position sensors, and both of the vanos sensors, cannot clear the code but the car runs great. Has some rough idle for a few minutes at cold start up though???? 2006 325i . Any ideas as to why I cant clear codes after replacing all those sensors?
D
Appreciate 0
      06-05-2014, 06:42 PM   #198
Zero_09
Captain
Canada
18
Rep
622
Posts

Drives: 07 E90, 2011 E90
Join Date: Jul 2012
Location: =

iTrader: (1)

It's been almost two months now since I switch the Vanos solenoid and have not had any problems and CEL ever since. Thanks for te DIY. Save me quite a bit of money.. Hopefully it doesn't show up again.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:13 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST