E90Post
 


E92-lighting
 
BMW 3-Series (E90 E92) Forum > BIMMERPOST Universal Forums > General BMW News and Cars Discussion > my BMW is driving me crazy. please HELP!!



Reply
 
Thread Tools Search this Thread
      11-28-2013, 01:33 PM   #1
Sasha78
Registered
0
Rep
2
Posts

 
Drives: 2009 BMW 328i
Join Date: Nov 2013
Location: Vancouver, Canada

iTrader: (0)

my BMW is driving me crazy. please HELP!!

Hi guys,

I bought my 2009 328i a couple years ago. Currently it has 58,000KM on it. it has been in a front end collision before and it was repaired and ran prefectly when I bought it. 4 months ago I replaced the alternator because the original one had a crack and it died. I also put a brand new battrey in it at the time. Right now it's charging prefectly.

My problem: about a month ago, in the morning I get in the car, and the car is really hard to start. I start the car, the rpm races to around 2,000 and the car immediately dies. this happens around 5-6 times, then the car would just turn over but not start. The engine light (not the little yellow one, but the bigger one on the screen). I also hear loud sound from the engine once in a while when it's trying to start up, sounds like 2 pieces of metal hitting against eachother, just once, it's not continous. After trying for about 10-15 times. the car starts! no engine lights no nothing and after the car is warmed up, it seems to me that it runs prefectly.

Through out the day as long as the car is not sitting more than 4-5 hours, it starts right up with the first try. My problem is when the car is sitting for more than say 5 hours or specially over night.

I took the car to a respectable shop, the mechanic did some diagnostic and he said he is getting a while bunch of codes, from Valvetronic sensor and motor code to fuel pump, ECU code and overheating problem. He said he has to do more tests.

I took the car because he said he is busy till next week and he can't do more tests to pinpoint the problem and I needed the car.

Today, I went to try the car, and it turns over, like the starter is working, but it won't start up, I can hear the fuel pump engaging when I first turn the ignition in position 2.


I just need some help from you guys, I'm going through some troubles right now financially, and trying to save some money on fixing this.

Thank you.
Appreciate 0
      11-28-2013, 02:36 PM   #2
631twentyeighteye
Lieutenant Colonel
631twentyeighteye's Avatar
United_States
33
Rep
1,905
Posts

 
Drives: 2010 130i MT
Join Date: Aug 2012
Location: Long island

iTrader: (6)

giving us the diagnostic codes would give us a little more insight so we could perhaps help you out. If your mechanic won't tell you which ones came up go to autozone and have them scan your car, they do it for free. Write down the codes that come up and post them on here.
__________________
3 stage manifold, Mapleridge headers, AA tune, Injen intake
Appreciate 0
      11-28-2013, 03:39 PM   #3
pj.rodriguez
Major
pj.rodriguez's Avatar
Canada
16
Rep
1,375
Posts

 
Drives: Alpine White 128i Cabrio
Join Date: Jun 2013
Location: Toronto, Ontario, Canada

iTrader: (6)

Garage List
Quote:
Originally Posted by 631twentyeighteye View Post
giving us the diagnostic codes would give us a little more insight so we could perhaps help you out. If your mechanic won't tell you which ones came up go to autozone and have them scan your car, they do it for free. Write down the codes that come up and post them on here.
Partsource in Canada.

Agreed. Get the codes. Post them up. I won't be able to help you any more than google will though, but I'm sure some experienced people will be able to help you!
__________________
2008 128i E88 / Alpine White / Boston Leather Sport / 6AT / M3 Paddle Shifters / M-Sport Suspension / BMW 335i Front Brakes / PIAA Xtreme White 4150K Angel Eyes / Rear Fogs Enabled / Cyba Air Scoops / Euro Airbox / BMW Performance Exhaust / Stubby BMW Antenna
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:16 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST