E90Post
 


E92 Lighting
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > Australia > Steering rack clunking noise



Reply
 
Thread Tools Search this Thread
      10-14-2013, 11:59 AM   #23
Bleach8484
Private
 
Drives: 335i
Join Date: Sep 2013
Location: Atlanta

Posts: 99
iTrader: (0)

Did anyone ever confirm what the problem is? I'm having the same issue
Bleach8484 is offline  
0
Reply With Quote
      10-14-2013, 05:47 PM   #24
kaitan
Major
 
kaitan's Avatar
 
Drives: Bus 11 AKA walking
Join Date: Nov 2011
Location: sydney, australia

Posts: 1,317
iTrader: (1)

Quote:
Originally Posted by Bleach8484 View Post
Did anyone ever confirm what the problem is? I'm having the same issue
Apparently it's due to low brake pads but some of us have relatively good pad thickness. For me my pads were low but after a year or so as my pads are not due yet the clunks just went away.

So I can't really pinpoint what the problems be?
__________________
Sold:08 BSM E92 335i JB4, AR Design DP, M3 Steering Wheel, BMS PODS, Michelin PSS 225/255, Black Grille, CF Quad Diffuser, Remus Quad Exhaust, BSM Bootlip (Missing it badly )

Check out Facebook: TLCC @ Pymble.
kaitan is offline  
0
Reply With Quote
      10-14-2013, 06:18 PM   #25
Bleach8484
Private
 
Drives: 335i
Join Date: Sep 2013
Location: Atlanta

Posts: 99
iTrader: (0)

Well. That's a little more reassuring than what I thought. I assumed it was something internal in the transmission. Or at the very least a TCU problem.
Bleach8484 is offline  
0
Reply With Quote
      12-04-2013, 09:42 PM   #26
Joke8
Registered
 
Drives: 335 E92
Join Date: May 2013
Location: Melbourne

Posts: 1
iTrader: (0)

having the same issue when parking...especially reverse parking...
Joke8 is offline   Australia
0
Reply With Quote
      12-04-2013, 09:58 PM   #27
Zen
Lieutenant
 
Drives: E92 335i
Join Date: Nov 2008
Location: Sydney Aus

Posts: 586
iTrader: (0)

Possible movement within the pads which also means that they might need changing soon. I had mine changed recently and the clicking noises seems to had disappeared.
__________________
08' E92 335I
Black Sapphire Metallic | M-Sport | GT-CS 19" Matte Anthracite | BMW Perf. Exhaust | JB4 | AR Design Catless DP | R1 Concepts Cross-drilled & Slotted Rotors | aFe DCI | ER Chargepipe with Forge DV | ER FMIC
Zen is offline   Australia
0
Reply With Quote
      12-04-2013, 10:35 PM   #28
Bleach8484
Private
 
Drives: 335i
Join Date: Sep 2013
Location: Atlanta

Posts: 99
iTrader: (0)

I tightened all the bolts on the steering rack. One bolt was actually loose. That cured my problem for sure.

As for the pads. I get that noise as well.
Bleach8484 is offline  
0
Reply With Quote
      12-05-2013, 01:00 AM   #29
samchuang33
Captain
 
samchuang33's Avatar
 
Drives: 2009 330d LCI Sport
Join Date: Feb 2009
Location: Brisbane

Posts: 743
iTrader: (0)

My pad is getting a bit close to replacing. I will report back in coming month after I replace brakes.
__________________
2009 LCI 330d Sport Auto
Space Grey, Sunroof, 18", Professional Nav, Individual Audio

Diesel POWER!!!!!!!
samchuang33 is offline   Australia
0
Reply With Quote
      12-05-2013, 04:08 AM   #30
pd135
Private First Class
 
pd135's Avatar
 
Drives: Bmw 135i
Join Date: Oct 2011
Location: Brisbane, Australia

Posts: 169
iTrader: (0)

Garage List
2008 BMW 135i  [4.67]
Mine was making a clicking sound that could be felt through the steering wheel as well.

On of the bolts On my steering rack was a bit loose. Tightening that fixed my problem.
pd135 is offline  
0
Reply With Quote
      12-30-2013, 12:11 PM   #31
HPF 335i #1
Captain
 
Drives: 2008 E92 335i 6AT
Join Date: Sep 2009
Location: Ft. Riley Kansas

Posts: 883
iTrader: (0)

I have this issue now too… Im thinking the steering column now but at pone point i thought it was the gear box bearings… Im actually under the car now trying to figure out if its the rack or the Column.

Some of you tightened the rack bolts? which ones, any pictures?

My clicks are in both directions and parking lot speeds. I can even make the sounds with the engine off just by putting mild pressure on the wheel in any direction.

looking for a quick solution.
__________________
FFTEC Single Turbo, HPF FMIC, HPF OCC, HPF Exhaust, KW V1, M3 Front & Rear Roll Bars, M3 Control Arms, Rear Toe Arms, M3 Sub Bushings, WT LSD, VMR 710s, Stop Tech Brakes, AEM Boost Pods, CF Boot Lid, Vented CF Hood, M-Tech Front, Aluminum Pedals, LED Shifter, Mat Black front Grill.
HPF 335i #1 is offline  
0
Reply With Quote
      12-30-2013, 12:21 PM   #32
Bleach8484
Private
 
Drives: 335i
Join Date: Sep 2013
Location: Atlanta

Posts: 99
iTrader: (0)

Just check all the lots on the steering rack. Seemed to fix mine
Bleach8484 is offline  
0
Reply With Quote
      01-07-2014, 08:52 PM   #33
jasonway
Registered
 
Drives: 328i Luxury '13
Join Date: Dec 2013
Location: Melbourne, Australia

Posts: 1
iTrader: (0)

MY 13.5 328i
I have exactly the same problem described. I have 1,800km on clock and most noticeable when reversing.

I'm going to raise this with the Dealer when they are fixing my window tinting.


Regards

Jason
jasonway is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:44 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST