E90Post
 


MaxcySpeed & Company
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > Cic nav fitted, maps not showing correct location



Reply
 
Thread Tools Search this Thread
      12-25-2013, 03:05 AM   #1
320dlci
Enlisted Member
 
Drives: 320D Lci sport
Join Date: Jun 2013
Location: Bury

Posts: 33
iTrader: (0)

Cic nav fitted, maps not showing correct location

I've finally fitted the cic nav in my lci e90...
Everything is working fine as it should, also DVDs play whilst driving! But the nav isn't up2 scratch at the moment, not sure if its the gps or anything else as u can see the vehicle position on the map moving but it's not in the correct location in map? Do I need to do anything to get this this updated to the right location or is it the GPS?

Cheers
320dlci is offline  
0
Reply With Quote
      12-25-2013, 06:42 AM   #2
IanS100
Colonel
 
IanS100's Avatar
 
Drives: 320d LCI M Sport Plus
Join Date: Nov 2011
Location: Southport UK

Posts: 2,485
iTrader: (0)

Apparently the GPS remembers the last position it was used ( ie before being removed from the donor car) Initially mine was the same when Sam installed it, but he did something to reset the location so it's not anything to worry about. Hopefully someone will be along soon to give you some pointers on how to initialize the location, or if you're in a hurry try having a Google.
IanS100 is online now   United Kingdom
0
Reply With Quote
      12-25-2013, 07:40 PM   #3
jammy78
Major
 
Drives: E92 330D M Sport
Join Date: Nov 2012
Location: Hertfordshire

Posts: 1,010
iTrader: (15)

I believe you have to re-set the gps by going into the secret menu - various turns of the controller......ask google!

Then an extra menu option will appear in the settings!
jammy78 is offline   United Kingdom
0
Reply With Quote
      12-26-2013, 05:15 AM   #4
blues n twos
Lieutenant
 
blues n twos's Avatar
 
Drives: BMW E93 330i M Sport
Join Date: Jun 2013
Location: Beaconsfield, Bucks

Posts: 435
iTrader: (1)

Mine did this also but after driving it the gps corrected itself to the correct location. Have you driven it yet?

Jon
__________________
E93 330i M-Sport Auto. Led angle eyes, performance rear diffuser, Alpine Audio upgrade, Full CiC install, Matt carbon interior trim wrap, new 313's
blues n twos is offline   United Kingdom
0
Reply With Quote
      12-26-2013, 01:34 PM   #5
320dlci
Enlisted Member
 
Drives: 320D Lci sport
Join Date: Jun 2013
Location: Bury

Posts: 33
iTrader: (0)

Yes I've driven the car for over a week but map is not updating to the location that am at? But I can see the blue arrow moving... How do h get to this secret menu?
320dlci is offline  
0
Reply With Quote
      12-26-2013, 01:41 PM   #6
IanS100
Colonel
 
IanS100's Avatar
 
Drives: 320d LCI M Sport Plus
Join Date: Nov 2011
Location: Southport UK

Posts: 2,485
iTrader: (0)

As jammy78 said, Google it, I found it a few weeks ago & it's a series of pushes & turns of the icontroller, but can't remember what exactly.
IanS100 is online now   United Kingdom
0
Reply With Quote
      12-26-2013, 02:05 PM   #7
telewebby
Enlisted Member
 
Drives: lowandslow320i
Join Date: Jan 2013
Location: warwickshire

Posts: 39
iTrader: (0)

make sure you have got the gps antenna plugged correctly

Alex
telewebby is offline  
0
Reply With Quote
      12-26-2013, 05:55 PM   #8
ukbeemerboy
Beemer Heaven
 
ukbeemerboy's Avatar
 
Drives: BMW 330d M Sport
Join Date: Feb 2007
Location: Somerset UK

Posts: 976
iTrader: (0)

Garage List
Quote:
Originally Posted by 320dlci View Post
Yes I've driven the car for over a week but map is not updating to the location that am at? But I can see the blue arrow moving... How do h get to this secret menu?
Quick search and you'd of found the answer.... 7th post in this thread

http://www.e90post.com/forums/showth...IC+hidden+menu
__________________
Scott

2009 BMW 330d M Sport : 2012 BMW 320d M Sport
ukbeemerboy is offline   United Kingdom
0
Reply With Quote
      01-15-2014, 04:28 AM   #9
bungleaio
Second Lieutenant
 
Drives: 325i E93
Join Date: Mar 2013
Location: Leicester UK

Posts: 244
iTrader: (0)

My factory fit CIC is now giving me the wrong location for the car. I've opened up the service menu and its saying it's seeing 14 satelites but there is no GPS signal.

Is there a way to reset the car so that it will refind the satelites through some button presses or removing the battery? Or is a visit to a dealer with their computer required?
bungleaio is offline  
0
Reply With Quote
      01-15-2014, 12:59 PM   #10
gurpinderp
Private
 
Drives: e92 330i
Join Date: Jun 2012
Location: Windsor, Berkshire

Posts: 60
iTrader: (2)

Quote:
Originally Posted by bungleaio View Post
My factory fit CIC is now giving me the wrong location for the car. I've opened up the service menu and its saying it's seeing 14 satelites but there is no GPS signal.

Is there a way to reset the car so that it will refind the satelites through some button presses or removing the battery? Or is a visit to a dealer with their computer required?
Try holding the volume button down for about 20 secs and let go, it resets the CIC. I commonly drive through a densely populated wood which blocks my car from acquiring a strong enough signal, and this sorts it for me!

Otherwise you can do the service menu GPS location reset fix, also tends to work in my experience.

Happy hunting!
gurpinderp is offline  
0
Reply With Quote
      01-15-2014, 03:13 PM   #11
bungleaio
Second Lieutenant
 
Drives: 325i E93
Join Date: Mar 2013
Location: Leicester UK

Posts: 244
iTrader: (0)

Cheers mate, I'd already tried the power button but it didn't make ay difference.

I reset the location through the service menu and all seems well now.
bungleaio is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:47 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST