E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > BMW iPhone 5 and iOS 6 Functions, Bluetooth and Y-Cable Overview and FAQ



Reply
 
Thread Tools Search this Thread
      11-09-2013, 03:39 AM   #45
alexwhittemore
Lieutenant Colonel
 
Drives: 2009 Crimson 328i
Join Date: Oct 2012
Location: Los Angeles

Posts: 1,682
iTrader: (0)

Quote:
Originally Posted by Koreyy View Post
hey let me know how it goes, i bought cheap adapter from ebay and it only charges the phone no aux. im guessing bc its not original...
That's believable. There are LOTS of active electronics in the Apple adapters to implement all the dock connector functionality.
__________________
alexwhittemore is offline  
0
Reply With Quote
      12-09-2013, 01:30 PM   #46
Brent
Private
 
Drives: 2008 328i E90
Join Date: May 2011
Location: Inland Empire, CA / So Cal

Posts: 74
iTrader: (0)

Quote:
Originally Posted by Koreyy View Post
hey let me know how it goes, i bought cheap adapter from ebay and it only charges the phone no aux. im guessing bc its not original...
Well, I ended up with both the adapter and the adapter with cable. The adapter works - charges and allows me to use my steering wheel controls to control the iPhone. For some reason the cable adapter does NOT work. I get a message that says "device not supported" in my iPhone. Both were from Apple. So I use the adapter that goes lightning to 30 pin, then a 30 pin cable to my BMW splitter, and plug that in to the car's USB and aux in, and it all works now.
Brent is offline  
0
Reply With Quote
      12-09-2013, 01:36 PM   #47
Koreyy
KOrey
 
Drives: 335i Coupe
Join Date: May 2012
Location: Philadelphia

Posts: 547
iTrader: (5)

Garage List
2008 BMW 335i  [0.00]
Quote:
Originally Posted by Brent View Post
Well, I ended up with both the adapter and the adapter with cable. The adapter works - charges and allows me to use my steering wheel controls to control the iPhone. For some reason the cable adapter does NOT work. I get a message that says "device not supported" in my iPhone. Both were from Apple. So I use the adapter that goes lightning to 30 pin, then a 30 pin cable to my BMW splitter, and plug that in to the car's USB and aux in, and it all works now.
finally just bought $29 apple's adapter and it works with my steering wheel and idrive mode.. i guess the cheap ebay ones only charges the phone. now my another problem is that iphone cable from bmw is too short....
Koreyy is offline   United_States
0
Reply With Quote
      12-16-2013, 08:12 PM   #48
smaccona
Registered
 
Drives: 2011 BMW 328i
Join Date: Dec 2013
Location: New York

Posts: 4
iTrader: (0)

Quote:
Originally Posted by alexwhittemore View Post
It's not the type of issue I've ever seen or heard of in a Y cable specifically, but it's certainly the type of thing that could pop up if you have a bad serial chip in the Y cable. And the cable gets temp cycled really hard inside a car, and I wouldn't be surprised if the cheap Ebay cables are built with counterfeit chips to begin with (usually parts that don't pass testing at the factory, but work well enough to fool you). It could even be something like a crappy solder joint, I've certainly opened my cable to resolder it because of intermittent connection issues.

Bottom line, it seems crazy, but you've only got $20 to lose trying a new cable, and it's probably the most likely culprit.
I am having even worse luck with my iPhones. I just acquired a CPO 2011 328xi without iDrive, and the dealer gave me a Y-cable to integrate my iPhone. Here are the applicable codes from entering my VIN into bmwvin.com:

S639A - Preparation f mobile phone cpl. USA/CDN
S6FLA - USB/Audio interface

When I plug the Y-cable into the center console, and either an iPhone 4 or an iPhone 5/5S with Lightning-to-30-pin adapter into the other end of the Y-cable, I can't find any way to access the music on the device. The Audio menu just shows "Tuner", "CD", "Aux" and "USB". Selecting "Aux" switches to Aux but when I play a track on the iPhone, it just comes out of the iPhone speaker. Selecting "USB" displays the message "Insert USB".

I have tried this with:

- iPhone 5S (iOS7) -> Lightning-30pin adapter -> Y-cable -> USB & AUX ports
- iPhone 5S (iOS7) -> Lightning cable -> USB port
- iPhone 5 (iOS7) -> Lightning-30pin adapter -> Y-cable -> USB & AUX ports
- iPhone 5 (iOS7) -> Lightning cable -> USB port
- iPhone 4S (iOS6) -> Y-cable -> USB & AUX ports
- iPhone 4S (iOS6) -> 30-pin adapter -> USB port

I didn't expect the 2nd, 4th and 6th efforts to work, since I believe I need the Y-cable to get audio, but I tried them anyway for completeness.

I also tried all of these with and without Bluetooth enabled.

Anyone have any tips or pointers, or what am I missing?

Thanks!
smaccona is offline  
0
Reply With Quote
      12-16-2013, 09:21 PM   #49
alexwhittemore
Lieutenant Colonel
 
Drives: 2009 Crimson 328i
Join Date: Oct 2012
Location: Los Angeles

Posts: 1,682
iTrader: (0)

Quote:
Originally Posted by smaccona View Post
I am having even worse luck with my iPhones. I just acquired a CPO 2011 328xi without iDrive, and the dealer gave me a Y-cable to integrate my iPhone. Here are the applicable codes from entering my VIN into bmwvin.com:

S639A - Preparation f mobile phone cpl. USA/CDN
S6FLA - USB/Audio interface

When I plug the Y-cable into the center console, and either an iPhone 4 or an iPhone 5/5S with Lightning-to-30-pin adapter into the other end of the Y-cable, I can't find any way to access the music on the device. The Audio menu just shows "Tuner", "CD", "Aux" and "USB". Selecting "Aux" switches to Aux but when I play a track on the iPhone, it just comes out of the iPhone speaker. Selecting "USB" displays the message "Insert USB".

I have tried this with:

- iPhone 5S (iOS7) -> Lightning-30pin adapter -> Y-cable -> USB & AUX ports
- iPhone 5S (iOS7) -> Lightning cable -> USB port
- iPhone 5 (iOS7) -> Lightning-30pin adapter -> Y-cable -> USB & AUX ports
- iPhone 5 (iOS7) -> Lightning cable -> USB port
- iPhone 4S (iOS6) -> Y-cable -> USB & AUX ports
- iPhone 4S (iOS6) -> 30-pin adapter -> USB port

I didn't expect the 2nd, 4th and 6th efforts to work, since I believe I need the Y-cable to get audio, but I tried them anyway for completeness.

I also tried all of these with and without Bluetooth enabled.

Anyone have any tips or pointers, or what am I missing?

Thanks!
Good completeness for sure, that helps. It totally sounds like you have a bunk Y cable, mind posting a picture of it?

EDIT: sorry, you said you got it from the dealer. Better questions: does bluetooth (handsfree) work in your car with either phone? Does USB work with a thumbdrive? Does the phone charge plugged into the Y cable? (You probably need to test this at both like 85-90% battery and 50% battery, it'll work at one and not the other.)
__________________
alexwhittemore is offline  
0
Reply With Quote
      12-16-2013, 09:42 PM   #50
smaccona
Registered
 
Drives: 2011 BMW 328i
Join Date: Dec 2013
Location: New York

Posts: 4
iTrader: (0)

Quote:
Originally Posted by alexwhittemore View Post
Good completeness for sure, that helps. It totally sounds like you have a bunk Y cable, mind posting a picture of it?

EDIT: sorry, you said you got it from the dealer. Better questions: does bluetooth (handsfree) work in your car with either phone? Does USB work with a thumbdrive? Does the phone charge plugged into the Y cable? (You probably need to test this at both like 85-90% battery and 50% battery, it'll work at one and not the other.)
Bluetooth works with all 3 phones for phone functionality only (not music). I can answer and make calls, though I haven't really played with the BMW interface for dialing, I just dialed on the iPhone.

The phones all display the charging icon when plugged into the Y cable (they charge slowly, but I understand from other posts that this is expected). When I plug an iOS7 phone in, I get a message on the phone asking whether to "trust the computer" (paraphrasing from memory), so a connection is being made.

I haven't tried a USB thumb drive yet - I take it dumping a few MP3s onto a FAT32-formatted device should be OK to test?
smaccona is offline  
0
Reply With Quote
      12-16-2013, 10:14 PM   #51
alexwhittemore
Lieutenant Colonel
 
Drives: 2009 Crimson 328i
Join Date: Oct 2012
Location: Los Angeles

Posts: 1,682
iTrader: (0)

Quote:
Originally Posted by smaccona View Post
When I plug an iOS7 phone in, I get a message on the phone asking whether to "trust the computer" (paraphrasing from memory), so a connection is being made.
THERE'S your problem, sparky!

If the device is asking to trust the computer, I'm pretty confident that means the phone is seeing a native USB connection, which implies you have not-the-right Y cable (the right cable has a USB-Serial converter, the phone wouldn't know it's plugged into USB, or indeed a computer of any sort). Which seems pretty unbelievable, since you got it from the dealership. But nobody's perfect. Does your Y cable look (exactly) like this?

http://www.ebay.com/itm/BMW-iDRIVE-I...p2054897.l4276

If not, it doesn't have the right electronics internally.

Incidentally, I just found this: http://www.ebay.com/itm/like/281216401551?lpid=82

I wonder if it works, or if it's BS. Might pick one up just to see, but I don't know of any lightning male-female extension cables in existence, so maybe I won't.
__________________
alexwhittemore is offline  
0
Reply With Quote
      12-17-2013, 12:44 AM   #52
smaccona
Registered
 
Drives: 2011 BMW 328i
Join Date: Dec 2013
Location: New York

Posts: 4
iTrader: (0)

Quote:
Originally Posted by alexwhittemore View Post
THERE'S your problem, sparky!

If the device is asking to trust the computer, I'm pretty confident that means the phone is seeing a native USB connection, which implies you have not-the-right Y cable (the right cable has a USB-Serial converter, the phone wouldn't know it's plugged into USB, or indeed a computer of any sort). Which seems pretty unbelievable, since you got it from the dealership. But nobody's perfect. Does your Y cable look (exactly) like this?

http://www.ebay.com/itm/BMW-iDRIVE-I...p2054897.l4276

If not, it doesn't have the right electronics internally.

Incidentally, I just found this: http://www.ebay.com/itm/like/281216401551?lpid=82

I wonder if it works, or if it's BS. Might pick one up just to see, but I don't know of any lightning male-female extension cables in existence, so maybe I won't.
It doesn't look EXACTLY like that - I've attached a photo.

The cable didn't come in any packaging - I kind of got the impression it was one the dealer had lying around.

Attached Images
 
smaccona is offline  
0
Reply With Quote
      12-17-2013, 01:05 AM   #53
alexwhittemore
Lieutenant Colonel
 
Drives: 2009 Crimson 328i
Join Date: Oct 2012
Location: Los Angeles

Posts: 1,682
iTrader: (0)

Here's a test. Plug it into your computer. If you can sync, the cable is bullshit. It looks exactly like the other non-car Y cables I've seen, I can't believe a dealer gave you one.
alexwhittemore is offline  
0
Reply With Quote
      12-17-2013, 08:13 PM   #54
smaccona
Registered
 
Drives: 2011 BMW 328i
Join Date: Dec 2013
Location: New York

Posts: 4
iTrader: (0)

Quote:
Originally Posted by alexwhittemore View Post
Here's a test. Plug it into your computer. If you can sync, the cable is bullshit. It looks exactly like the other non-car Y cables I've seen, I can't believe a dealer gave you one.
Your test worked. I can see my iPhone in iTunes via the cable + Lightning adapter. I agree it's odd about the dealer - I'll let him know; I have no doubt they'll replace it.

Thanks for all the help - perhaps you can help me with another question: what would I need to do in order to support Bluetooth Audio (A2DP) in my vehicle? I think that S639A only gives me phone call support over Bluetooth, correct (though, oddly, Siri seems to use that profile instead of regular audio)?
smaccona is offline  
0
Reply With Quote
      12-17-2013, 09:19 PM   #55
alexwhittemore
Lieutenant Colonel
 
Drives: 2009 Crimson 328i
Join Date: Oct 2012
Location: Los Angeles

Posts: 1,682
iTrader: (0)

Siri supports headset profile since that includes provisions for a microphone, a2dp is one way. There are lots of threads to search, the short answer is if you have iDrive, combox retrofit, and regardless of iDrive, parrot mki series (bad), Dension gateway 500, or probably best of all, the $100 tune2air wma1000 - it's getting great reviews.
alexwhittemore is offline  
0
Reply With Quote
      12-25-2013, 04:42 PM   #56
Braudham
New Member
 
Drives: 2011 128i - Alpine White
Join Date: Dec 2013
Location: CA

Posts: 8
iTrader: (0)

Hi Alex,

I have the base 6 speaker non i-drive system and one of the dealership techs told me that I couldn't play audio from my iPhone directly through USB because my system doesn't have the combox. I'm stuck using the y cable and the audio is pretty bad. Do you know if this combo retrofit is available for the base audio system?
Braudham is offline  
0
Reply With Quote
      12-25-2013, 05:28 PM   #57
alexwhittemore
Lieutenant Colonel
 
Drives: 2009 Crimson 328i
Join Date: Oct 2012
Location: Los Angeles

Posts: 1,682
iTrader: (0)

Quote:
Originally Posted by Braudham View Post
Hi Alex,

I have the base 6 speaker non i-drive system and one of the dealership techs told me that I couldn't play audio from my iPhone directly through USB because my system doesn't have the combox. I'm stuck using the y cable and the audio is pretty bad. Do you know if this combo retrofit is available for the base audio system?
Base audio system, yes, but you must have iDrive, so your car is still sadly out.
__________________
alexwhittemore is offline  
0
Reply With Quote
      12-26-2013, 12:29 PM   #58
Braudham
New Member
 
Drives: 2011 128i - Alpine White
Join Date: Dec 2013
Location: CA

Posts: 8
iTrader: (0)

Thanks Alex. Maybe it's not the combox after all. Before purchasing my 2011 128i I test drove another 2011 that I now believe had the hifi system. I was able to use the Apple lightning cable on that one with no problem. Do you know if there is a way to gain that capability on my base stereo? Software update, any type of retrofit, replacing the head unit with hifi one?
Braudham is offline  
0
Reply With Quote
      12-26-2013, 02:01 PM   #59
alexwhittemore
Lieutenant Colonel
 
Drives: 2009 Crimson 328i
Join Date: Oct 2012
Location: Los Angeles

Posts: 1,682
iTrader: (0)

Quote:
Originally Posted by Braudham View Post
Thanks Alex. Maybe it's not the combox after all. Before purchasing my 2011 128i I test drove another 2011 that I now believe had the hifi system. I was able to use the Apple lightning cable on that one with no problem. Do you know if there is a way to gain that capability on my base stereo? Software update, any type of retrofit, replacing the head unit with hifi one?
I'm on mobile right now so I can't see, but I recall you're in America? If so, hifi IS the base option. You're certain that car didn't have iDrive? That sounds like it had a combox to me. To the best of my knowledge, even the newer head units with built in USB and Bluetooth still don't support A2DP stereo streaming or USB audio.
alexwhittemore is offline  
0
Reply With Quote
      12-26-2013, 02:11 PM   #60
Braudham
New Member
 
Drives: 2011 128i - Alpine White
Join Date: Dec 2013
Location: CA

Posts: 8
iTrader: (0)

Yes, I'm in US. I read somewhere for for the 2010 & 2011 year, BMW sold vehicles with the base 6 speaker setup. I believe the one I test drove had tweeters but they weren't the Harmon Kardon ones.
Braudham is offline  
0
Reply With Quote
      01-15-2014, 08:27 PM   #61
IMLH
IMLHE93
 
IMLH's Avatar
 
Drives: 09 335 White hard top convert
Join Date: Jan 2014
Location: N. Texas

Posts: 9
iTrader: (0)

2009 E93 with the idrive system and an apple iPhone 5s. All I can say - pure misery. Great car to drive but OMG - bluetooth is a nightmare. My solution is to break the law and put the cell phone to my ear in school zones and roll the dice.
I've been told the Tune2Air 1000 is a solid fix for audio streaming - but I need a reliable bluetooth connection for speaking while driving. It appears in 2009 BMW could not get this right.
IMLH is offline   United_States
0
Reply With Quote
      01-15-2014, 08:38 PM   #62
alexwhittemore
Lieutenant Colonel
 
Drives: 2009 Crimson 328i
Join Date: Oct 2012
Location: Los Angeles

Posts: 1,682
iTrader: (0)

Quote:
Originally Posted by IMLH View Post
2009 E93 with the idrive system and an apple iPhone 5s. All I can say - pure misery. Great car to drive but OMG - bluetooth is a nightmare. My solution is to break the law and put the cell phone to my ear in school zones and roll the dice.
I've been told the Tune2Air 1000 is a solid fix for audio streaming - but I need a reliable bluetooth connection for speaking while driving. It appears in 2009 BMW could not get this right.
The Tune2air absolutely rocks, but you're right, doesn't help you out here. What's your problem, exactly, just instability and unreliability? Poor audio quality? Something else? 2009/no idrive/iphone5 works great for me. The audio quality is pretty bad, but that's true of the handset profile in general - the clarity is just fine and the other end never complains.

There are a bunch of solutions, but none of them super perfect. If you give more details about what in particular you don't like, maybe one fits well.
__________________
alexwhittemore is offline  
0
Reply With Quote
      01-22-2014, 05:38 PM   #63
ericgt79
New Member
 
Drives: 08 335i Sedan
Join Date: Aug 2013
Location: Killeen, Tx

Posts: 5
iTrader: (0)

im so lost on this crap, i dont have iDrive and im trying to make my ipone work and my steering controls. I have the yDrive cable but it only plays music thru aux setting. what am i doing wrong or what else can i get to make this work? is there a way for me to get connect drive or is that the nav system screen?
ericgt79 is offline  
0
Reply With Quote
      01-22-2014, 06:11 PM   #64
alexwhittemore
Lieutenant Colonel
 
Drives: 2009 Crimson 328i
Join Date: Oct 2012
Location: Los Angeles

Posts: 1,682
iTrader: (0)

Quote:
Originally Posted by ericgt79 View Post
im so lost on this crap, i dont have iDrive and im trying to make my ipone work and my steering controls. I have the yDrive cable but it only plays music thru aux setting. what am i doing wrong or what else can i get to make this work? is there a way for me to get connect drive or is that the nav system screen?
"Connected drive" does require iDrive, yes, and in particular a newer version of it. Post a picture of your Y cable. Chances are, it's either not the right type (they sell generic charge+aux out cables, BMWs is more specific) or it's broken.
__________________
alexwhittemore is offline  
0
Reply With Quote
      01-24-2014, 04:37 PM   #65
mschuler
Registered
 
Drives: 2012 335is cab
Join Date: Jul 2013
Location: Burkington, ON

Posts: 4
iTrader: (0)

I have no problems with Bluetooth phone calls in my 2012 335is convertible using an iPhone 5. I do have problems with Office. I do not get emails or text messages. Is the calendar supposed to show up as well?
mschuler is offline   Canada
0
Reply With Quote
      02-12-2014, 02:40 PM   #66
mikelord7
Private
 
mikelord7's Avatar
 
Drives: 2010 335XI 6MT
Join Date: Jan 2014
Location: Exton, PA

Posts: 84
iTrader: (1)

When I play songs through my iphone (ycable with apple adapter), only the track name shows up on the car display (non idrive). Is there a way to set it so the artist and track name show up on the display?

I've searched and read the manual with no luck.

thanks
mikelord7 is offline  
0
Reply With Quote
Reply

Bookmarks

Tags
bmw ios 6, bmw ios6, bmw iphone, bmw iphone 5, bmw iphone 5 adapter, bmw iphone 5 bluetooth, bmw iphone 5 cradle, bmw iphone 5 snap in adapter, bmw iphone 5 y-cable, bmw iphone adapter, bmw iphone snap-in adapter, bmw iphone5, bmw iphone5 adapter, bmw iphone5 bluetooth, bmw iphone5 cradle, bmw iphone5 snap in adapter, bmw iphone5 y-cable, ios 6 bmw, ios6 bmw, iphone 5 bmw adapter, iphone 5 bmw cradle, iphone 5 bmw snap in adapter, iphone bmw adapter, iphone bmw snap in adapter, iphone5 bmw adapter, iphone5 bmw cradle

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:44 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST