E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > [Video Guide] Full BMW Coding Setup



Reply
 
Thread Tools Search this Thread
      10-25-2013, 02:56 PM   #177
Nedal0
New Member
 
Drives: E93
Join Date: Oct 2013
Location: North West, UK

Posts: 14
iTrader: (0)

Can anyone please provide me with links to the installation files ?

Edit: Found it. Nevermind !

Last edited by Nedal0; 10-25-2013 at 03:01 PM.
Nedal0 is offline  
0
Reply With Quote
      11-14-2013, 05:01 AM   #178
seatac
Registered
 
Drives: 2008 335i N54 E93
Join Date: Nov 2011
Location: Seattle, WA

Posts: 1
iTrader: (0)

Please help, getting error during press F5.

Have no problem read CAS module, but trying read MAN file (F5) got an error below. Yes, I download tools 2.12 v49 and follow this DIY.

COAPI-2041: Wrong ECU coding index A_PL2KMB: COBIERINDEX = 08h
KMBI_PL2.C05: CODIERINDEX = 05
COAPI-2041: Wrong ECU coding index CODIERDATEN_LESEN
COAPI-2041: Wrong ECU coding index A_PL2KMB
COAPI-2041: Error


here is my I-Level:
---------------------------------
apiJob("E89X","i_stufe_lesen","","job_status;i_stu fe_werk;i_stufe_ho;i_stufe_ho_backup;_tel_auftrag; _tel_antwort")

Satz : 0
OBJECT = e89x
SAETZE = 1
JOBNAME = i_stufe_lesen
VARIANTE = E89X
JOBSTATUS =
UBATTCURRENT = -1
UBATTHISTORY = -1
IGNITIONCURRENT = -1
IGNITIONHISTORY = -1
Satz : 1
JOB_STATUS = OKAY
I_STUFE_WERK = E89X-07-12-515
I_STUFE_HO = E89X-10-03-502
I_STUFE_HO_BACKUP = E89X-09-09-516
_TEL_AUFTRAG = 6 Bytes
0000 : 83 72 F1 22 10 0B ?r"..
_TEL_ANTWORT = 13 Bytes
0000 : 89 F1 72 62 10 0B 00 ED 33 CA 29 D8 54 ?rb... 3)T
seatac is offline  
0
Reply With Quote
      11-20-2013, 01:34 PM   #179
Supra98
Private First Class
 
Drives: E92 335i
Join Date: Sep 2011
Location: Gahanna, Ohio

Posts: 142
iTrader: (1)

Can someone PM me the link to these files? Thanks!
Supra98 is offline  
0
Reply With Quote
      12-02-2013, 11:13 AM   #180
E36graduate
Lieutenant
 
E36graduate's Avatar
 
Drives: 2008 335xi Sport 6MT
Join Date: Nov 2010
Location: Southeastern MASS

Posts: 407
iTrader: (0)

CAN someone post a sticky with the links to the INPA-EDIABAS and other necessary software????? I'm getting tired of going through post after post trying to figure out which software to use and WHERE to get it? I've tried a half dozen recommended sites and the download doesn't exist...except one that said it would take 160 hours to download?

Quote:
Originally Posted by Supra98 View Post
Can someone PM me the link to these files? Thanks!
__________________

2008 335xi - 6MT - BMS JB4 G5i - BMS DCI - BMS OCC - BMS WW Meth - Spec Stage 2+ - Spec SMFW - 19" MVR Magnum's - KW V1's - TMS 12.5+20mm Spacers
E36graduate is offline  
0
Reply With Quote
      12-02-2013, 06:14 PM   #181
cranelec
New Member
 
Drives: BMW
Join Date: Nov 2013
Location: NEPA

Posts: 5
iTrader: (0)

Garage List
2007 BMW 328xi  [0.00]
I just wanted to say "THANK YOU!" Great video. I read most of the "coding success" thread and was inspired and dejected. Like you downloaded Gbytes of headaches. Thanks for saving me all that time!
cranelec is offline  
0
Reply With Quote
      12-03-2013, 10:41 AM   #182
fmonteiro444
First Lieutenant
 
fmonteiro444's Avatar
 
Drives: 09 335i X-Drive
Join Date: Feb 2013
Location: NJ

Posts: 368
iTrader: (5)

Garage List
Quote:
Originally Posted by Martin93 View Post
First of all, thanks for this guide.

Could you please look over the link for the download of the sgdat folder. I can't get the link to work.
Same here. I got coding to work with NCSexpert but INPA will not work because there are no IPO files in the ECU folder.
__________________
09 335xi - DCI, CP-E CP w/Tial, JB4 w/custom flash, E45, 50/50 meth, Alpina Flash - 12.4 @115
fmonteiro444 is offline  
0
Reply With Quote
      01-01-2014, 10:53 AM   #183
nycfin3st
New Member
 
Drives: 2006 330i sport
Join Date: Sep 2013
Location: NYC/Springfield, MA

Posts: 20
iTrader: (0)

Can somebody pm me the links...having passenger occupancy sensor issues
nycfin3st is offline  
0
Reply With Quote
      01-01-2014, 05:33 PM   #184
335powers
New Member
 
Drives: 2009 335xi
Join Date: Sep 2012
Location: SoCal

Posts: 6
iTrader: (0)

Experiencing two issues with the install.

INPA loads and i get the full black dots for battery and ignition but i only get F1(Info) F2(script) and F10(End). When selecting F2 i get an error since no .ipo files are located in the folder. ( i believe its looking in the INPA/BIN folder. I copied the E89 ecu folders contents into the SGDAT folder in the INPA directory per the following post.

"2nd note: For the inpa working, dont use the inpa folder in the guide. Copy over the "ecu" folder from the E89 daten into the SGDAT folder in your inpa directory"

In NCS expert
I have created a new expert profile and changed profile info to "FSW PSW MAN" but after reading the CAS module, my VIN and FA shows however i get an COAPI-1020 error.

This translates to "file could not be opened for reading" and is looking in "C:\NCSEXPER\WORK\FSW_PSW.MAN"

I followed the instructions with the only exception being that after changing the profile info from expert to "FSW PSW MAN" i had to save the profile, close NCSEXPER, and then reopen the FSW PSW MAN profile, otherwise i would just see expert profiles rather than the new FSW PSW MAN. Any ideas how to correct this error would be greatly appreciated.

~AP
335powers is offline  
0
Reply With Quote
      01-04-2014, 07:06 PM   #185
lfelunden
First Lieutenant
 
lfelunden's Avatar
 
Drives: Alpina B3S Biturbo Coupe
Join Date: Aug 2011
Location: German Autobahn

Posts: 321
iTrader: (0)

Garage List
Any link to standard tools 2.12, INPA 5.0.6??
__________________
Alpina B5S doing 330kmh/205mph for more than 1 minute: http://www.youtube.com/watch?v=hGizo...9gVs9cAUP05Zk=
lfelunden is offline   Germany
0
Reply With Quote
      01-05-2014, 07:28 AM   #186
lfelunden
First Lieutenant
 
lfelunden's Avatar
 
Drives: Alpina B3S Biturbo Coupe
Join Date: Aug 2011
Location: German Autobahn

Posts: 321
iTrader: (0)

Garage List
Not sure if stated, but the link doesn't work I got INPA 5.0.2 and ediabia 7.3.0?? I'm downloading daten for E89 atm. I need the 5.0.6 INPA as I got the MSD81 ecu on my Alpina B3s biturbo
__________________
Alpina B5S doing 330kmh/205mph for more than 1 minute: http://www.youtube.com/watch?v=hGizo...9gVs9cAUP05Zk=
lfelunden is offline   Germany
0
Reply With Quote
      01-09-2014, 08:35 PM   #187
CJD3
Enlisted Member
 
CJD3's Avatar
 
Drives: 2007 328xi
Join Date: Aug 2013
Location: Wisconsin

Posts: 40
iTrader: (0)

Garage List
2007 328xi  [0.00]
where can i get that BMW standard tools from? Im trying to follow this DIY and looked everywhere on the internet for it but cant find it.

EDIT: Nevermind I found it! Thanks

Last edited by CJD3; 01-09-2014 at 09:11 PM.
CJD3 is offline  
0
Reply With Quote
      01-09-2014, 10:59 PM   #188
CJD3
Enlisted Member
 
CJD3's Avatar
 
Drives: 2007 328xi
Join Date: Aug 2013
Location: Wisconsin

Posts: 40
iTrader: (0)

Garage List
2007 328xi  [0.00]
I got the program working! Excellent video, thank you so much for taking the time to put it together!
CJD3 is offline  
0
Reply With Quote
      01-21-2014, 10:00 PM   #189
ksspacegray07
Lieutenant
 
Drives: 335is coupe
Join Date: Nov 2009
Location: NY

Posts: 520
iTrader: (1)

ok i've tried so many tutorials and this once seemed promising...
Im running windows 7 32 bit via parallels on my mac
I have a 2011 335is and a kdcan cable off ebay which i unsoldering the connection to 7-8 pin

i run inpa and both circles are black but i dont get to choose my chasis
i then run ncsexpert and get to choose my chasis and then cas and i get this erorr

what am I doing wrong..I've spent decades on this tried it on an actual pc with windows and other tutorials..is it the cable?
Attached Images
 
ksspacegray07 is offline   United_States
0
Reply With Quote
      01-22-2014, 08:15 AM   #190
PichaDis11
Captain
 
PichaDis11's Avatar
 
Drives: 08 328i
Join Date: Mar 2013
Location: NY

Posts: 902
iTrader: (2)

Quote:
Originally Posted by ksspacegray07
ok i've tried so many tutorials and this once seemed promising...
Im running windows 7 32 bit via parallels on my mac
I have a 2011 335is and a kdcan cable off ebay which i unsoldering the connection to 7-8 pin

i run inpa and both circles are black but i dont get to choose my chasis
i then run ncsexpert and get to choose my chasis and then cas and i get this erorr

what am I doing wrong..I've spent decades on this tried it on an actual pc with windows and other tutorials..is it the cable?
If you follow this tut to the t and still have errors I would most likely say that it is the cable. To be sure, there are other members running the software on a Mac so do check with them if you can to iron some issues with virtualization if any.

If not the cable from Onestop is down right just great.
__________________
Retrofitted: CIC iDrive System With MULF2 USB & Bluetooth. Combox coming soooon , Auto-Dimming Interior Mirror, LCI Halogen Head Lights, Wheels, ECS Geomet Slotted Rotors, Akebono Pads... And coded.
.. And Some Dipped Pieces
PichaDis11 is offline   United_States
0
Reply With Quote
      01-31-2014, 10:47 AM   #191
330xtrai
Do you even post BRO?
 
330xtrai's Avatar
 
Drives: 330xi
Join Date: Jun 2012
Location: New Jersey

Posts: 1,747
iTrader: (1)

Garage List
2006 BMW 330xi  [0.00]
I cant get inpa airbag test or basically anything else other than the black dots on inpa to work i beleive that im missing a bunch of .ipo files n the sgdat file. the link doesnt work in OP if anyone else has a fix please lmk!
also the other programs work i coded using toolset32 and worked perfectly fine.
thanks
330xtrai is offline   United_States
0
Reply With Quote
      01-31-2014, 11:17 AM   #192
WRichieX
Captain
 
WRichieX's Avatar
 
Drives: 07 335i e93 6MT
Join Date: May 2013
Location: Chicago

Posts: 937
iTrader: (0)

Garage List
sub'd for when I try this when weather gets nicer.
__________________

07 BMW 335i E93 6MT (Praying neighborhood doesn't get flooded...again)
04 Infiniti G35 Coupe 6MT (Flooded)
08 Audi TT 2.0T DSG (Flooded)
03 Subaru WRX 5MT (Flooded)
WRichieX is offline   United_States
0
Reply With Quote
      01-31-2014, 12:40 PM   #193
fmonteiro444
First Lieutenant
 
fmonteiro444's Avatar
 
Drives: 09 335i X-Drive
Join Date: Feb 2013
Location: NJ

Posts: 368
iTrader: (5)

Garage List
Quote:
Originally Posted by 330xtrai View Post
I cant get inpa airbag test or basically anything else other than the black dots on inpa to work i beleive that im missing a bunch of .ipo files n the sgdat file. the link doesnt work in OP if anyone else has a fix please lmk!
also the other programs work i coded using toolset32 and worked perfectly fine.
thanks
I can give you my sgdat files. Send me a pm.
__________________
09 335xi - DCI, CP-E CP w/Tial, JB4 w/custom flash, E45, 50/50 meth, Alpina Flash - 12.4 @115
fmonteiro444 is offline  
0
Reply With Quote
      01-31-2014, 06:08 PM   #194
330xtrai
Do you even post BRO?
 
330xtrai's Avatar
 
Drives: 330xi
Join Date: Jun 2012
Location: New Jersey

Posts: 1,747
iTrader: (1)

Garage List
2006 BMW 330xi  [0.00]
Quote:
Originally Posted by fmonteiro444 View Post
I can give you my sgdat files. Send me a pm.
Thanks!
330xtrai is offline   United_States
0
Reply With Quote
      01-31-2014, 06:11 PM   #195
fmonteiro444
First Lieutenant
 
fmonteiro444's Avatar
 
Drives: 09 335i X-Drive
Join Date: Feb 2013
Location: NJ

Posts: 368
iTrader: (5)

Garage List
Quote:
Originally Posted by 330xtrai View Post
Thanks!
Let me know how you make out.
__________________
09 335xi - DCI, CP-E CP w/Tial, JB4 w/custom flash, E45, 50/50 meth, Alpina Flash - 12.4 @115
fmonteiro444 is offline  
0
Reply With Quote
      02-09-2014, 09:06 PM   #196
rfkhan28
Registered
 
Drives: e90 320i
Join Date: Jan 2014
Location: new jersey

Posts: 1
iTrader: (0)

hello

how r u...this is my first post on this forum and I am new to this so here is my situation..... I currently live in new York and my parents reside in Trinidad...my father purchased a 2009 320i from japan and imported it to Trinidad and everything works great except that the radio is tuned to japans frequency which is a problem because Trinidad has the same fm frequency an usa I know that the radio can be coded to work but are there any hidden menus that can be accessed to change this without hooking it up to a pc or is coding it the only way..i will be leaving in a couple weeks to go down there and try to reprogram if it needs to but any help would be greatly appreciated..

thank you in advance
rishi
rfkhan28 is offline  
0
Reply With Quote
      02-10-2014, 07:14 AM   #197
BMW..
Lieutenant
 
Drives: E46 M3 /E90
Join Date: May 2013
Location: Boca Raton FL

Posts: 585
iTrader: (0)

Quote:
Originally Posted by rfkhan28
how r u...this is my first post on this forum and I am new to this so here is my situation..... I currently live in new York and my parents reside in Trinidad...my father purchased a 2009 320i from japan and imported it to Trinidad and everything works great except that the radio is tuned to japans frequency which is a problem because Trinidad has the same fm frequency an usa I know that the radio can be coded to work but are there any hidden menus that can be accessed to change this without hooking it up to a pc or is coding it the only way..i will be leaving in a couple weeks to go down there and try to reprogram if it needs to but any help would be greatly appreciated..

thank you in advance
rishi
Hey rishi. Turn car on. Turn radio off. Right when turning radio back on hold the M button next to the arrows until a menu pops up. I've never used this before but it should be in there. Good luck
__________________
Mystic Blue E90
Phoenix Yellow E46
BMW.. is offline  
0
Reply With Quote
      02-23-2014, 10:57 PM   #198
blk08e92
Private
 
Drives: 2008 BMW e92 Coupe
Join Date: Nov 2011
Location: Huntsville, AL.

Posts: 66
iTrader: (0)

Link to files??? Anyone feel free to pm me with a link! I have ncsexpert working, just need the alpina flash and winkfp
blk08e92 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:09 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST