E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > CEL & Limp mode today???



Reply
 
Thread Tools Search this Thread
      11-26-2007, 02:41 PM   #1
Gran Coopay
Enlisted Member
0
Rep
39
Posts

 
Drives: 2013 650i Gran Coupe SG
Join Date: Nov 2007
Location: AZ

iTrader: (0)

CEL & Limp mode today???

Today heading to work like normal and an IS350 is tailgating me. I PROcede'd to toast him. In manual/step I drop from 6th to 4th and go from 80 - 105 or so, then limp mode and "service engine soon" lights come on. I have v1.47 and have had the boost target limp mode before, but this was different. I still had power, sort of, but when I accelerated a violent shutter began. I pulled off the freeway to restart, and as i'm slowing to pullover all the CEL's went off and it feels about only 85% as before. Has anyone else had this happen?
Appreciate 0
      11-26-2007, 02:48 PM   #2
shiv@vishnu
Tuner
United_States
702
Rep
17,616
Posts

 
Drives: X1, 335i
Join Date: Sep 2006
Location: SF Bay, CA

iTrader: (0)

Quote:
Originally Posted by AZ_E90 View Post
Today heading to work like normal and an IS350 is tailgating me. I PROcede'd to toast him. In manual/step I drop from 6th to 4th and go from 80 - 105 or so, then limp mode and "service engine soon" lights come on. I have v1.47 and have had the boost target limp mode before, but this was different. I still had power, sort of, but when I accelerated a violent shutter began. I pulled off the freeway to restart, and as i'm slowing to pullover all the CEL's went off and it feels about only 85% as before. Has anyone else had this happen?
What you got was knock retard. Did you fill up with bad gas? IIRC, AZ is like CA in that you only get 91oct. This makes picking a quality gas station critical. Does anyone else drive your car? Could they have filled up with regular?

As for being down on power, that's normal if you got knock activity. Power will slowly creep back up once the ECU confirms that everything is back to normal. Just run out the tank of gas and fill it up again with some quality gas.

Shiv
Appreciate 0
      11-26-2007, 02:51 PM   #3
Driver72
Brigadier General
108
Rep
4,485
Posts

 
Drives: 335i - to new owners now.
Join Date: Dec 2006
Location: California

iTrader: (0)

Did you recently fill up or put gas in?

I got that from a couple times on my sedan when I was on v1.2 and v1.4
Like you, it would clear pretty quickly though and all was fine after that.

I have never gotten a limp with v1.47 on my auto coupe though.

If it cleared right away you should be fine, you probably just didn't hit the boost target or if you recently filled up, maybe got a bad batch of gas.

It is the shuttering you mentioned that might be a concern.
That has never happened to me and sounds like it could be the fuel pump issue.

How many miles on your car?
When was it made?
Appreciate 0
      11-26-2007, 02:53 PM   #4
Driver72
Brigadier General
108
Rep
4,485
Posts

 
Drives: 335i - to new owners now.
Join Date: Dec 2006
Location: California

iTrader: (0)

Ahh, Shiv snuck in the post before I got a chance to respond too.

Stick with Chevron, Shell or Union 76 if you can.
Appreciate 0
      11-26-2007, 03:01 PM   #5
Gran Coopay
Enlisted Member
0
Rep
39
Posts

 
Drives: 2013 650i Gran Coupe SG
Join Date: Nov 2007
Location: AZ

iTrader: (0)

Quote:
Originally Posted by shiv@vishnu View Post
What you got was knock retard. Did you fill up with bad gas? IIRC, AZ is like CA in that you only get 91oct. This makes picking a quality gas station critical. Does anyone else drive your car? Could they have filled up with regular?

As for being down on power, that's normal if you got knock activity. Power will slowly creep back up once the ECU confirms that everything is back to normal. Just run out the tank of gas and fill it up again with some quality gas.

Shiv
I put Shell 91 in it last. The station was sort of seedy though and was a "cash discount" type of place, but still Shell. Should that matter? Anyways, i'll run this tank out, thanks.
Appreciate 0
      11-26-2007, 03:04 PM   #6
e90AW335i
Major General
United_States
81
Rep
6,608
Posts

 
Drives: e90 335i
Join Date: Sep 2007
Location: ......

iTrader: (4)

Quote:
Originally Posted by AZ_E90 View Post
I put Shell 91 in it last. The station was sort of seedy though and was a "cash discount" type of place, but still Shell. Should that matter? Anyways, i'll run this tank out, thanks.
Not saying this is the same situation, but I had a gas station doing a deal like that and they actually watered down the gas.....
Appreciate 0
      11-26-2007, 03:21 PM   #7
shiv@vishnu
Tuner
United_States
702
Rep
17,616
Posts

 
Drives: X1, 335i
Join Date: Sep 2006
Location: SF Bay, CA

iTrader: (0)

Quote:
Originally Posted by AZ_E90 View Post
I put Shell 91 in it last. The station was sort of seedy though and was a "cash discount" type of place, but still Shell. Should that matter? Anyways, i'll run this tank out, thanks.
If it was "seedy", i'd chalk it up to that. Still with a reputable gas station and you'll be good to go

Shiv
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:34 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST