E90Post
 


PYSPEED
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > weak AC?



Reply
 
Thread Tools Search this Thread
      03-02-2006, 12:27 AM   #1
KevinC
your average JAMF
 
KevinC's Avatar
 
Drives: '07 Z4MC, '05 330Ci ZHP
Join Date: Oct 2005
Location: Chandler, AZ

Posts: 1,468
iTrader: (0)

weak AC?

I hope not! Living here in hell (errr I mean Phoenix), weak AC is NOT an option. I'd read something in the C&D article months ago that they thought the AC was weak.. then read something else later saying it was fine. It was ~ 85 over the weekend and I fired the sucker up for the first time, and was amazed at the moderate airflow at full fan speed. Lots of racket, not much air for being the highest setting. Air temp seemed OK, it was the volume that concerns me.

For those of you who had your cars during the summer last year, how would you rate the AC performance?
__________________
'05 330Ci ZHP ..PD99819______________'07 Z4M Coupe ..LL93707
KevinC is offline  
0
Reply With Quote
      03-02-2006, 12:32 AM   #2
arcrox
E90post addict
 
arcrox's Avatar
 
Drives: 2006 E90 325i
Join Date: Sep 2005
Location: Scottsdale, AZ (BMW city)

Posts: 475
iTrader: (0)

Garage List
2006 325i  [0.00]
When I drive alone I just shut off the rear vents and the right side passenger vent, and override the automatic setting to just blow air from the other three vents at my face. Running it at 3 bars is plenty to cool me off and it's not too noisy...even though I am usually blasting some music.
arcrox is offline  
0
Reply With Quote
      03-02-2006, 01:00 AM   #3
Oz
Lieutenant Colonel
 
Oz's Avatar
 
Drives: 2006 330i, 2004 X5
Join Date: Aug 2005
Location: Wayne, NJ

Posts: 1,770
iTrader: (1)

Garage List
2006 330i  [0.00]
Send a message via AIM to Oz Send a message via MSN to Oz
I have driven my car in August ( got my car on 8/15 so it was pretty hot in NJ) and haven't really had an issue with the AC.
__________________
2006 330i Steptronic/Alpine White/Black Leather/Burl Walnut Trim/Premium Package/iDrive/Heated Seats/Winter: STYLE 159 Blizzak LM-22 RFT/Summer: TBD
2004 X5 Steptronic/Alpine White/Grey Leather/Poplar Trim/Premium Package/Heated Seats/iPod Adapter
Oz is offline   United_States
0
Reply With Quote
      03-02-2006, 01:14 AM   #4
deutsch100
2006 330i, 2003 Z8 Alpina, 2005 G55 Kompressor
 
Drives: 2006 330i
Join Date: Dec 2005
Location: Hollywood, CA

Posts: 149
iTrader: (0)

I'm very disappointed with the AC in my E90. I have had like 4-5 other Bimmers, and the AC was awesome. In my 330i, it is cold, but it just doesn't blow. Even if I override Auto, and put it to maximum fan speed..it just isn't that strong. I like to use the Auto function, but it seems that it sets the fan speed so low, that I bake in the car.
Don't know if I should just let it go, or make a service appt.
__________________

2006 330i Sparkling Graphite with Black Dakota Leather
Premium and Sport Packages
Steptronic Transmission
Satellite Radio
CD & Alarm
(oOO \ (||||)(||||) / OOo)
deutsch100 is offline  
0
Reply With Quote
      03-02-2006, 03:11 AM   #5
Dizzy330i
Private
 
Dizzy330i's Avatar
 
Drives: BMW 330i
Join Date: Dec 2005
Location: Miami, FL USA

Posts: 95
iTrader: (0)

Garage List
2006 330i  [0.00]
How about the "max" button? I pushed it almost instinctively as soon as I would get in the car all throughout last August. It gets pretty hot down here too, but the AC hasn't been bad at all for me.
__________________
2006 330i SG/Terra ZPP Step OEM Spoiler...and Blacklines!!
Dizzy330i is offline  
0
Reply With Quote
      03-02-2006, 03:36 AM   #6
carl_d
General
 
carl_d's Avatar
 
Drives: E90 335i M-Sport N55 6SP Nov10
Join Date: May 2005
Location: UK

Posts: 681
iTrader: (0)

This sounds like the AC gas needs topping up?

Quote:
Originally Posted by deutsch100
I'm very disappointed with the AC in my E90. I have had like 4-5 other Bimmers, and the AC was awesome. In my 330i, it is cold, but it just doesn't blow. Even if I override Auto, and put it to maximum fan speed..it just isn't that strong. I like to use the Auto function, but it seems that it sets the fan speed so low, that I bake in the car.
Don't know if I should just let it go, or make a service appt.
carl_d is offline   United Kingdom
0
Reply With Quote
      03-02-2006, 03:42 AM   #7
Pretender
Colonel
 
Pretender's Avatar
 
Drives: 2006 330i, 2007 328i
Join Date: Aug 2005
Location: Bay Area, CA

Posts: 2,292
iTrader: (1)

Garage List
06 330i  [0.00]
No problem for me. I usually used "max" for a few minutes then switch to auto at 68F recycle mode. If driving alone, I also used the closer passenger's vent for my face and closed the rear one.
Pretender is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:36 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST