E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > Idrive/Nav System freezing up



Reply
 
Thread Tools Search this Thread
      01-03-2008, 07:24 AM   #1
torgo
New Member
1
Rep
5
Posts

 
Drives: BMW 325i
Join Date: Jul 2005
Location: RSA

iTrader: (0)

Idrive/Nav System freezing up

Hi

I had experienced this once or twice before but it seems to be more often. While driving, the radio cuts out and it seems like the nav screen has frozen. If youy press menu or idrive controller, it takes 4 to 5 seconds before it responds and at that stage the radio come alive again. Looks like teh system is freezing up occassionaly.

Also happed once is that during this ferezing up moment teh Idrive screen went blank with lines across it. I switched off for 15 minutes and then it came back..

Anyone experience thsi failure? Software or hardware related!
Appreciate 0
      01-03-2008, 07:43 AM   #2
Placey
First Lieutenant
Placey's Avatar
United_States
3
Rep
367
Posts

 
Drives: 08 Z4 3.0SI
Join Date: Feb 2007
Location: Upstate New York

iTrader: (1)

Most likely software issue, however it could be a failure of the nav system. either way, you will have to take this to the dealer and expect to receive it next day due to diagnosis/programming.

I have seen this problem before, sometimes it does require replacement of the nav system (CCC), sometimes just programming
Appreciate 0
      01-03-2008, 10:21 AM   #3
Gripster
Captain
Gripster's Avatar
United_States
19
Rep
923
Posts

 
Drives: F10 535 M-Sport
Join Date: May 2005
Location: San Diego

iTrader: (5)

Garage List
Quote:
Originally Posted by torgo View Post
Hi

I had experienced this once or twice before but it seems to be more often. While driving, the radio cuts out and it seems like the nav screen has frozen. If youy press menu or idrive controller, it takes 4 to 5 seconds before it responds and at that stage the radio come alive again. Looks like teh system is freezing up occassionaly.

Also happed once is that during this ferezing up moment teh Idrive screen went blank with lines across it. I switched off for 15 minutes and then it came back..

Anyone experience thsi failure? Software or hardware related!
I had this happen twice over 12 months. It really didn't bother me, but when I told the dealer he swapped out the CCC and replaced the idrive screen. The car was updated to Progman 27, which I love.

Tell your dealer - he should get it taken care of. Apparently the car logs these events, so you won't even have to demonstrate it.
__________________
2006 330i - ZSP/ZPP/ZCW/i-Drive/Steptronic Sold
Appreciate 0
      01-03-2008, 11:54 AM   #4
Blue328xi
Private First Class
4
Rep
188
Posts

 
Drives: 328xi
Join Date: Sep 2006
Location: NY

iTrader: (0)

I once had the whole idrive crash while I was using the radio, unfortunately I didnt know the reboot procedure so I had to drive with a half working iDrive.

Seems something is screwey with the way iDrive manages the radio, seems very sluggish.
__________________
2007 328xi - Montego Blue - Black Dakota Leather - Gray poplar - Auto - Nav - IPod - Heated Seats - Sport & Premium
Appreciate 0
      01-03-2008, 02:28 PM   #5
addy85
Got beef?
addy85's Avatar
United_States
55
Rep
3,646
Posts

 
Drives: E90 335i
Join Date: Oct 2007
Location: Arlington Texas

iTrader: (4)

Garage List
2007 335i  [0.00]
My iDrive has frozen a couple of times and I couldnt listen to the radio or do anything!
__________________

Special Thanks to AU335
Appreciate 0
      01-07-2008, 05:42 PM   #6
highlander777
Private
0
Rep
58
Posts

 
Drives: BMW 330D M Touring (62)
Join Date: Mar 2005
Location: Herts, UK

iTrader: (0)

My iDrive Crashed. Getting a new CCC

Hi

My iDrive crashed. Today, BMW are replacing the whole unit and they cannot eject the DVD and my CD. They claim that the unit will need to be sent back to Germany, so they can extract the DVD and CD then send back. Surely it would be easier to give me the lastest DVD Nav :-), I will propose that tomorrow, wish me luck
Appreciate 0
      01-31-2008, 01:58 PM   #7
Tommy420
peace.love.health.happine ss
Tommy420's Avatar
14
Rep
631
Posts

 
Drives: 2008 335i e92 Montego/Blk lthr
Join Date: Nov 2007
Location: Los Angeles

iTrader: (0)

This happens to me every now and then...it doesn't disrupt the music/radio I'm listening to, but sometimes the idrive freezes up for a couple of seconds...i just chalk it up to normal glitches in the computer. Wonder if I should mention it to my dealer?
__________________
2008 335i e92 Montego blue/black leather, alum brush trim, MT, ZSP, ZPP, nav, ipod/usb, sirius, alum brush e-brake, alum pedals, 35% Madico

For pics of my ride, go to www.e90post.com/forums/showthread.php?t=108628
Appreciate 0
      02-01-2008, 09:02 AM   #8
Zephyr15
Second Lieutenant
Zephyr15's Avatar
United_States
5
Rep
296
Posts

 
Drives: '07 e90 335i
Join Date: Jun 2007
Location: NJ

iTrader: (0)

Quote:
Originally Posted by torgo View Post
I had experienced this once or twice before but it seems to be more often. While driving, the radio cuts out and it seems like the nav screen has frozen. If youy press menu or idrive controller, it takes 4 to 5 seconds before it responds and at that stage the radio come alive again. Looks like teh system is freezing up occassionaly.

Also happed once is that during this ferezing up moment teh Idrive screen went blank with lines across it. I switched off for 15 minutes and then it came back..

Anyone experience thsi failure? Software or hardware related!
Similar thing happened to me last night. I drove home and quickly changed for a vball match. Start it up about 10 minutes later on my way out and its stuck on one Sirius preset and the idrive will display that it has changed stations, but the same one keeps playing. I turn the car off and restart at a stop light 1 minute later. Now, the screen is frozen on the same radio station and won't even display new inputs, plus no bluetooth. Drive 2 miles to a stop light and restart again. Screen frozen on the main menu, I get a signal that SOS is unavailable and still no bluetooth. After driving for 2 more miles I hear a chime, music starts playing and I regain full control of the idrive, but I have no presets and bluetooth still unavailable (unsure about SOS). Play vball for almost two hours and car is back to normal when I drive home.

I guess I'll email my SA and see what he says.
__________________
'07 e90 335i: Monaco/Lemon ZSP ZPP ZCW (gone)
'02 e46 325ci: BSM/Black ZSP ZPP 5MT
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:09 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST