E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > Aftermarket amp and sub for 06' 325i!!!



Reply
 
Thread Tools Search this Thread
      04-21-2006, 03:17 PM   #1
bmw_angel_06_325i
New Member
1
Rep
6
Posts

 
Drives: 2006 BMW 325I
Join Date: Apr 2006
Location: CA

iTrader: (0)

Red face Aftermarket amp and sub for 06' 325i!!!

I just got my car a few days ago and the stock sound system (not Logic 7) in my car doesn't sound all that great :mad: I have an appointment to install a aftermarket amp and subs. I need your help regarding installation I just don't want any warning signs to appear :mad: I did searches on upgrade on sounds but no luck...it would be for different model cars or they have Logic 7 in there car. I have a 2006 BMW 325i and it's the regular unit (not Logic 7). I'm a female and very on performance sounds. I need your help on location of the stock amp, diagram or instruction on installation for a aftermarket amp and subs. Please help me I would greatly appreciated
Appreciate 0
      04-21-2006, 03:40 PM   #2
xcalibr
First Lieutenant
xcalibr's Avatar
Taiwan
9
Rep
370
Posts

 
Drives: E90 325xi
Join Date: Jun 2005
Location: Fremont, CA

iTrader: (4)

Garage List
2006 E90 325xi  [0.00]
Search this sub-forum... there's info all over the place. Stock amp is located on the driver side in the trunk... battery is on the opposite side. There are diagrams on this forum somewhere of what wires to splice into...
http://www.e90post.com/forums/showthread.php?t=6234 (post#7-8)

The tricky thing is the remote... the stereo shop will either have to find a +12V hot source from accessory power, directly from the fuse box, or from the overhead light assembly, or something... OR, use one of those speaker signal remote boxes as matt0528 did in this post here: http://www.e90post.com/forums/showthread.php?t=16250

an install shop should be able to do the job fairly competently... as long as they're aware that the factory amp doesn't use a remote signal like normal amps... so they can't tap it for a remote signal.

...i know you searched, but next time, just try looking down the page for this audio/video subforum... there's at least 3 threads regarding subwoofer installation on the first page.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:49 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST