E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Cosmetic and Lighting Modifications (exterior/interior) > e90 + mtech = no oil cooler duct????



Reply
 
Thread Tools Search this Thread
      06-24-2008, 08:35 PM   #1
JayAre335i
New Member
 
Drives: e90 335i
Join Date: Jan 2008
Location: Ohio

Posts: 22
iTrader: (0)

e90 + mtech = no oil cooler duct????

i had the full mtech kit installed on my car about a month ago and the lower grill on the front bumper on the passenger side is blocked off where the oil cooler duct is (between the brake duct and the foglight)...... i kno another member started a thread a couple months ago about him having the same problem and noticed oil temps running about 20 degrees higher cuz of the lack of airflow..... has anyone found the solution to getting this duct opened back up (part numbers maybe?)????? my parts guy at the stealership has been messing around with his dick in the ground for the last month and still hasn't come up with anything. ( he claimed that he already talked 2 BMWNA, but 2 days ago he said he had the correct grill ordered but he actually just ordered a grill for the original stock bumper) its getting somewhat annoying that they cant get anything figured out after a month of "investigating" this issue so if anyone knos anything that'd be greattt.

thanks
JayAre335i is offline   United_States
0
Reply With Quote
      06-24-2008, 08:43 PM   #2
Kev
Resident Anesthesiologist
 
Kev's Avatar
 
Drives: VW bug with a misplaced engine
Join Date: Aug 2006
Location: Seattle, WA

Posts: 8,815
iTrader: (24)

Garage List
You just have to create your own opening.
__________________
kev { divinum est sedate dolorem }
Kev is offline   Hong Kong
0
Reply With Quote
      06-24-2008, 10:04 PM   #3
JayAre335i
New Member
 
Drives: e90 335i
Join Date: Jan 2008
Location: Ohio

Posts: 22
iTrader: (0)

soo i haveta take the bumper off and cut out wat looks like a cover over the oil cooler duct??? hmmm seems like bmw should have a better solution but if thats all i can do i guess thats it then...... y would bmw block the opening to the duct in the first place?? weird....
JayAre335i is offline   United_States
0
Reply With Quote
      06-24-2008, 10:12 PM   #4
cbad335
Lieutenant Colonel
 
cbad335's Avatar
 
Drives: '09 E92 335i
Join Date: Jan 2008
Location: Cardiff-by-the-Sea, CA

Posts: 1,733
iTrader: (17)

Garage List
I had posted about the same problem, and coincidentally, I just edited my post (w/ pics) with the fix tonight: http://www.e90post.com/forums/showthread.php?t=141946

Basically, the blank in front of the duct is part of the fog light. The body shop cut off that extension to the fog light and viola, oil cooler air duct.
cbad335 is offline   United_States
0
Reply With Quote
      06-25-2008, 07:10 AM   #5
1clean335i
Perf BMW mag issue 147, 159
 
1clean335i's Avatar
 
Drives: Project Estoril
Join Date: Feb 2007
Location: Central Florida

Posts: 6,752
iTrader: (30)

Garage List
Why dont you just get the correct lower grill for that side? The only problem I had was that the new fender liner did not have the opening for the oil cooler so I had to mock something up.
__________________
'13 Estoril Blue 335i M-sport
*Don't PM me!* Message me here- http://www.facebook.com/ProjectEstoril
1clean335i is offline   Vietnam
0
Reply With Quote
      06-26-2008, 02:01 PM   #6
JayAre335i
New Member
 
Drives: e90 335i
Join Date: Jan 2008
Location: Ohio

Posts: 22
iTrader: (0)

Quote:
Originally Posted by cbad335 View Post
I had posted about the same problem, and coincidentally, I just edited my post (w/ pics) with the fix tonight: http://www.e90post.com/forums/showthread.php?t=141946

Basically, the blank in front of the duct is part of the fog light. The body shop cut off that extension to the fog light and viola, oil cooler air duct.
heh yeahh i saw that u updated after i posted this thread. i think i'll print out ur thread and give it to my parts guy so he can finally stop scratching his ass trying to figure it out. welp sounds like i gotta go back to the body shop so they can fix this prob..... thnks for the help man
JayAre335i is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:49 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST