E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > DIY Guides > Service reset DIY



Reply
 
Thread Tools Search this Thread
      07-13-2008, 04:13 AM   #45
charlote
New Member
0
Rep
5
Posts

Drives: E90 320
Join Date: May 2005
Location: singapore

iTrader: (0)

Used the above method to reset my front brake pad service light but after the reset process, I had the mileage as "---------" and the service warning is still on.
Anyone have a clue whats happening here? Now even the inspection icon(car lifted up icon) is lighted up. Can anyone help me ?

TIA.
Appreciate 0
      07-13-2008, 07:23 AM   #46
charlote
New Member
0
Rep
5
Posts

Drives: E90 320
Join Date: May 2005
Location: singapore

iTrader: (0)

Anyone please??
TIA
Appreciate 0
      07-13-2008, 10:25 AM   #47
charlote
New Member
0
Rep
5
Posts

Drives: E90 320
Join Date: May 2005
Location: singapore

iTrader: (0)

Help ! anyone??
TIA
Appreciate 0
      07-13-2008, 12:31 PM   #48
georgeyklee
Private
0
Rep
69
Posts

Drives: 325I E90
Join Date: Oct 2005
Location: California

iTrader: (1)

i had to take my car to BMW to reset the brakes. Manual reset wont work on front and rear brakes.
Appreciate 0
      07-13-2008, 12:42 PM   #49
Majikthese42
Philosopher-king
Majikthese42's Avatar
12
Rep
1,113
Posts

Drives: 2008 E91
Join Date: Apr 2005
Location: People's Republic of New Jersey

iTrader: (0)

Quote:
Originally Posted by BMW NA Website
BMW Maintenance Program: One of the most comprehensive maintenance programs in its class covering all factory-recommended maintenance, oil service and fluid service, as well as items that need replacement due to normal wear and tear - such as brake pads, brake rotors and wiper blade inserts.
Curious, are you over 50,000 miles or outside of the US?
__________________
E91 6MT Alpine, Terra, Xenons, ZSP, ZCW, ZPP, PDC, CA, alarm, M shifter and M brake handle, Euro rear fog light switch, Euro aspheric mirrors, rear power outlets, Garmin nüvi custom cupholder mount, Lidatek, V-1 built-in remote display, tire pump, jack, floor mats.
Appreciate 0
      07-14-2008, 06:20 PM   #50
khanhceo
ED Happy
khanhceo's Avatar
United_States
0
Rep
22
Posts

Drives: 325XI E90
Join Date: Apr 2006
Location: FL

iTrader: (0)

Brake Lights

Turns out my rear brakes had to be replaced (the sensors were touching the rotors). My front brake pads had 1/3 more life on them. In my car, the RED car lift symbol appeared.

So, I replaced the rear brake pads, and the single Rear Right sensor. After the replacement, I followed the instructions to reset the red lights and everything is fine.

I'm not sure why other people couldn't replace the worn brake pads and reset the brake pad service indicator. -Just telling you what i did.
__________________
Picked up ED -pic is from Switzerland in Feb 06.

Appreciate 0
      07-15-2008, 10:34 AM   #51
charlote
New Member
0
Rep
5
Posts

Drives: E90 320
Join Date: May 2005
Location: singapore

iTrader: (0)

Sent back the car to the dealer. Change front n back pads, change sensor and eevrythign reset by dealer. All ok now.So can comfirm tht the DIY service reset will work for all except brake pad service since the sensor triggered the fault light and must be replaced before it can be reset again.
Hope this helps.
Appreciate 0
      07-15-2008, 05:32 PM   #52
YvesD
Lamininist
YvesD's Avatar
United Kingdom
15
Rep
888
Posts

Drives: 335i Coupe
Join Date: Apr 2008
Location: United Kingdom

iTrader: (3)

Quote:
Originally Posted by mikem View Post
Nice, to set the "next service date" to a desired date, choose your date, deduct 2 years, then before you reset the service alter the date in your settings to that date.
mikem,

Any idea how to re-set when the computer has already accepted a re-set and shows a tick in the box against the item in the menu ?

I seem to have re-set it twice ( forgot to alter the date to two years ago first ) and now its showing a four year service interval and 31000 miles to next service !

Woops.

Yves
Appreciate 0
      08-05-2008, 09:10 AM   #53
snkpkp
Enlisted Member
Bangladesh
1
Rep
35
Posts

Drives: BMW E60 530i
Join Date: Mar 2008
Location: Bangladesh

iTrader: (0)

Send a message via MSN to snkpkp
Quote:
Originally Posted by ontopofm View Post
do you guys remember the brake code: im seeing all these codes when im in the menu:

01.00
FGSTNR
P035630

01.01
KZAL W/T
78827/78028

01.02
BMWTNR
000009168354

01.03
COD DIA
0008h 08D0h

01.04
KIHSTLDATUM
13.04.2007

01.05
HW AEI
0C0Eh 000Dh

01.06
SW
73.52.C0

01.07
KODIERDATEN
08.0E.30.18

01.08
CAN
00 22 17
mine also does this, i can reset everything just fine in my 02/05 E60 but not on the 07/05 E90 does anyone know any more details? need to change microfilter issue
Appreciate 0
      08-05-2008, 10:31 PM   #54
IllLojik
Lieutenant
IllLojik's Avatar
United_States
17
Rep
446
Posts

Drives: //'12 F30 328i\\
Join Date: Jul 2008
Location: Long Island, NY

iTrader: (2)

Send a message via AIM to IllLojik Send a message via MSN to IllLojik Send a message via Yahoo to IllLojik
This worked perfectly in my 06 330i. Thanks alot, just reset my oil lamp. 19k?? WTF
Appreciate 0
      08-06-2008, 08:02 AM   #55
snkpkp
Enlisted Member
Bangladesh
1
Rep
35
Posts

Drives: BMW E60 530i
Join Date: Mar 2008
Location: Bangladesh

iTrader: (0)

Send a message via MSN to snkpkp
ok it worked now , the thing is you have to wait 15 sec after the service light goes away and then when it comes to the RED MICROFILTER LOGO, you have to press the BC button on the steering column and press it down for two seconds it will ask RESET? then you let go and press it down again for 2 seconds....then you will be done. I think there is a difference on US spec and EU spec cars which is not the case with my E60 which is the same process as US Spec vehicles.
Appreciate 0
      12-06-2008, 06:01 PM   #56
Greg 1
Private
United Kingdom
3
Rep
69
Posts

Drives: 320 se d sparkling graphite
Join Date: Sep 2007
Location: uk

iTrader: (0)

reset service light

Quote:
Originally Posted by diu lay View Post
Has anyone ever have a problem where you reset the service early than needed or accidentally reseted the service without doing anything to the parts(brakes)...the result is a yellow light with the mileage being "-------"..

I went to reset the rear brake pad indicator but accidentally reseted the front ones first.. so the front is messed up but the rear is doing fine.
i reset my microfilter and it worked i then went to reset the front brake pads got to the" -----" and then the the car on the lift is on i checked my front pads and they are half worn i went and got a new sensor and pads dont know if replacing will reset all or not can you help?
Appreciate 0
      12-07-2008, 03:31 PM   #57
mikem
Lieutenant Colonel
29
Rep
1,556
Posts

Drives: Z4M
Join Date: Oct 2006
Location: Somewhere

iTrader: (0)

Change the sensor, then it will reset fine. I don`t have the E90 anymore but had to do this the other day on my other half`s E87.
Appreciate 0
      12-09-2008, 10:14 PM   #58
cgnahc
Major
cgnahc's Avatar
United_States
31
Rep
1,258
Posts

Drives: TiAg E90 ZSP
Join Date: Dec 2006
Location: Westlake Village, CA

iTrader: (9)

This is great! I had a recent oil change (out of warranty) at the dealer and they charge labor 1 x $70/hour oil change, 1 x $70/hr scope, which I found out was downloading car data and reset, and parts ($17 filter + 5 x $7/quart synthetic oil = $52) Total around $200 for an oil change. Ouch!!!

Does this reset oil even if there is no warning light? I did not get a warning light but the car indicated it had only a few miles (<100 miles) left in the oil life. Does this reset only if you have a warning light lit?

I see this resets:

Microfilter warning
Brake pad (replace with new sensor to work properly)
Brake fluid
General service (if that is what it's called...2 year intervals)
Oil service
Exhaust emission test service (I think)
what else?? Please list.
__________________
9/2011 Need someone to install angle eye bulbs.
9/2011 WTB: an OEM 17" front rim.

Last edited by cgnahc; 04-09-2009 at 02:32 PM.
Appreciate 0
      12-14-2008, 01:56 PM   #59
ron gray
New Member
0
Rep
29
Posts

Drives: 2006 325i
Join Date: Apr 2008
Location: ohio

iTrader: (0)

Wanted to give some quick props to the OP...worked like a champ on my 06 325i. Took care of my oil change interval and my low tire pressure light that shows up everytime I change from summer to winter wheels. This forum rules. Thanks OP!
Appreciate 0
      12-29-2008, 09:06 PM   #60
cgnahc
Major
cgnahc's Avatar
United_States
31
Rep
1,258
Posts

Drives: TiAg E90 ZSP
Join Date: Dec 2006
Location: Westlake Village, CA

iTrader: (9)

Haven't tried it yet, but this one deserves a sticky, so here is a free bump!!
__________________
9/2011 Need someone to install angle eye bulbs.
9/2011 WTB: an OEM 17" front rim.
Appreciate 0
      01-07-2009, 11:39 AM   #61
bmw_E90_330i
Enlisted Member
7
Rep
42
Posts

Drives: BMW 330i 2006
Join Date: Dec 2008
Location: London

iTrader: (0)

Photos please
Appreciate 0
      01-07-2009, 12:56 PM   #62
bmw_E90_330i
Enlisted Member
7
Rep
42
Posts

Drives: BMW 330i 2006
Join Date: Dec 2008
Location: London

iTrader: (0)

Great!!!
Appreciate 0
      01-10-2009, 11:30 AM   #63
ASHFORTHUK
New Member
0
Rep
12
Posts

Drives: E90 330i
Join Date: Nov 2008
Location: STAFFORD UK

iTrader: (0)

Thumbs up



cheers mikem fitted new front brakes disc,brake pads and sensor today then reset as you told us and it worked a treat.
Appreciate 0
      01-10-2009, 02:40 PM   #64
bmw_E90_330i
Enlisted Member
7
Rep
42
Posts

Drives: BMW 330i 2006
Join Date: Dec 2008
Location: London

iTrader: (0)

Thanks
Appreciate 0
      01-17-2009, 03:09 PM   #65
kevbhoy
Private First Class
kevbhoy's Avatar
Scotland
6
Rep
105
Posts

Drives: '06 325i SE Coupe
Join Date: May 2005
Location: Aberdeen, Scotland

iTrader: (0)

Send a message via MSN to kevbhoy
Hi all!

I tried this reset today after putting my car into a non BMW dealer to have the front brake pads replaced.

Got into the menu ok and selected reset. The front brake pad icon in now yellow and the miles are showing as ------. The red car on the lift, the handbrake light and the ! in the triangle still appear.

From what I am reading if a new sensor is fitted then the reset should work is that correct?

If this is the case is it possible that the garage used the old sensor or can that not be done?

Thanks in advance for your help.
__________________
Current - '06 325i SE Coupe
Previous - '08 330d M Sport
Previous - '05 320i SE
Appreciate 0
      01-18-2009, 06:24 AM   #66
bmwbazza
New Member
bmwbazza's Avatar
United Kingdom
1
Rep
22
Posts

Drives: E90 320d - Mk1 Capri v8
Join Date: Jan 2009
Location: london UK

iTrader: (0)

Hi kevbhoy

The garage you used should in all fairness have replaced the sensor at the same time as the pads, and then when resetting the service it would have functioned correctly.

I work at a motor factors in north london and supply to the trade garages in my area and i can honestly say that if they can get away with i.e replacing the sensors for instance (THEY WILL DO).

I would go back and get them to change the sensor and then all will be good.

Regards
Barry
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:59 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST