E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Engine Problem?



Reply
 
Thread Tools Search this Thread
      10-02-2008, 11:49 AM   #1
HenryGale
Registered
 
Drives: 335
Join Date: Oct 2008
Location: NY

Posts: 2
iTrader: (0)

Lightbulb Engine Problem?

Hello everyone. I was directed here by a fellow friend who said many experts reside here, and often times are more knowledgeable than the BMW employees themselves. I have a 2008 BMW 335i Sedan. About 1000 miles ago or so, a co-worker installed a performance chip on my car and it made it a lot faster. I had no problems and the car worked great.

Two days ago, out of nowhere, I started my car and about 10 seconds later, the engine cut out. I was just sitting there and had not driven it yet. It did not shake at all or anything, just completely went dead. I restarted the engine, and the "engine malfunction - reduced power" mode came on. Also, the engine would rev by itself, almost at an increasing pace, which scared me and I shut off the car. I restarted it, same thing with the half engine sign and it revving itself. I tried again about 90 minutes later, same thing.

My coworker said it may be the chip or possible a pump fueler, but he was not sure. He said if it was my pump fueler my car would have trouble starting, but it has always started immediately upon pushing the start button. Anyway I thought I would post here to see if anyone has any thoughts until I can get my coworker to take some time to take the chip out. He has to pull apart the engine and access the main computer to do so.

I'm just confused on why the engine would rev itself. Thanks to all who offer help. If it makes a difference my car has sport package and cold weather package, and active steering. No other options.

Jeff
HenryGale is offline  
0
Reply With Quote
      10-02-2008, 12:00 PM   #2
sambonator
Samtaro!
 
sambonator's Avatar
 
Drives: a car
Join Date: May 2007
Location: Milky Way Galaxy

Posts: 2,504
iTrader: (5)

What "chip" was installed? I'd contact the "chip" vendor for assistance.
__________________
sambonator is offline   United_States
0
Reply With Quote
      10-02-2008, 12:00 PM   #3
fll335
Major
 
fll335's Avatar
 
Drives: C6 Z06, X5M
Join Date: Jun 2007
Location: FL

Posts: 1,198
iTrader: (3)

Take the chip out and go to the dealer. But it could be the Fuel Pump.
fll335 is offline   United_States
0
Reply With Quote
      10-02-2008, 12:01 PM   #4
Makushr1
Lieutenant
 
Makushr1's Avatar
 
Drives: 2008 335i Sedan Auto
Join Date: May 2008
Location: Texas

Posts: 480
iTrader: (2)

Quote:
Originally Posted by fll335 View Post
Take the chip out and go to the dealer. But it could be the Fuel Pump.
+1

See if it still has the problem without the chip.
__________________
2008 Montego Blue E90 ll Custom K&N Dual Cone Intake ll Aluminum OEM Pedals ll 25% Tint ll M3 Spoiler

To Do (Cosmetic): Black Line lights, Lux 4.0 Angel Eyes, 19" CSL HyperBlack
To Do (Performance): Exhaust (still undecided which brand), SSTT, FMIC (unsure what type)
Makushr1 is offline  
0
Reply With Quote
      10-02-2008, 12:03 PM   #5
midlife
ocasionally in crisis
 
midlife's Avatar
 
Drives: '08 335i cabrio
Join Date: Jun 2007
Location: ..........

Posts: 2,359
iTrader: (0)

Quote:
Originally Posted by fll335 View Post
Take the chip out and go to the dealer. But it could be the Fuel Pump.
my first thought exactly....make sure u leave no trace of the aftermarket chip.
__________________
If your car isn't scary - it's just not fast enough !
RPI IC / UR catless DPs / JB3 2.0 beta / UR CAI / Quaife LSD / Snow Methanol Injection / VK oil cooler upgrade / Forge DVs /
M3 rear sway / Riss catch can / Paddle shifting 6AT / M Sport steering wheel / Logic 7 / Dunlop Direzza Z1 255/235 /
midlife is offline  
0
Reply With Quote
      10-02-2008, 12:06 PM   #6
vegasspeed
Captain
 
vegasspeed's Avatar
 
Drives: 335i 6MT coupe Montego Blue
Join Date: Apr 2008
Location: Las Vegas

Posts: 761
iTrader: (1)

Do you have a chip in your car?
__________________
335i coupe Montego Blue Dinan stage 3 tune, Advan RS wheels 350whp/365wtq
1994 Brooklands Green Acura NSX Comptech Supercharged 390whp/300wtq
vegasspeed is offline   United_States
0
Reply With Quote
      10-02-2008, 12:21 PM   #7
HenryGale
Registered
 
Drives: 335
Join Date: Oct 2008
Location: NY

Posts: 2
iTrader: (0)

I appreciate your replies very much. To answer your questions, I do not know what chip my coworker installed. He is the tech guy at our small office (I do cabinet sales), and speaks broken english. But he was a wiz at the install.

Rallye Motors is not too far, I can probably tow the car there. The self-revving scares me too much to drive it there. But I will heed your advice and take the chip out first (well, have him take the chip out).
HenryGale is offline  
0
Reply With Quote
      10-03-2008, 11:16 AM   #8
vegasspeed
Captain
 
vegasspeed's Avatar
 
Drives: 335i 6MT coupe Montego Blue
Join Date: Apr 2008
Location: Las Vegas

Posts: 761
iTrader: (1)

Wait, so your broken english friend put a chip in your car that you don't know about or which one it is? This sounds fishy....
__________________
335i coupe Montego Blue Dinan stage 3 tune, Advan RS wheels 350whp/365wtq
1994 Brooklands Green Acura NSX Comptech Supercharged 390whp/300wtq
vegasspeed is offline   United_States
0
Reply With Quote
      10-03-2008, 11:27 AM   #9
mithiral67
That guy
 
mithiral67's Avatar
 
Drives: 2015 Cayman GTS
Join Date: Jun 2008
Location: Chicago Burbs

Posts: 5,694
iTrader: (4)

Yea, i let some guy play around under the hood of my $50k car. I mean, he looked like he know what he was doing, regardless of whether I could understand him. I feel good about this decision.
mithiral67 is offline  
0
Reply With Quote
      10-03-2008, 11:31 AM   #10
BES335xi
Colonel
 
BES335xi's Avatar
 
Drives: FBO+ N54xi
Join Date: Mar 2008
Location: Queens, NYC

Posts: 2,133
iTrader: (4)

Garage List
03/07 E90 335xi  [0.50]
installed a pre29.2 tune on a 29.2 car..most likely.
__________________
JB4+usb | P3 Vent Boost Gauge v2 | BMS OCC | BMS DCI | AMS FMIC | AR xi CL DP's | BT Tool | Edibias/NCSExpert/INPA BMW Coding | Cyba Quad Exhaust tips | M-Tech Rear & M3 Front Bumper | Red Cyba Air Scoops | Blacklines | Vinyl Overlays | ACS Roof Spoiler | Matte Black Grilles | LED Side Mirrors | Rear Euro Fogs | etc..
.
BES335xi is offline   Albania
0
Reply With Quote
      10-03-2008, 12:28 PM   #11
ezatnova
Colonel
 
ezatnova's Avatar
 
Drives: C63 AMG
Join Date: Jan 2006
Location: West Chester, PA

Posts: 2,188
iTrader: (5)

Quote:
Originally Posted by mithiral67 View Post
Yea, i let some guy play around under the hood of my $50k car. I mean, he looked like he know what he was doing, regardless of whether I could understand him. I feel good about this decision.
Lol. I was trying to find a good way of saying that. I'll just give it the 'ol +1

I'm just picturing some crazy dude jamming this thing in there to make it work.
ezatnova is offline   United_States
0
Reply With Quote
      10-03-2008, 02:58 PM   #12
GGreek5
Olimpiakos
 
GGreek5's Avatar
 
Drives: E90 335i
Join Date: Apr 2008
Location: Mass

Posts: 1,247
iTrader: (10)

Ask your friend what the hell he put in your car. Or tell him to take it out.
GGreek5 is offline   Greece
0
Reply With Quote
      10-03-2008, 02:59 PM   #13
mithiral67
That guy
 
mithiral67's Avatar
 
Drives: 2015 Cayman GTS
Join Date: Jun 2008
Location: Chicago Burbs

Posts: 5,694
iTrader: (4)

Quote:
Originally Posted by GGreek5 View Post
Ask your friend what the hell he put in your car.
Things he should have asked before the install?
mithiral67 is offline  
0
Reply With Quote
      10-07-2008, 05:18 PM   #14
vegasspeed
Captain
 
vegasspeed's Avatar
 
Drives: 335i 6MT coupe Montego Blue
Join Date: Apr 2008
Location: Las Vegas

Posts: 761
iTrader: (1)

Exactly, Why didn't he ask this prior to installing the "CHIP".
__________________
335i coupe Montego Blue Dinan stage 3 tune, Advan RS wheels 350whp/365wtq
1994 Brooklands Green Acura NSX Comptech Supercharged 390whp/300wtq
vegasspeed is offline   United_States
0
Reply With Quote
      10-08-2008, 12:45 AM   #15
Tuned335i
Major
 
Drives: E92 335i
Join Date: Jun 2007
Location: World of Torque

Posts: 1,310
iTrader: (0)

You have to be kidding me. You'd have to have no concept of the value of money to allow someone to make an unknown modification to a $14K engine that "makes it faster" but which you know nothing about and obviously have no knowledge of the consequences of modifications to the drivetrain.

I'm not going to call BS just yet, or say that this is a complete TROLL, but the OP needs to get the installer over and pull out whatever it was they installed. Disconnect the battery for an hour, reconnect and my guess it that everything will be fine. Unless of course it's actually the HPFP (which is what I suspect also).

Anyway, good luck to the OP. I think you've learned a valuable lesson. If you want significantly more power without mods, may I suggest a 2007 Z06 (hell with things the way they are with the economy, you can get a deal on a Z06 isn't that far off of a loaded 335i...)
Tuned335i is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:40 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST