E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > JB3 questions?



Reply
 
Thread Tools Search this Thread
      10-10-2008, 07:59 AM   #1
Abel_135
Second Lieutenant
4
Rep
223
Posts

 
Drives: Bmw 135i
Join Date: Oct 2008
Location: SPAIN

iTrader: (1)

JB3 questions?

Hello there Im new at this forum Im from spain and Im wondering if there are anybody from europe that has jb3 on their cars, I bought 1 week ago and Im happy with the hardware quality,and dual cones sounds great,but my map isnt going fine yet, Ive tried high boost and give me limps and already had talk to terry which is one of the best person Ive talked from the states and gave me many answers, he thinks is maybe the fuel so I would like to know if someone from europe can tell me their impressions, I use shell v power 98 octanes and bp ultime 98 in here are the best so.

Im running low boost without limps or anything but I expected more gain with the jb3 I cant feel 80 wrhp yet maybe my map is wrong or something terry sent me a newone to find out.

So if anyone from europe can help me I would appreciate it,is becasue I have read lately that here we work at different bits so not sure because terry would told me before.

Thank you very much to all.
Appreciate 0
      10-10-2008, 08:20 AM   #2
bootay
Private First Class
2
Rep
182
Posts

 
Drives: 2009 E90 335i
Join Date: Feb 2008
Location: NC

iTrader: (0)

If you're talking with Terry, you're talking with the man - no one else is will know more about getting the JB3 working right for you .

That said, European 98 octane = 91-93 octane US, which the maps should handle fine. I'm guessing you've got the wrong piggyback version (running the pre 92 version when you need the V), or have had some bad gas.

Good luck! Even running the low boost map, you're not that much away from the full maps, and should be seeing huge HP/TQ gains...
Appreciate 0
      10-10-2008, 08:24 AM   #3
xsb00st
Lieutenant Colonel
United_States
37
Rep
1,530
Posts

 
Drives: Slow
Join Date: Nov 2005
Location: Earth

iTrader: (21)

Only thing I can think of is that you're using a pre v81 JB3 and your car is V81... I just pulled that out of my ass, but Abel135's right, Terry is the man with all the answers.
Appreciate 0
      10-10-2008, 08:28 AM   #4
Abel_135
Second Lieutenant
4
Rep
223
Posts

 
Drives: Bmw 135i
Join Date: Oct 2008
Location: SPAIN

iTrader: (1)

I know he is such a great man he said maybe bad gas or worng chip so that is what I want to find out and if someone from europe can help me out,here 98 shell v power is not bad gas at all there are a lot of tune cars here and run fine so dont think is the fuel,according to theory 98 is 93 octane us so it should be better than fien my car is after march build so post 92 is from augoust. The first time i tried the jb3 with dual i noticed a good gain but dunno lets wait or do a dyno here to see.I would like to have a run with an rs4 or a m3 e92 to see the gains and how I supoose to be against them with low boost
Appreciate 0
      10-10-2008, 08:38 AM   #5
Abel_135
Second Lieutenant
4
Rep
223
Posts

 
Drives: Bmw 135i
Join Date: Oct 2008
Location: SPAIN

iTrader: (1)

thanks for answers my piggabag says 1.1v, so dont now :S, but mostly I want to be quiet that is not the bad fuel if is the chip its ok can be solve but fuel hope is not the fuel
Appreciate 0
      10-10-2008, 08:40 AM   #6
enrita
Major General
enrita's Avatar
Sweden
94
Rep
7,331
Posts

 
Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

iTrader: (0)

i have the JB3 V1.1 and only tank V-Power 99, never had a limp but my ECU is still adapting.
Also only using High Boost map.
Appreciate 0
      10-10-2008, 08:45 AM   #7
xsb00st
Lieutenant Colonel
United_States
37
Rep
1,530
Posts

 
Drives: Slow
Join Date: Nov 2005
Location: Earth

iTrader: (21)

Hopefully the new maps Terry sends you fixes the problem.
Appreciate 0
      10-10-2008, 08:52 AM   #8
Abel_135
Second Lieutenant
4
Rep
223
Posts

 
Drives: Bmw 135i
Join Date: Oct 2008
Location: SPAIN

iTrader: (1)

thanks enrita wow you just make me happy because i was reading that en europe we use different bits for the ecu and a lot of things I didnt like,you v power 99 it suppose to be the same that 98 here maybe 1 octane higher.But I want to know maybe is the worng version of the chip
Appreciate 0
      10-10-2008, 09:00 AM   #9
enrita
Major General
enrita's Avatar
Sweden
94
Rep
7,331
Posts

 
Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

iTrader: (0)

if you have the 1.1V will work for all ECUs . You might got a 1.1 thats why is throwing limp codes
Appreciate 0
      10-10-2008, 09:49 AM   #10
Abel_135
Second Lieutenant
4
Rep
223
Posts

 
Drives: Bmw 135i
Join Date: Oct 2008
Location: SPAIN

iTrader: (1)

mines says 1.1v so dont know what is wrong then
Appreciate 0
      10-10-2008, 09:59 AM   #11
enrita
Major General
enrita's Avatar
Sweden
94
Rep
7,331
Posts

 
Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

iTrader: (0)

yeah maybe 1.1 V on the outside but wrong chip . Just wait till the new one arrives. just drive with Valet or Low Boost map.
Appreciate 0
      10-10-2008, 10:13 PM   #12
jesdan14
Captain
United_States
14
Rep
796
Posts

 
Drives: 335i Coupe sapphire Black
Join Date: Mar 2008
Location: Lakeworth Florida

iTrader: (7)

Garage List
2007 335I Coupe  [0.00]
Send a message via AIM to jesdan14
Who's terry? lol is he like the owner of the juice box company?
Appreciate 0
      10-10-2008, 10:51 PM   #13
mithiral67
That guy
mithiral67's Avatar
68
Rep
5,724
Posts

 
Drives: 2015 Cayman GTS
Join Date: Jun 2008
Location: Chicago Burbs

iTrader: (4)

Garage List
He some guy that hates cars with only 8psi of boost.
Appreciate 0
      10-11-2008, 10:52 AM   #14
jesdan14
Captain
United_States
14
Rep
796
Posts

 
Drives: 335i Coupe sapphire Black
Join Date: Mar 2008
Location: Lakeworth Florida

iTrader: (7)

Garage List
2007 335I Coupe  [0.00]
Send a message via AIM to jesdan14
so how do i get in touch with him? where is he located? does he install?
Appreciate 0
      10-11-2008, 12:15 PM   #15
jcarlucci1
Lieutenant Colonel
26
Rep
1,638
Posts

 
Drives: Jet Black 335i
Join Date: Mar 2007
Location: Tampa

iTrader: (10)

Quote:
Originally Posted by jesdan14 View Post
so how do i get in touch with him? where is he located? does he install?
go to www.n54tech.com
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:49 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST