E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Heater Squeal



Reply
 
Thread Tools Search this Thread
      01-28-2009, 09:37 AM   #1
P2
Private First Class
4
Rep
188
Posts

 
Drives: 2006 325i Silver/Black
Join Date: Mar 2006
Location: NW Chicago Land

iTrader: (0)

Heater Squeal

When it's 20F(ish) or below I get a high pitch ticking squeal. The colder it is, the worse it gets. So when it was -21f a few weeks ago, it was out of control. It's also worse when I accelerate or make a right turn. I have brought this up during two winters and BMW says "BMW's all do that for as long as I can remember". Then they do nothing. I looked at my paperwork and they did not annotate a thing. My fault for not paying attention to detail there. So I am going to bring it in Monday, for this problem only. Still under Warranty for another year.

So, any other cold weather member had this trouble? What was the fix at BMW? I am looking for some ammo when I go in.

p2
Appreciate 0
      01-28-2009, 09:30 PM   #2
ENINTY
Banned
51
Rep
3,415
Posts

 
Drives: 2006 325i Sport
Join Date: Jun 2006
Location: Virginia

iTrader: (0)

P2, it's the blower motor. This is common on some cars. My '06 did it the first winter I had it when it got down into single digit temperatures. My car now has 70K on it (3 years later) and this past week when it was 2 deg, my blower motor did not make any noise. I think as the bearings wear in they no loner squeal. I left mine alone because I didn't want a Tech pulling half my dash apart to replace the blower motor with one that would probably just do the same thing. BMWs are funny cars. They will do strange things once or a few times and then never do it again. It takes awhile for the car to break in.
Appreciate 0
      01-28-2009, 10:08 PM   #3
P2
Private First Class
4
Rep
188
Posts

 
Drives: 2006 325i Silver/Black
Join Date: Mar 2006
Location: NW Chicago Land

iTrader: (0)

Quote:
Originally Posted by ENINTY View Post
P2, it's the blower motor. This is common on some cars. My '06 did it the first winter I had it when it got down into single digit temperatures. My car now has 70K on it (3 years later) and this past week when it was 2 deg, my blower motor did not make any noise. I think as the bearings wear in they no loner squeal. I left mine alone because I didn't want a Tech pulling half my dash apart to replace the blower motor with one that would probably just do the same thing. BMWs are funny cars. They will do strange things once or a few times and then never do it again. It takes awhile for the car to break in.
It's getting worse as time goes by. I have had it since new and this is the 3rd winter. I don't want my dash apart either but it's driving me crazy. Thanks for the advice. Maybe my next one will break in .

p2
Appreciate 0
      01-28-2009, 10:10 PM   #4
JL328i
feening for an E90
United_States
6
Rep
456
Posts

 
Drives: E46 328i
Join Date: Jul 2008
Location: Salt Lake City Utah

iTrader: (0)

my 99 328i does this as well, not just the heater tho, ac as well. ive asked a Service adviser about it and he said that the blower fan needed to be lubed? it was something along thoes lines.
__________________
The 328i that once was...
Appreciate 0
      01-29-2009, 07:27 PM   #5
jaylo247
New Member
jaylo247's Avatar
United_States
0
Rep
25
Posts

 
Drives: 2006 325i
Join Date: Mar 2008
Location: USA

iTrader: (0)

I had the exact symptoms that you are currently having and just picked my car up today. They performed SIB 640105 and now everything is fine. My blower motor was corroded and rusty due to water ingress. Glad I was still under warranty. It took several days, best of luck.

http://www.bmwtis.com/tsb/bulletins/...p/B640105g.htm
Appreciate 0
      02-05-2009, 03:45 PM   #6
P2
Private First Class
4
Rep
188
Posts

 
Drives: 2006 325i Silver/Black
Join Date: Mar 2006
Location: NW Chicago Land

iTrader: (0)

Quote:
Originally Posted by jaylo247 View Post
I had the exact symptoms that you are currently having and just picked my car up today. They performed SIB 640105 and now everything is fine. My blower motor was corroded and rusty due to water ingress. Glad I was still under warranty. It took several days, best of luck.

http://www.bmwtis.com/tsb/bulletins/...p/B640105g.htm
Thanks. Mine was not a whistle but a high pitch squeal. Kinda like what they played over the speakers during my military POW training. I think maybe the same defect causing it. Anyway, they replaced the blower motor and all seemed well in the single digits when I picked it up.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:59 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST