E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > iDRIVE SCREEN TOTALLY OFF & doesn't turn back on



Reply
 
Thread Tools Search this Thread
      02-12-2009, 09:19 PM   #1
dom1
Private First Class
dom1's Avatar
United_States
1
Rep
163
Posts

 
Drives: 2006 330xi
Join Date: Jan 2006
Location: Methuen, MA

iTrader: (0)

iDRIVE SCREEN TOTALLY OFF & doesn't turn back on

My E90 has 50384 miles and sure enough, the i-drive went totally dead for the 1st time ever. I quickly came to E90post and started searching posts (as always do with any BMW problems). Well, I let the car off for about 30 minutes and tried again. Unfortunately, it's still dead. Nothing works, no radio, no navigation, no eject, etc. I will call the dealer tomorrow and hope they don't rip me off. Hopefully it's just a stupid fuse (wishful thinking), but I'm afraid it may be more than that. Anyone has any idea what to expect or anyone has an idea on how to fix? Or which fuse should I be checking? My car is an 06 330xi.

Thanks!

BTW, I posted the same message in I-DRIVE but I don't know if that was the right forum to post it. Any replies will be greatly appreciated.
__________________
2006 330xi MB, Terra, Burl Walnut, Auto, PP, Nav, Heated Seats, SP w/18in
2002 Acura MDX - wife's ride
2000 Ford Expedition Eddie Bauer 4x4 - wife's SUV retired after 120K miles and lots of problems
1994 Pontiac Sunbird 4 cyl. - retired after 170K miles
Appreciate 0
      03-23-2009, 10:53 PM   #2
bmwtech
New Member
bmwtech's Avatar
0
Rep
16
Posts

 
Drives: blue snap on tool box
Join Date: Jan 2007
Location: some where in FL. under your hood

iTrader: (0)

did you ever get this issue fixed?
Appreciate 0
      03-24-2009, 12:25 PM   #3
Rekla
Hug the road... Carpe Asphalt
Rekla's Avatar
United_States
19
Rep
601
Posts

 
Drives: 2007 ///M Coupe
Join Date: Sep 2006
Location: Greater Seattle area - WA

iTrader: (18)

This morning my I-drive screen was frozen in the I-mode screen as well!

After I started the car it started of with a SOS not Available message on the instrument cluster. Then the I-drive screen froze and I could free spin the I-drive controller.
I also noticed there was no time and date shown in the lower section on the I-drive screen, while date and time were displayed on the instrument cluster. No radio, nothing.
I kept on driving and after approx 8 minutes the screen turned into the striped BMW screen - just like when you completely shut down the car. Following this the screen turned black and then it started up again with the "accept" message. After all this it is operating as before and it kept all my personal settings (radio stations, etc). I think it re-booted itself. I hope this is just a one time incident. BTW I have a 2006 330i and the dealer reprogramed the vehicle (including the updated I-drive sw) a couple weeks ago due to the infamous steering wheel lock error.

Any body experienced something similar?
__________________
2013 X5-35d - Platinum Grey / Oyster; Premium - Sport
2007 BMW ///M Coupe
RETIRED 2006 TiAg E90 330i - Black leather - Alu Trim - Prem - Sport - NAV - Step - CA - Heated Seats
Appreciate 0
      03-27-2009, 01:49 AM   #4
jcrwu
Private
0
Rep
88
Posts

 
Drives: 2006 330i
Join Date: Jan 2008
Location: San Francisco

iTrader: (5)

You can try reading this thread in the iDrive section: http://www.e90post.com/forums/showthread.php?t=243293

I had similar problems with my iDrive. Sometimes, there is a fuse behind the CCC that blows that causes the iDrive to go dead. In other cases, like mine, the CCC just went bad so the dealership had to replace my CCC and reprogram the entire Progman.

Good luck...
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:39 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST