E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Loss of power after HPFP replaced?



Reply
 
Thread Tools Search this Thread
      04-18-2009, 11:47 AM   #1
muvaside
Second Lieutenant
 
muvaside's Avatar
 
Drives: E90 335i
Join Date: Mar 2007
Location: SoCal

Posts: 268
iTrader: (3)

Send a message via AIM to muvaside
Loss of power after HPFP replaced?

Just got the car back two days ago and it just does not feel the same!I have Jb3 and drop in BMS filter.The rpm does not climb up as fast.I'm thinking , they might have reprogramed the ecu or I just have to wait until it adapts for a few days(so confused)!Anyone else experience the same problem?
muvaside is offline   United_States
0
Reply With Quote
      04-18-2009, 01:44 PM   #2
muvaside
Second Lieutenant
 
muvaside's Avatar
 
Drives: E90 335i
Join Date: Mar 2007
Location: SoCal

Posts: 268
iTrader: (3)

Send a message via AIM to muvaside
Anyone?
muvaside is offline   United_States
0
Reply With Quote
      04-18-2009, 01:50 PM   #3
shaddai
former N54 owner
 
shaddai's Avatar
 
Drives: 2008 Audi S4 DTM
Join Date: Mar 2008
Location: Bay Area, CA

Posts: 608
iTrader: (0)

Garage List
2008 335i  [0.00]
Give it a few days. Mine SUCKED for a day and a half until the throttle module recalibrated itself to my right foot.
__________________
+lemon
shaddai is offline   United_States
0
Reply With Quote
      04-18-2009, 01:55 PM   #4
muvaside
Second Lieutenant
 
muvaside's Avatar
 
Drives: E90 335i
Join Date: Mar 2007
Location: SoCal

Posts: 268
iTrader: (3)

Send a message via AIM to muvaside
Quote:
Originally Posted by shaddai View Post
Give it a few days. Mine SUCKED for a day and a half until the throttle module recalibrated itself to my right foot.
Hoping that's the case.
muvaside is offline   United_States
0
Reply With Quote
      04-19-2009, 09:50 AM   #5
Zeph
Major
 
Drives: 2008 E92 335i 6MT SGM CR/BD
Join Date: Jul 2008
Location: Southeast USA

Posts: 1,394
iTrader: (0)

Send a message via AIM to Zeph Send a message via Yahoo to Zeph
So did you get the long cranks or poor idling before it went out? Mine has had about 3-4 cranks that took 4-5 seconds over the past week. Afraid I will be stranded on the side of the road (or in my garage) soon
I already had 1 pump fail, but it was the regular pump in my gas tank and not the HFPF. I only had about 2300 miles on my car then, and now I have about 8200.
Zeph is offline   United_States
0
Reply With Quote
      04-19-2009, 10:05 AM   #6
kptaylor
First Lieutenant
 
kptaylor's Avatar
 
Drives: '07 335i Coupe
Join Date: Mar 2007
Location: PHX, AZ

Posts: 323
iTrader: (0)

Yep, your ECU was upgraded as I think that is a part of the diagnosis/corrections in the service bulletin. However, thought the latest s/w wasn't as laggy...
kptaylor is offline  
0
Reply With Quote
      04-19-2009, 11:16 AM   #7
muvaside
Second Lieutenant
 
muvaside's Avatar
 
Drives: E90 335i
Join Date: Mar 2007
Location: SoCal

Posts: 268
iTrader: (3)

Send a message via AIM to muvaside
Quote:
Originally Posted by Zeph View Post
So did you get the long cranks or poor idling before it went out? Mine has had about 3-4 cranks that took 4-5 seconds over the past week. Afraid I will be stranded on the side of the road (or in my garage) soon
I already had 1 pump fail, but it was the regular pump in my gas tank and not the HFPF. I only had about 2300 miles on my car then, and now I have about 8200.
Yup!For the last month and they were more like 9-10sec starts.It's all good now,problem fixed.
muvaside is offline   United_States
0
Reply With Quote
      04-19-2009, 11:24 AM   #8
muvaside
Second Lieutenant
 
muvaside's Avatar
 
Drives: E90 335i
Join Date: Mar 2007
Location: SoCal

Posts: 268
iTrader: (3)

Send a message via AIM to muvaside
Quote:
Originally Posted by kptaylor View Post
Yep, your ECU was upgraded as I think that is a part of the diagnosis/corrections in the service bulletin. However, thought the latest s/w wasn't as laggy...
Shouldn't they have informed me if they upgraded the ecu?However , JB3 was hooked up when I took it in.My car has passed warranty (52kmiles),it didn't make sense to take it off.It was covered under the two year BMW parts warranty,because this is my second one they replaced.
muvaside is offline   United_States
0
Reply With Quote
      04-19-2009, 11:40 AM   #9
Morpheus
Captain
 
Drives: 335i Titanium Silver
Join Date: Sep 2008
Location: Cockaigne

Posts: 848
iTrader: (1)

Quote:
Originally Posted by muvaside View Post
Shouldn't they have informed me if they upgraded the ecu?However , JB3 was hooked up when I took it in.My car has passed warranty (52kmiles),it didn't make sense to take it off.It was covered under the two year BMW parts warranty,because this is my second one they replaced.
Which version JB3 do you have? Perhaps it reverted to map 0 when they d/c'd battery? If you have 1.22 or higher try changing to map 6.
Morpheus is offline  
0
Reply With Quote
      04-19-2009, 12:01 PM   #10
muvaside
Second Lieutenant
 
muvaside's Avatar
 
Drives: E90 335i
Join Date: Mar 2007
Location: SoCal

Posts: 268
iTrader: (3)

Send a message via AIM to muvaside
Quote:
Originally Posted by Morpheus View Post
Which version JB3 do you have? Perhaps it reverted to map 0 when they d/c'd battery? If you have 1.22 or higher try changing to map 6.
It's the original version , when the plug n plays first came out.I actually would like to know also?
muvaside is offline   United_States
0
Reply With Quote
      04-24-2009, 12:36 AM   #11
muvaside
Second Lieutenant
 
muvaside's Avatar
 
Drives: E90 335i
Join Date: Mar 2007
Location: SoCal

Posts: 268
iTrader: (3)

Send a message via AIM to muvaside
Quote:
Originally Posted by shaddai View Post
Give it a few days. Mine SUCKED for a day and a half until the throttle module recalibrated itself to my right foot.
You were right on the money!Car is back to normal and running even more stronger than before.
muvaside is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:41 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST