E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > All-Wheel-Drive (Xi / xDrive) Talk > Vanos Problem ????



Reply
 
Thread Tools Search this Thread
      05-18-2009, 01:34 AM   #1
LJE92
Captain
LJE92's Avatar
Dominican Republic
9
Rep
753
Posts

 
Drives: 2008 BMW 335XI
Join Date: May 2008
Location: JMCA QNZ

iTrader: (1)

Vanos Problem ????

I have a e92xi and have problems with limp mode all the time i floor the car and after the gear changes the car gets to 250 degrees and always goes into limp mode .
i check the with the bt scann tool and says the vanos sytem ?
does anyone have or had problems with the vanos ???
i have a v3 with dci thats it ???
should i get an intercooler or take to the dealer what to do??? oh i have 31k miles on the car ????
Appreciate 0
      05-18-2009, 02:11 AM   #2
UdubBadger
Banned
No_Country
348
Rep
24,716
Posts

 
Drives: '04 330i ZHP
Join Date: Dec 2007
Location: Chicago Burbs

iTrader: (22)

Garage List
2004 BMW 330i ZHP  [4.75]
2011 135i  [3.73]
2008 328xi  [4.38]
do you have the latest bmw software (not sure what is current on 335's)?

if it is actually the vanos malfunctioning then you could be fucked.... take that thing in and let them know whats going on.
Appreciate 0
      05-18-2009, 12:51 PM   #3
LJE92
Captain
LJE92's Avatar
Dominican Republic
9
Rep
753
Posts

 
Drives: 2008 BMW 335XI
Join Date: May 2008
Location: JMCA QNZ

iTrader: (1)

[quote=UdubBadger;5143492]do you have the latest bmw software (not sure what is current on 335's)?

if it is actually the vanos malfunctioning then you could be fucked.... take that thing in and let them know whats going on.[/QU

fucked in what why ???
Appreciate 0
      05-18-2009, 12:55 PM   #4
UdubBadger
Banned
No_Country
348
Rep
24,716
Posts

 
Drives: '04 330i ZHP
Join Date: Dec 2007
Location: Chicago Burbs

iTrader: (22)

Garage List
2004 BMW 330i ZHP  [4.75]
2011 135i  [3.73]
2008 328xi  [4.38]
well if you have Vanos problems it might not be an easy fix... could be time consuming but you're still under warranty so you should be fine. Just take the car in and let BMW decide whats wrong.
Appreciate 0
      05-18-2009, 02:02 PM   #5
LJE92
Captain
LJE92's Avatar
Dominican Republic
9
Rep
753
Posts

 
Drives: 2008 BMW 335XI
Join Date: May 2008
Location: JMCA QNZ

iTrader: (1)

Quote:
Originally Posted by UdubBadger View Post
well if you have Vanos problems it might not be an easy fix... could be time consuming but you're still under warranty so you should be fine. Just take the car in and let BMW decide whats wrong.

and thats what can be causing the car to run so hot for no reason huh?
Appreciate 0
      05-18-2009, 02:49 PM   #6
pdjafari
Colonel
pdjafari's Avatar
43
Rep
2,402
Posts

 
Drives: Axe Murderer with headlights
Join Date: Oct 2007
Location: Earth

iTrader: (5)

do you have an oil cooler? In order to get the factory oil cooler you need to have sports package AND 18" wheels on the XI's....
Appreciate 0
      05-18-2009, 02:49 PM   #7
chesterfan1230
Colonel
chesterfan1230's Avatar
51
Rep
2,561
Posts

 
Drives: a Bat Mobile :)
Join Date: Apr 2008
Location: NJ

iTrader: (10)

Garage List
2012 335iS  [0.00]
Send a message via AIM to chesterfan1230
That happened to my e90xi....The front fan also stopped working so they replaced it. Also replaced vanos.
__________________
Current: 2012 335iS
Past: 2006 e90 325xi, 2010 135i
Appreciate 0
      05-18-2009, 08:22 PM   #8
LJE92
Captain
LJE92's Avatar
Dominican Republic
9
Rep
753
Posts

 
Drives: 2008 BMW 335XI
Join Date: May 2008
Location: JMCA QNZ

iTrader: (1)

Quote:
Originally Posted by chesterfan1230 View Post
That happened to my e90xi....The front fan also stopped working so they replaced it. Also replaced vanos.
how long did it take ....?
also did you go in to limp mode alot when you mashed down on the pedal ?
please if you dnt mind explain what happen to u thanks
Appreciate 0
      05-18-2009, 08:24 PM   #9
LJE92
Captain
LJE92's Avatar
Dominican Republic
9
Rep
753
Posts

 
Drives: 2008 BMW 335XI
Join Date: May 2008
Location: JMCA QNZ

iTrader: (1)

Quote:
Originally Posted by pdjafari View Post
do you have an oil cooler? In order to get the factory oil cooler you need to have sports package AND 18" wheels on the XI's....
yup i have 335xi coupe with sports package and 18'' wheels .
Appreciate 0
      05-18-2009, 08:26 PM   #10
chesterfan1230
Colonel
chesterfan1230's Avatar
51
Rep
2,561
Posts

 
Drives: a Bat Mobile :)
Join Date: Apr 2008
Location: NJ

iTrader: (10)

Garage List
2012 335iS  [0.00]
Send a message via AIM to chesterfan1230
Quote:
Originally Posted by LJE92 View Post
how long did it take ....?
also did you go in to limp mode alot when you mashed down on the pedal ?
please if you dnt mind explain what happen to u thanks
yup lol
i felt like i lost 150 horsepower LOL.
I was driving someplace and all of a sudden my car started acting up, braking wierda nd what not. I immediately go straight to the dealer. Drop the car off get it back 3 days later, replaced the Front fan, VANOS system and re flashed the car.
I have an n52 as well.....
__________________
Current: 2012 335iS
Past: 2006 e90 325xi, 2010 135i
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:21 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST