E90Post
 


Alpine HID
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Wash, Wax, Detailing and Cosmetic protection/repairs > problem with my paint job



Reply
 
Thread Tools Search this Thread
      05-31-2009, 04:22 PM   #1
jimmyvo
New Member
 
Drives: 2006 330i e90
Join Date: Aug 2007
Location: new orleans, la

Posts: 27
iTrader: (0)

problem with my paint job

hi, last year i had my front bumper repainted with the oem splitters attached. Yesterday morning I removed the oem splitters and I see this odd residue. I'm not sure if its permanent or removable. Do you guys maybe have any ideas or advice on what I should do? Any help is appreciated, thanks - jimmy


jimmyvo is offline  
0
Reply With Quote
      06-01-2009, 09:30 AM   #2
UncleWede
Long Time Admirer, First Time Owner
 
UncleWede's Avatar
 
Drives: E90 325i Arctic
Join Date: Jun 2005
Location: Oxnard, CA

Posts: 2,272
iTrader: (0)

clay bar, then polish. It kinda looks like the splitters weren't secured very well and bounced around and scuffed the paint, but start with clay bar.
UncleWede is offline   United_States
0
Reply With Quote
      06-01-2009, 10:08 AM   #3
picus
Brigadier General
 
picus's Avatar
 
Drives: e92 SG 335i Coupe
Join Date: Jun 2006
Location: Toronto, ON

Posts: 4,176
iTrader: (0)

Looks like overspray. Probably feels gritty? Claybar it.
picus is offline   Canada
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:47 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST