E90Post
 


E92-lighting
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > LCI iDrive lock ups. Arrrgh!



Reply
 
Thread Tools Search this Thread
      04-14-2009, 07:41 AM   #1
SteveMD
Colonel
 
SteveMD's Avatar
 
Drives: '12 X5 50i, '11 GTI DSG
Join Date: Dec 2005
Location: Raventown!

Posts: 2,363
iTrader: (3)

Garage List
2012 X5 50i  [0.00]
LCI iDrive lock ups. Arrrgh!

Well, something had to go wrong

The iDrive screen will not respond to the controller. This has happened a couple of times now in the two weeks that I have had the car. Previously I have been able to hold down a few buttons and it cleared.

I did find out that a reset is performed by holding in the volume button for about 15 seconds. This does in fact reboot the computer but I end up back where I was before with no controller input. Voice commands work fine and the unit works as advertised.

Any ideas? I guess I'm going to have to take it in.
__________________
2006 E90 330i (retired)
2009 E90 335i (retired)
2012 E70 X5 50i M Sport, JB Stage 1, 4.6 secs 0-60.
2011 VW GTI/DSG
SteveMD is offline   United_States
0
Reply With Quote
      04-14-2009, 09:09 AM   #2
Nomad
Why Ask Why?!
 
Nomad's Avatar
 
Drives: 2009 E90 335xi
Join Date: Jan 2009
Location: Colorado

Posts: 405
iTrader: (0)

Bummer hasn't happened to me yet...but only 800 miles too...good luck let us know what the service guys say.
__________________
2009 335xi E90
||Space Gray|Black Leather|Alum Trim/Pedals|Cold,Sport,Prem Packages|18" Wheels|Paddles|IPOD/USB|Smartphone|Park Assist|Nav/HD/Sirius|Comfort Access|Logic 7|20% Tint|Escort 9500xi||
Nomad is offline   United_States
0
Reply With Quote
      04-14-2009, 09:15 AM   #3
canucklion
pull my finger to get your kinder® surprise
 
canucklion's Avatar
 
Drives: circles around you
Join Date: Dec 2005
Location: Toronto, Canada

Posts: 10,454
iTrader: (9)

wow, holding it down for 15 seconds, that's a hell of a long time for a reset.

Hope your dealer can fix it easily! GL
__________________
canucklion is offline   Canada
0
Reply With Quote
      04-14-2009, 09:39 AM   #4
SteveMD
Colonel
 
SteveMD's Avatar
 
Drives: '12 X5 50i, '11 GTI DSG
Join Date: Dec 2005
Location: Raventown!

Posts: 2,363
iTrader: (3)

Garage List
2012 X5 50i  [0.00]
Yes, luckily I have a dealer literally across the street from my business so it is in there now and I have been talking to them.

At first they thought it may be the pairing of my two phones via Bluetooth but we had lock ups before we did the pairing. In any event, they have unpaired the phones.

They have managed to get it unlocked and are playing with it but no codes or errors have been logged. Which sucks because it will probably keep happening.
__________________
2006 E90 330i (retired)
2009 E90 335i (retired)
2012 E70 X5 50i M Sport, JB Stage 1, 4.6 secs 0-60.
2011 VW GTI/DSG
SteveMD is offline   United_States
0
Reply With Quote
      06-21-2009, 11:58 PM   #5
nood1es
Captain
 
Drives: E70
Join Date: May 2007
Location: Madison, WI

Posts: 669
iTrader: (10)

have u gotten a solution yet from the dealer with this problem? Just happened to me, screen is blank radio and everything works fine..Im just not able to turn the screen back on after I hit the "screen off" option. Even when I push in on the knob.
nood1es is offline  
0
Reply With Quote
      06-22-2009, 11:23 AM   #6
Kilgore Trout
Chicks dig wagons!
 
Kilgore Trout's Avatar
 
Drives: 2009 E91
Join Date: Aug 2008
Location: Where you can see through the people, but not the air (i.e., Los Angeles!)

Posts: 1,375
iTrader: (0)

I got 10,000 miles on my LCI and no probs whatsoever. Hasn't locked up once. Sounds really strange - like a HD problem or something.
__________________
E91 Montego Blue gray leather burl walnut , Idrive, PDC, Logic7, CA, Sirius, xenons, 6FL, ZPP, heated seats, 17" tires.

4, 8, 15, 16, 23, 42
Kilgore Trout is offline  
0
Reply With Quote
      06-22-2009, 01:04 PM   #7
Crisp
Lieutenant Colonel
 
Crisp's Avatar
 
Drives: E60 M5 6 Speed
Join Date: Jun 2008
Location: NYC

Posts: 1,505
iTrader: (1)

Quote:
Originally Posted by Kilgore Trout View Post
I got 10,000 miles on my LCI and no probs whatsoever. Hasn't locked up once. Sounds really strange - like a HD problem or something.
+1


11k miles and the navi only restarded once while i was driving...no other problems or issues.
Crisp is offline   Albania
0
Reply With Quote
Reply

Bookmarks

Tags
idrive, locked, lockups, reset

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:46 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST