E90Post
 


PYSPEED
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > engine malfunction with JB3 pnp "Limp Mode"



Reply
 
Thread Tools Search this Thread
      06-25-2009, 03:47 AM   #1
eminhello
Private First Class
 
Drives: 2007 335
Join Date: Aug 2008
Location: California

Posts: 152
iTrader: (1)

engine malfunction with JB3 pnp "Limp Mode"

so i havnt had the time to post on this but i think its a really big problem.
i have a o8 335i about 11,000 miles on it.
i got the jb3 pnp "programed" and put on mi car by terry himself for 60 bux...

the past month my car has been going into this kind of mode (Engine Malfunction, Reduced power). sometimes it barely takes any power away, but yesterday i was pushing the car to the redline and it went into a really bad limp mode. the engine was shaky and wen i put the car into park to restart it it was rumbling. this mode can also come wen im in low rpm and has happend in 3rd gear??
very confusing and sux when a m3 is next to me and i punch it and it goes into limp mode. anyone else had this problem??? its totally random and the car goes back to normal when i restart it..except for that check engine light that i have now -_-
eminhello is offline   Armenia
0
Reply With Quote
      06-25-2009, 04:46 AM   #2
Bomis
Captain
 
Bomis's Avatar
 
Drives: BMW E92 M3
Join Date: Apr 2009
Location: Sweden

Posts: 992
iTrader: (1)

sounds like its something wrong with the HPFP.....welcome to the family....
__________________


EURO E92 M3 2008 6MT Interlagos ///Fully Loaded! Evolve-R ECU Flash/Gintani Sport Exhaust/MS Stg2 Intake Kit/H&R Springs/MS 18/15 mm spacers/Bmw Perf. Grills/Gloss Black side gills/LCI Tails/LUX V3's/RD license plate leds
Bomis is offline   Sweden
0
Reply With Quote
      06-25-2009, 04:52 AM   #3
eminhello
Private First Class
 
Drives: 2007 335
Join Date: Aug 2008
Location: California

Posts: 152
iTrader: (1)

maybe but i tought if its the HPFP the car wont go back to normal wen restarted?
eminhello is offline   Armenia
0
Reply With Quote
      06-25-2009, 08:18 AM   #4
enrita
Major General
 
enrita's Avatar
 
Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

Posts: 7,318
iTrader: (0)

u should contact Terry and get your car scanned to see which codes you got...
__________________
07 335i AT - TD St.2 Turbos - COBB (Custom Cobb mapping by http://www.protuningfreaks.com/) - JB4G5 ISO - Okada Coils - NGK 5992 Plugs - E85 Walbro - Injen Intake - Helix IC - Snow Stg. 3 - Stett CP - AR DPs - midpipes 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - Level 10 AT upgrade - Alpina AT Flash
enrita is offline   Sweden
0
Reply With Quote
      06-25-2009, 08:23 AM   #5
Morpheus
Captain
 
Drives: 335i Titanium Silver
Join Date: Sep 2008
Location: Cockaigne

Posts: 848
iTrader: (1)

If terry is close enough to you to install the jb3 himself, then what the hell are you doing asking questions on a forum? Doesn't make any sense. Contact him directly by email. He always responds within a few hours from my experience.
Morpheus is offline  
0
Reply With Quote
      06-25-2009, 08:50 AM   #6
Xander
I'm new
 
Xander's Avatar
 
Drives: 997 carrera, Golf R
Join Date: Jan 2009
Location: Buffalo, NY

Posts: 248
iTrader: (4)

It seems like most of the time when your car isn't running 100%, the mods show it much quicker. I made my car 100% stock and had a hell of a time throwing the same codes as I had with procede or JB3, but in the end I was able to do it. Obviously running considerably more boost shows problems in the car much quicker than the few lbs. BMW wants the car to run.

I had the same problem (kinda) and so far I've changed the plugs, and had the intake pressure sensor replaced, and the the Vanos Solenoid for the exhaust side (it was sticking) replaced. I guess my car was pulling timing and acting all funny because of the solenoid. I will put some sort of tuning back on tonight to see if it's "fixed"


X...
Xander is online now   United_States
0
Reply With Quote
      06-25-2009, 11:55 AM   #7
Terrance28
Brigadier General
 
Terrance28's Avatar
 
Drives: Crimson Red E92
Join Date: Nov 2007
Location: Killeen, TX

Posts: 3,336
iTrader: (17)

Send a message via Yahoo to Terrance28
Jesus christ not another one. Contact your tuners do not start a public thread. They can help you better than anyone else can.
__________________
Mods list got too long, lets just say more than enough.
Terrance28 is offline   United_States
0
Reply With Quote
      06-25-2009, 12:34 PM   #8
RambleJ
Colonel
 
RambleJ's Avatar
 
Drives: F10 535i M-sport
Join Date: Oct 2008
Location: Back in teh so cal

Posts: 2,012
iTrader: (2)

Quote:
Originally Posted by Morpheus View Post
If terry is close enough to you to install the jb3 himself, then what the hell are you doing asking questions on a forum? Doesn't make any sense. Contact him directly by email. He always responds within a few hours from my experience.
My thoughts exactly, and you let this go on for a month without contacting Terry to see what was going on?
RambleJ is offline   No_Country
0
Reply With Quote
      06-25-2009, 12:35 PM   #9
bulldog x6
Major General
 
Drives: x6 panzer
Join Date: Oct 2008
Location: probably work

Posts: 5,017
iTrader: (28)

Quote:
Originally Posted by eminhello View Post
sux when a m3 is next to me and i punch it and it goes into limp mode.
I thought you were an m3 killer.. what happened? LOL
bulldog x6 is offline  
0
Reply With Quote
      06-25-2009, 12:38 PM   #10
TurboSid
Colonel
 
TurboSid's Avatar
 
Drives: 2011 AW 335is Coupe DCT
Join Date: Apr 2008
Location: Florida

Posts: 2,023
iTrader: (3)

Garage List
2008 335i  [0.00]
why are u pushing the car to redline when u know something is wrong with it??
__________________
TurboSid is offline  
0
Reply With Quote
      06-25-2009, 12:43 PM   #11
ianthegreat
Colonel
 
ianthegreat's Avatar
 
Drives: n54
Join Date: Apr 2008
Location: Pittsburgh/Houston

Posts: 2,314
iTrader: (1)

Quote:
Originally Posted by TurboSid View Post
why are u pushing the car to redline when u know something is wrong with it??
because.. the 335i is INVINCIBLE.
ianthegreat is offline  
0
Reply With Quote
      06-25-2009, 12:45 PM   #12
sneaks
Lieutenant
 
sneaks's Avatar
 
Drives: '08 335xi
Join Date: Apr 2008
Location: 24 Sussex

Posts: 431
iTrader: (1)

Garage List
2008 335xi  [0.00]
Quote:
Originally Posted by eminhello View Post
......, but yesterday i was pushing the car to the redline and it went into a really bad limp mode......_-
If you knew somthing might be wrong then;
When you rock that hard, sometings gotta give.
sneaks is offline   Canada
0
Reply With Quote
      06-25-2009, 01:00 PM   #13
TreDirtyFive
Captain
 
Drives: 335i Coupe
Join Date: Jun 2008
Location: Los Angeles, CA

Posts: 916
iTrader: (8)

Def. contact Terry but sounds like a Fuel Pump to me.
__________________
335 F30 MSport: N55.Tech.NAV.+
135 DCT:N55.Prem.Sports.NAV.IPod
X-335 E92: Prem.Sports.NAV.IPod
Audi A3: Sports.Tech.NAV.sways.DP.K2 Coils.Flash.etc
X-67 Baracuda Fastback: DragGears.Sway.etc.
TreDirtyFive is offline   United_States
0
Reply With Quote
      06-25-2009, 02:22 PM   #14
eminhello
Private First Class
 
Drives: 2007 335
Join Date: Aug 2008
Location: California

Posts: 152
iTrader: (1)

wow i thought u guys knew how to read...i said i took it to him already and have contacted him about the same problem. just wanted to see what everyone has to say...are you guys woried the JB3's reputation is going to come down or something????
im going to take the tune off and have ask if bmw will check out the fuel pump since i have to delete the codes before i take it in.
eminhello is offline   Armenia
0
Reply With Quote
      06-25-2009, 03:10 PM   #15
RambleJ
Colonel
 
RambleJ's Avatar
 
Drives: F10 535i M-sport
Join Date: Oct 2008
Location: Back in teh so cal

Posts: 2,012
iTrader: (2)

Quote:
Originally Posted by eminhello View Post
wow i thought u guys knew how to read...i said i took it to him already and have contacted him about the same problem. just wanted to see what everyone has to say...are you guys woried the JB3's reputation is going to come down or something????
im going to take the tune off and have ask if bmw will check out the fuel pump since i have to delete the codes before i take it in.
Your post states that you had Terry program(assuming update the chip to the latest version) and install the JB3, not that you had taken it to him after the issues had arisen.
RambleJ is offline   No_Country
0
Reply With Quote
      06-25-2009, 10:20 PM   #16
Morpheus
Captain
 
Drives: 335i Titanium Silver
Join Date: Sep 2008
Location: Cockaigne

Posts: 848
iTrader: (1)

Quote:
Originally Posted by eminhello View Post
wow i thought u guys knew how to read...i said i took it to him already and have contacted him about the same problem. just wanted to see what everyone has to say...are you guys woried the JB3's reputation is going to come down or something????
im going to take the tune off and have ask if bmw will check out the fuel pump since i have to delete the codes before i take it in.
I'm just tired of these posts. Both JB3 and vishnu. They're never productive. How's this one working out for ya?
Morpheus is offline  
0
Reply With Quote
      06-25-2009, 10:35 PM   #17
MACH V
MEFAKED
 
MACH V's Avatar
 
Drives: 335i
Join Date: Jun 2009
Location: FT. Lauderdale, FL

Posts: 51
iTrader: (0)

Send a message via AIM to MACH V
Disconnect your battery for 2 minutes and reconnect. This just happend to me today...
MACH V is offline  
0
Reply With Quote
      06-26-2009, 01:02 AM   #18
wonsungnabi
First Lieutenant
 
Drives: E92 335
Join Date: Dec 2007
Location: Boston MA

Posts: 355
iTrader: (7)

HPFP sucksssssssssssssssssss
wonsungnabi is offline  
0
Reply With Quote
      06-26-2009, 02:10 AM   #19
soontobe
First Lieutenant
 
Drives: 335i
Join Date: Jan 2008
Location: Socal

Posts: 395
iTrader: (1)

Quote:
Originally Posted by TurboSid View Post
why are u pushing the car to redline when u know something is wrong with it??
My thoughts exactly...Can't wait till I get my 335 so I can join the family of issues lol. It's all part of modding cars though, I go through the same shit everyday with my Evo, but I'll never stop haha it's just a way of life!

-RJ
soontobe is offline   United_States
0
Reply With Quote
      06-26-2009, 02:21 AM   #20
gerardm
Captain
 
gerardm's Avatar
 
Drives: '07 335i Sedan - Alpine White
Join Date: Apr 2009
Location: Rocky Point, NY

Posts: 701
iTrader: (5)

Quote:
Originally Posted by Morpheus View Post
I'm just tired of these posts. Both JB3 and vishnu. They're never productive. How's this one working out for ya?
i agree.. ive only been a member for a few months but every day i come on i see another post about someone's car breaking or needing service... it makes me not enjoy my car at all. every time i think about it i dread that todays gonna be the day instead of getting in and having fun. all i think about is the bad thats gonna happen eventually/most likely.

cray thing is i know my car is running fine but every time im in my car now im like trying/waiting to find something wrong to the point where somedays i think i do find things wrong like a bad reverse placebo effect sorta thing.

i gotta stop checking the engine/tuning part of these forums cause i have nightmares all the time from everyones freakin horror stories and reading the same old questions and issues over and over... if ur car dies on you take the shit off and take it in. no need to complain about it anymore everyone knows theres issues with the car and everyone knows running tunes and dp's and mp's are not recommended and will fuck ur warranty down the road if discovered.

auggghhh i feel like screamin

sorry for the rant... sorta but not really
gerardm is offline   United_States
0
Reply With Quote
      06-26-2009, 10:54 AM   #21
NRG
Lieutenant Colonel
 
NRG's Avatar
 
Drives: 2012 X5 35d
Join Date: Mar 2007
Location: Montreal QC

Posts: 1,659
iTrader: (5)

Quote:
Originally Posted by Morpheus View Post
I'm just tired of these posts. Both JB3 and vishnu. They're never productive. How's this one working out for ya?
WTF you're talking about? For the OP, best to contact BMS tech support!
__________________

Retired: 2005 N52 E90 330i Sport 6AT
Retired: 2007 N54 E92 335i Sport 6AT

Current: 2012 M57 E70 X5 xDrive35D
NRG is offline   Russian Federation
0
Reply With Quote
      06-26-2009, 12:37 PM   #22
E92White
**N54 Power Baby**
 
E92White's Avatar
 
Drives: E82 135i SGM
Join Date: Nov 2008
Location: Brownsville,TX

Posts: 681
iTrader: (3)

Quote:
Originally Posted by gerardm View Post
i agree.. ive only been a member for a few months but every day i come on i see another post about someone's car breaking or needing service... it makes me not enjoy my car at all. every time i think about it i dread that todays gonna be the day instead of getting in and having fun. all i think about is the bad thats gonna happen eventually/most likely.

cray thing is i know my car is running fine but every time im in my car now im like trying/waiting to find something wrong to the point where somedays i think i do find things wrong like a bad reverse placebo effect sorta thing.

i gotta stop checking the engine/tuning part of these forums cause i have nightmares all the time from everyones freakin horror stories and reading the same old questions and issues over and over... if ur car dies on you take the shit off and take it in. no need to complain about it anymore everyone knows theres issues with the car and everyone knows running tunes and dp's and mp's are not recommended and will fuck ur warranty down the road if discovered.

auggghhh i feel like screamin

sorry for the rant... sorta but not really
+10000..bottom line folks : Scan your car (if possible)Contact your tuner if you're having limp modes,etc..if you cant find a solution(which im sure you will) then,and only then post a thread about it.

I had a problem with the wiring in the accelerator pedal module (non tune related)a while back,and could never figure it out..the dealer finally figured out,thru the process of elimination..I posted a thread a way back,but only because nobody could figure out the problem!
E92White is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:00 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST