E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > KW Noise issue?



Reply
 
Thread Tools Search this Thread
      06-03-2009, 04:23 PM   #1
Tom@KW
Registered
 
Drives: KW Equipped
Join Date: Jun 2009
Location: Sanger CA

Posts: 4
iTrader: (0)

KW Noise issue?

We have received several emails from customers having a noise in the front of there suspension after the installation of the KW coilovers.

Last week, our GM spent some time in Germany reviewing the report from the US with the German R&D team, and trying to recreate the problem in the test cars we used to build the system. Unfortunately at this point, we have been un able to do so.

What we are looking for is a car that currently has this noise issue that is able to bring the vehicle to our facilities in Central California. In this way we can investigate the noise to try and find the problem, and therefore a solution for the customers who do have it.

If you or anyone you know who has this issue is available to bring the car to us for investigation, please contact our offices directly, and we can setup a time that will work for you to have it in our Sanger CA facility.

Tom Edge

KW automotive North America, Inc

1075 North Avenue

Sanger, CA 93657

Tel: +1 559.875.0222 ext. 143

Fax: +1 559.876.2259

Email: tom.edge@kwautomotive.com

Web: www.kwautomotive.com
Tom@KW is offline  
0
Reply With Quote
      06-03-2009, 06:35 PM   #2
Ferg
Master of my own domain!!
 
Ferg's Avatar
 
Drives: E92 XI
Join Date: Dec 2006
Location: Tacoma, WA

Posts: 600
iTrader: (0)

Tom,
How long do you estimate you will need the car?
__________________
Ferg is offline  
0
Reply With Quote
      06-03-2009, 09:37 PM   #3
Diesel///M
Colonel
 
Drives: E92 ///M
Join Date: Apr 2007
Location: IN NY/NJ, missing FL

Posts: 2,295
iTrader: (20)

ferg please do so i can get my noise fixed lol
Diesel///M is offline  
0
Reply With Quote
      06-04-2009, 02:02 PM   #4
SV Concepts
 
SV Concepts's Avatar
 
Drives: Vorsteiner E60 M5
Join Date: Mar 2006
Location: 1460 White Oaks Rd. Suite F. Campbell, CA 95008

Posts: 5,869
iTrader: (10)

Only noise I have is the shock compression, which is louder than you would expect, but not unusual.

Other than that, loving my K-Dubbs
SV Concepts is offline   United_States
0
Reply With Quote
      06-04-2009, 03:49 PM   #5
Ferg
Master of my own domain!!
 
Ferg's Avatar
 
Drives: E92 XI
Join Date: Dec 2006
Location: Tacoma, WA

Posts: 600
iTrader: (0)

Diesel, do you want to drive to CA, LOL! I really don't want to drive the 3hrs to their CA location, but I will to not only help myself, but everyone else.
__________________
Ferg is offline  
0
Reply With Quote
      06-22-2009, 10:49 AM   #6
Tom@KW
Registered
 
Drives: KW Equipped
Join Date: Jun 2009
Location: Sanger CA

Posts: 4
iTrader: (0)

Ladies and Gentlemen

At this point this post has been on the board coming up on three weeks. I have received 1 phone call (I believe from Ferg) regarding the “chirp”. Unfortunately he has not been able to bring us his vehicle, and is not sure weather his noise is related to the same issue others are having.

As I stated in my original post, we have not been able to recreate this problem in house, and we need a car that is actually having the issue to see if we can find the source of the problem.

Again, if anyone has the ability to bring us there vehicle that is having this noise issue, please contact us directly at the phone number listed below.

Tom Edge

KW automotive North America, Inc
1075 North Avenue
Sanger, CA 93657
Tel: +1 559.875.0222 ext. 143
Fax: +1 559.876.2259
Email: tom.edge@kwautomotive.com
Web: www.kwautomotive.com
Tom@KW is offline  
0
Reply With Quote
      06-22-2009, 11:46 AM   #7
ThorsHammer
Major
 
ThorsHammer's Avatar
 
Drives: '09 BMW 335i Coupe
Join Date: Jan 2009
Location: San Antonio, TX

Posts: 1,389
iTrader: (10)

Awesome customer service. So glad I have some ST-V1's on the way!
__________________
"SYONRA" is for sale! http://www.e90post.com/forums/showthread.php?t=366678 BSM '09 e92 335i | Performance: JB3, RR Catted DP's, INJEN DCI, Britalman Exhst, AA FMIC, FORGE DVs | Suspension: ST-V1 Coils, Hotchkis Chassis Brace & F/R Sways | Wheels: Bremmer Kraft BR03s, Brake Performance Rotors, Cool Carbon Pads, ECS Lines | Exterior: OEM Aero Lip/Rear, ****** CF Trunk Lid, BLUX5 Angels, M-Force M3 Sides | Interior: Passport 9500ci, Black Trim, M3 Wheel
ThorsHammer is offline   United_States
0
Reply With Quote
      06-22-2009, 12:19 PM   #8
Ron@Modbargains
 
Ron@Modbargains's Avatar
 
Drives: 996TT/ae86
Join Date: Aug 2005
Location: 1721 E. Lambert Rd #C, La Habra, CA 90631

Posts: 2,201
iTrader: (3)

Send a message via AIM to Ron@Modbargains
GJ Tom in addressing people's concern
Ron@Modbargains is offline   United_States
0
Reply With Quote
      06-22-2009, 01:39 PM   #9
Digital.James
Colonel
 
Digital.James's Avatar
 
Drives: E92 M3
Join Date: Sep 2007
Location: NC

Posts: 2,610
iTrader: (7)

I have noise issues with my V2s, but its not a chirp. Just sounds like hydraulic compression
Digital.James is offline  
0
Reply With Quote
      06-22-2009, 06:22 PM   #10
Mantooth
Private First Class
 
Drives: 335i E92 montego blue
Join Date: May 2009
Location: San Diego

Posts: 174
iTrader: (4)

I thought the problem that most people experience was from improper install (torque-ing the nuts on the fronts). It seems that most threads I have read about the noise issue were resolved with this. At least that is the impression I got before I just bought mine from a member here.

Great, now I just bought them used so i'm sure KW won't fix them if there really is a problem.
Mantooth is offline  
0
Reply With Quote
      06-23-2009, 02:39 AM   #11
AKbmw
Colonel
 
AKbmw's Avatar
 
Drives: M-Sport LCI
Join Date: Dec 2006
Location: LA

Posts: 2,922
iTrader: (12)

i had first experienced that loud noice from my KW's when i first got them, but longtran helped me fix it. on way way home today i noticed the noise came back! i got so upset since every day i get a problem on my car ( valet f-ed up my rim yesterday so i gotta fix that) gotta take it in for service but can never find time, and now my KW's are making a REALLY loud noise for little bumps.... ill give you my car , PM me with your adress and how long you will need the car, if you are not too far ill be more than happy for you to fix my coilovers for me
__________________
AKbmw is offline   Armenia
0
Reply With Quote
      06-23-2009, 12:13 PM   #12
Tom@KW
Registered
 
Drives: KW Equipped
Join Date: Jun 2009
Location: Sanger CA

Posts: 4
iTrader: (0)

AKbmw

If you are currently experiencing the noise issue that others have, a “chirping” usually coming form the passenger side front, please call our offices directly, and we can sent up a time to bring you in and diagnose the car.

KW automotive North America, Inc
1075 North Avenue
Sanger, CA 93657
Tel: +1 559.875.0222 ext. 143
Fax: +1 559.876.2259
Email: tom.edge@kwautomotive.com
Web: www.kwautomotive.com
Tom@KW is offline  
0
Reply With Quote
      06-23-2009, 02:04 PM   #13
AKbmw
Colonel
 
AKbmw's Avatar
 
Drives: M-Sport LCI
Join Date: Dec 2006
Location: LA

Posts: 2,922
iTrader: (12)

Wow that's 3 and a half hours away ... I'll see if I can do that one day ...
__________________
AKbmw is offline   Armenia
0
Reply With Quote
      06-23-2009, 04:14 PM   #14
Ferg
Master of my own domain!!
 
Ferg's Avatar
 
Drives: E92 XI
Join Date: Dec 2006
Location: Tacoma, WA

Posts: 600
iTrader: (0)

Yeah, that was my problem too. Quite a drive.
__________________
Ferg is offline  
0
Reply With Quote
      06-25-2009, 12:41 AM   #15
Mantooth
Private First Class
 
Drives: 335i E92 montego blue
Join Date: May 2009
Location: San Diego

Posts: 174
iTrader: (4)

Why can't KW go to the people volunteering their cars?
Mantooth is offline  
0
Reply With Quote
      06-25-2009, 08:38 AM   #16
mwahlert
Lieutenant Colonel
 
mwahlert's Avatar
 
Drives: 2008 335i
Join Date: Apr 2008
Location: Durham, NC

Posts: 1,554
iTrader: (7)

Garage List
2007 335i  [0.00]
i don't have any squeaking - i get a kinda of clunk sound over various bumps - but not all the time.

it usually happens when i am going from high to low pavement. sounds like its coming from the front strut mounts or something..idk - just never took the time to investigate it..
mwahlert is offline  
0
Reply With Quote
      06-25-2009, 08:42 AM   #17
Kevin@AKMotorwerk
General
 
Kevin@AKMotorwerk's Avatar
 
Drives: THE GUY YOU LOVE TO HATE
Join Date: Mar 2009
Location: hillsborough, nj

Posts: 28,154
iTrader: (1)

Quote:
Originally Posted by mwahlert View Post
i don't have any squeaking - i get a kinda of clunk sound over various bumps - but not all the time.

it usually happens when i am going from high to low pavement. sounds like its coming from the front strut mounts or something..idk - just never took the time to investigate it..
im almost positive yours is the sway bar end link bolts coming loose. tighten them first and see if it went away. if you want to prevent it next time just apply blue loctite before tightening.
Kevin@AKMotorwerk is offline   United_States
0
Reply With Quote
      06-25-2009, 08:51 AM   #18
mwahlert
Lieutenant Colonel
 
mwahlert's Avatar
 
Drives: 2008 335i
Join Date: Apr 2008
Location: Durham, NC

Posts: 1,554
iTrader: (7)

Garage List
2007 335i  [0.00]
Quote:
Originally Posted by sexye92 View Post
im almost positive yours is the sway bar end link bolts coming loose. tighten them first and see if it went away. if you want to prevent it next time just apply blue loctite before tightening.
cool i'll check!
mwahlert is offline  
0
Reply With Quote
      06-28-2009, 09:35 PM   #19
original786
Major
 
Drives: 2007 335i
Join Date: Jun 2009
Location: Atlanta

Posts: 1,430
iTrader: (11)

it sucks for me im all the way in atlanta,
but i have like almost like a slight clunk noise from the front with the kw's
or maybe its like the hydraulic.. i dont know what to do

should i take it to the dealer??
original786 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:26 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST