E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > KW Noise issue?



Reply
 
Thread Tools Search this Thread
      06-03-2009, 05:23 PM   #1
Tom@KW
Registered
0
Rep
4
Posts

Drives: KW Equipped
Join Date: Jun 2009
Location: Sanger CA

iTrader: (0)

KW Noise issue?

We have received several emails from customers having a noise in the front of there suspension after the installation of the KW coilovers.

Last week, our GM spent some time in Germany reviewing the report from the US with the German R&D team, and trying to recreate the problem in the test cars we used to build the system. Unfortunately at this point, we have been un able to do so.

What we are looking for is a car that currently has this noise issue that is able to bring the vehicle to our facilities in Central California. In this way we can investigate the noise to try and find the problem, and therefore a solution for the customers who do have it.

If you or anyone you know who has this issue is available to bring the car to us for investigation, please contact our offices directly, and we can setup a time that will work for you to have it in our Sanger CA facility.

Tom Edge

KW automotive North America, Inc

1075 North Avenue

Sanger, CA 93657

Tel: +1 559.875.0222 ext. 143

Fax: +1 559.876.2259

Email: tom.edge@kwautomotive.com

Web: www.kwautomotive.com
Appreciate 0
      06-03-2009, 07:35 PM   #2
Ferg
Master of my own domain!!
Ferg's Avatar
10
Rep
602
Posts

Drives: E92 XI
Join Date: Dec 2006
Location: Tacoma, WA

iTrader: (0)

Tom,
How long do you estimate you will need the car?
__________________
Appreciate 0
      06-03-2009, 10:37 PM   #3
Diesel///M
Colonel
31
Rep
2,306
Posts

Drives: E92 ///M
Join Date: Apr 2007
Location: IN NY/NJ, missing FL

iTrader: (20)

ferg please do so i can get my noise fixed lol
Appreciate 0
      06-04-2009, 03:02 PM   #4
SV Concepts
SV Concepts's Avatar
United_States
175
Rep
5,869
Posts

Drives: Vorsteiner E60 M5
Join Date: Mar 2006
Location: 1460 White Oaks Rd. Suite F. Campbell, CA 95008

iTrader: (10)

Only noise I have is the shock compression, which is louder than you would expect, but not unusual.

Other than that, loving my K-Dubbs
Appreciate 0
      06-04-2009, 04:49 PM   #5
Ferg
Master of my own domain!!
Ferg's Avatar
10
Rep
602
Posts

Drives: E92 XI
Join Date: Dec 2006
Location: Tacoma, WA

iTrader: (0)

Diesel, do you want to drive to CA, LOL! I really don't want to drive the 3hrs to their CA location, but I will to not only help myself, but everyone else.
__________________
Appreciate 0
      06-22-2009, 11:49 AM   #6
Tom@KW
Registered
0
Rep
4
Posts

Drives: KW Equipped
Join Date: Jun 2009
Location: Sanger CA

iTrader: (0)

Ladies and Gentlemen

At this point this post has been on the board coming up on three weeks. I have received 1 phone call (I believe from Ferg) regarding the “chirp”. Unfortunately he has not been able to bring us his vehicle, and is not sure weather his noise is related to the same issue others are having.

As I stated in my original post, we have not been able to recreate this problem in house, and we need a car that is actually having the issue to see if we can find the source of the problem.

Again, if anyone has the ability to bring us there vehicle that is having this noise issue, please contact us directly at the phone number listed below.

Tom Edge

KW automotive North America, Inc
1075 North Avenue
Sanger, CA 93657
Tel: +1 559.875.0222 ext. 143
Fax: +1 559.876.2259
Email: tom.edge@kwautomotive.com
Web: www.kwautomotive.com
Appreciate 0
      06-22-2009, 12:46 PM   #7
ThorsHammer
Major
ThorsHammer's Avatar
United_States
35
Rep
1,389
Posts

Drives: '09 BMW 335i Coupe
Join Date: Jan 2009
Location: San Antonio, TX

iTrader: (10)

Awesome customer service. So glad I have some ST-V1's on the way!
__________________
"SYONRA" is for sale! http://www.e90post.com/forums/showthread.php?t=366678 BSM '09 e92 335i | Performance: JB3, RR Catted DP's, INJEN DCI, Britalman Exhst, AA FMIC, FORGE DVs | Suspension: ST-V1 Coils, Hotchkis Chassis Brace & F/R Sways | Wheels: Bremmer Kraft BR03s, Brake Performance Rotors, Cool Carbon Pads, ECS Lines | Exterior: OEM Aero Lip/Rear, ****** CF Trunk Lid, BLUX5 Angels, M-Force M3 Sides | Interior: Passport 9500ci, Black Trim, M3 Wheel
Appreciate 0
      06-22-2009, 01:19 PM   #8
Ron@Modbargains
Ron@Modbargains's Avatar
United_States
34
Rep
2,201
Posts

Drives: 996TT/ae86
Join Date: Aug 2005
Location: 1721 E. Lambert Rd #C, La Habra, CA 90631

iTrader: (3)

Send a message via AIM to Ron@Modbargains
GJ Tom in addressing people's concern
Appreciate 0
      06-22-2009, 02:39 PM   #9
Digital.James
Colonel
Digital.James's Avatar
41
Rep
2,613
Posts

Drives: E92 M3
Join Date: Sep 2007
Location: NC

iTrader: (7)

I have noise issues with my V2s, but its not a chirp. Just sounds like hydraulic compression
Appreciate 0
      06-22-2009, 07:22 PM   #10
Mantooth
Private First Class
6
Rep
174
Posts

Drives: 335i E92 montego blue
Join Date: May 2009
Location: San Diego

iTrader: (4)

I thought the problem that most people experience was from improper install (torque-ing the nuts on the fronts). It seems that most threads I have read about the noise issue were resolved with this. At least that is the impression I got before I just bought mine from a member here.

Great, now I just bought them used so i'm sure KW won't fix them if there really is a problem.
Appreciate 0
      06-23-2009, 03:39 AM   #11
AKbmw
Colonel
AKbmw's Avatar
Armenia
73
Rep
2,923
Posts

Drives: M-Sport LCI
Join Date: Dec 2006
Location: LA

iTrader: (12)

i had first experienced that loud noice from my KW's when i first got them, but longtran helped me fix it. on way way home today i noticed the noise came back! i got so upset since every day i get a problem on my car ( valet f-ed up my rim yesterday so i gotta fix that) gotta take it in for service but can never find time, and now my KW's are making a REALLY loud noise for little bumps.... ill give you my car , PM me with your adress and how long you will need the car, if you are not too far ill be more than happy for you to fix my coilovers for me
__________________
Appreciate 0
      06-23-2009, 01:13 PM   #12
Tom@KW
Registered
0
Rep
4
Posts

Drives: KW Equipped
Join Date: Jun 2009
Location: Sanger CA

iTrader: (0)

AKbmw

If you are currently experiencing the noise issue that others have, a “chirping” usually coming form the passenger side front, please call our offices directly, and we can sent up a time to bring you in and diagnose the car.

KW automotive North America, Inc
1075 North Avenue
Sanger, CA 93657
Tel: +1 559.875.0222 ext. 143
Fax: +1 559.876.2259
Email: tom.edge@kwautomotive.com
Web: www.kwautomotive.com
Appreciate 0
      06-23-2009, 03:04 PM   #13
AKbmw
Colonel
AKbmw's Avatar
Armenia
73
Rep
2,923
Posts

Drives: M-Sport LCI
Join Date: Dec 2006
Location: LA

iTrader: (12)

Wow that's 3 and a half hours away ... I'll see if I can do that one day ...
__________________
Appreciate 0
      06-23-2009, 05:14 PM   #14
Ferg
Master of my own domain!!
Ferg's Avatar
10
Rep
602
Posts

Drives: E92 XI
Join Date: Dec 2006
Location: Tacoma, WA

iTrader: (0)

Yeah, that was my problem too. Quite a drive.
__________________
Appreciate 0
      06-25-2009, 01:41 AM   #15
Mantooth
Private First Class
6
Rep
174
Posts

Drives: 335i E92 montego blue
Join Date: May 2009
Location: San Diego

iTrader: (4)

Why can't KW go to the people volunteering their cars?
Appreciate 0
      06-25-2009, 09:38 AM   #16
mwahlert
Lieutenant Colonel
mwahlert's Avatar
30
Rep
1,569
Posts

Drives: 2008 335i
Join Date: Apr 2008
Location: Durham, NC

iTrader: (7)

Garage List
2007 335i  [0.00]
i don't have any squeaking - i get a kinda of clunk sound over various bumps - but not all the time.

it usually happens when i am going from high to low pavement. sounds like its coming from the front strut mounts or something..idk - just never took the time to investigate it..
Appreciate 0
      06-25-2009, 09:42 AM   #17
Kevin@AKMotorwerk
General
Kevin@AKMotorwerk's Avatar
United_States
281
Rep
28,154
Posts

Drives: THE GUY YOU LOVE TO HATE
Join Date: Mar 2009
Location: hillsborough, nj

iTrader: (1)

Quote:
Originally Posted by mwahlert View Post
i don't have any squeaking - i get a kinda of clunk sound over various bumps - but not all the time.

it usually happens when i am going from high to low pavement. sounds like its coming from the front strut mounts or something..idk - just never took the time to investigate it..
im almost positive yours is the sway bar end link bolts coming loose. tighten them first and see if it went away. if you want to prevent it next time just apply blue loctite before tightening.
Appreciate 0
      06-25-2009, 09:51 AM   #18
mwahlert
Lieutenant Colonel
mwahlert's Avatar
30
Rep
1,569
Posts

Drives: 2008 335i
Join Date: Apr 2008
Location: Durham, NC

iTrader: (7)

Garage List
2007 335i  [0.00]
Quote:
Originally Posted by sexye92 View Post
im almost positive yours is the sway bar end link bolts coming loose. tighten them first and see if it went away. if you want to prevent it next time just apply blue loctite before tightening.
cool i'll check!
Appreciate 0
      06-28-2009, 10:35 PM   #19
original786
Major
20
Rep
1,432
Posts

Drives: 2007 335i
Join Date: Jun 2009
Location: Atlanta

iTrader: (11)

it sucks for me im all the way in atlanta,
but i have like almost like a slight clunk noise from the front with the kw's
or maybe its like the hydraulic.. i dont know what to do

should i take it to the dealer??
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 06:02 AM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST