E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > ConnectedDrive / I-Drive / Navigation Related Discussion > iDrive / HD Radio Malfunction



Reply
 
Thread Tools Search this Thread
      08-26-2009, 01:09 PM   #1
nycuser123
Registered
 
Drives: 2009 335xi
Join Date: Aug 2009
Location: NYC

Posts: 2
iTrader: (0)

iDrive / HD Radio Malfunction

I have a 2009 335 x-Drive sedan w/ Navi, and starting a couple of weeks ago, whenever a radio station goes into the HD mode (the little HD icon appears in the radio section of the navi screen), all of a sudden the radio starts to sound like a bad phone connection with every other 1/10th of a second cutting out. At first i thought it was a specific station, but soon realized that every station does this. Anyone else having this issue?

I took the car in for warranty service, and was told that it's a software issue that can't be fixed immediately, and i would need to wait several weeks for the fix.

Secondly, anyone else having issues with the Navi being somewhat imprecise in the NYC area?

Any feedback much appreciated.
nycuser123 is offline  
0
Reply With Quote
      08-28-2009, 02:58 PM   #2
Lrscpa
Second Lieutenant
 
Lrscpa's Avatar
 
Drives: 09 328i XDrive
Join Date: Jan 2007
Location: New Jersey

Posts: 231
iTrader: (0)

I had a similar situation with the HD radio driving up Rt 46 in NJ just past the I-95 interchange. Eventually stopped after getting off of Rt 46. I passed it off as being the HD radio equivalent of what happens on conventional radio when you drive by high tension wires.
__________________

2013 F30 335i xDrive Mineral Grey/Black Leather Premium|Cold|Tech|Driver Assist|HK Sound
2011 E90 328i xDrive Space Grey/Black Leather(Retired)
2009 E90 328i xDrive Monaco Blue/Saddle Brown Leather(Retired)
2007 E90 328i xDrive Graphite/Black Leather (Retired)
Lrscpa is offline   United_States
0
Reply With Quote
      09-01-2009, 08:25 AM   #3
nycuser123
Registered
 
Drives: 2009 335xi
Join Date: Aug 2009
Location: NYC

Posts: 2
iTrader: (0)

thanks.

Since the problem began i've taken the car to a dealer and apparently this is a known issue with HD radio. (When it isn't in the HD mode, it works great btw). The software fix is supposedly coming out in a few weeks and presumably all dealers should have them available.
nycuser123 is offline  
0
Reply With Quote
      09-01-2009, 08:26 AM   #4
Prowess Symphony
Major General
 
Prowess Symphony's Avatar
 
Drives: ///Mistress
Join Date: Nov 2008
Location: WV

Posts: 5,859
iTrader: (12)

Garage List
The dealer said there is a software fix coming soon? I hope it fixes all the other idrive bugs not just the hd radio one. My dealer said it would take the entire day to reinstall the idrive software.
Prowess Symphony is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Tags
idrive, malfunction, navi, radio

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:33 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST