TNT Racewerks
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Injen intake warranty question

Thread Tools Search this Thread
      09-19-2009, 11:35 AM   #1
RYANBOZ7's Avatar

Drives: 2008 BMW 335i TiAg COUPE
Join Date: Jan 2008

iTrader: (3)

Injen intake warranty question

Ok,I bought an Injen intake for my 335 and called the dealer in advance and they said it would not void my warranty as long as I didn't chip the car so after having it installed and having it for about three weeks,I went to take off at a light and a picture of my engine half colored in showed up on the dash and I felt a loss of power,like the turbos weren't working.Anyway,I took the car in and Bmw said there was a software upgrade and that should fix it but I just got the car back and the same thing happened.I'm wondering if anyone has had the same problem and what was done.Also,someone said that there is something to do with taking the negative charge out of the battery when installing the cold air intake? My service advisor did say I can bring it back in without the intake on and they will relook at the car but I'm really wanting to keep my intake on if possible without having any issues.Hopefully someone on here has had the same problem and can help.Thanks in advance....
Appreciate 0


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 12:10 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST