E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Any BMW Techs That Can Help - Fault 2AD8 "Implausible"



Reply
 
Thread Tools Search this Thread
      09-18-2009, 06:53 PM   #1
jmd_forest
Enlisted Member
0
Rep
45
Posts

 
Drives: 2008 328xi
Join Date: Jun 2009
Location: South NJ

iTrader: (0)

Any BMW Techs That Can Help - Fault 2AD8 "Implausible"

2008 328xi is NOT under warranty or I would have this at the dealer.

I'm getting a recurring SES light due to fault 2AD8 (EAC Sensor Monitoring/Control). There is a SBI 121607 describing this issue for cars produced up to 8/2007 (mine was produced 4/2008) stating implausible temperature differences at startup with the fix being a ProgMan update.

I'm getting this while driving, not at startup.

The fault events show the engine temp around 98 - 101 degrees Celsius, coolant temp between 55 - 75 degrees Celsius, and ambient temp around 17-18 degrees Celsius.

The car is a salvage unit. Radiator was replaced with used unit from 2006 328xi and I transplanted a sensor in the original radiator into the 2006 radiator. The thermostat and housing were also replaced with new.

I'm at a loss on what to do next. I'm considering replacing the lower hose temp sensor and the engine temp sensor but I don't want to just throw parts at it.

Any help would be appreciated.

jmd_forest
Appreciate 0
      09-18-2009, 08:40 PM   #2
bayerischeperformance
Second Lieutenant
4
Rep
237
Posts

 
Drives: e46 m3
Join Date: Jun 2008
Location: Fairfax, va

iTrader: (3)

correct parts for that car would have been a good start
Appreciate 0
      09-18-2009, 09:02 PM   #3
volkswackin
Lieutenant Colonel
United_States
19
Rep
1,918
Posts

 
Drives: too broke for a BMW
Join Date: Jan 2008
Location: i get around..

iTrader: (1)

youve created too many variables for me to even really want to guess..
Appreciate 0
      09-19-2009, 01:48 PM   #4
jmd_forest
Enlisted Member
0
Rep
45
Posts

 
Drives: 2008 328xi
Join Date: Jun 2009
Location: South NJ

iTrader: (0)

Yes, yes yes....in retrospect, springing for the $750 radiator only available from the dealer would have been smarter than the $125 used unit that I didn't know didn't include the sensor until it arrived in the mail. Live and learn.

The only additional variable is the transplanted sensor into the radiator so, go ahead take a shot.

Does any of the data provided in the recorded events indicate a problem? Engine temp of 101 C seems a bit high, but it seems reasonable if is were coming from the transplanted rad sensor it would be LOWER that actual not higher due to brazed fit of the original sensor. Unfortunatley, since these cars do not have a temp gauge, its a bit hard to monitor the temp while driving.

I'm leaning toward either the new thermostat is not operating correctly or the transplanted sensor. I'd just like enough confidence that if I replaced wither of these costly items, it will actually solve the problem.

If anyone know of a way to test the thermostat, please chime in. IIRC it is one of the new electrically operated units, not a standard wax expansion unit.

Thank you for the responses. I appreciate the help.

jmd_forest
Appreciate 0
      09-19-2009, 03:29 PM   #5
StoneCold
Captain
8
Rep
614
Posts

 
Drives: BMW 2008 328i Coupe, Pro 02/08
Join Date: Mar 2008
Location: Vancouver, WA

iTrader: (1)

Quote:
Originally Posted by jmd_forest View Post
Yes, yes yes....in retrospect, springing for the $750 radiator only available from the dealer would have been smarter than the $125 used unit that I didn't know didn't include the sensor until it arrived in the mail. Live and learn.

The only additional variable is the transplanted sensor into the radiator so, go ahead take a shot.

Does any of the data provided in the recorded events indicate a problem? Engine temp of 101 C seems a bit high, but it seems reasonable if is were coming from the transplanted rad sensor it would be LOWER that actual not higher due to brazed fit of the original sensor. Unfortunatley, since these cars do not have a temp gauge, its a bit hard to monitor the temp while driving.

I'm leaning toward either the new thermostat is not operating correctly or the transplanted sensor. I'd just like enough confidence that if I replaced wither of these costly items, it will actually solve the problem.

If anyone know of a way to test the thermostat, please chime in. IIRC it is one of the new electrically operated units, not a standard wax expansion unit.

Thank you for the responses. I appreciate the help.

jmd_forest

Temp sensor failed. This one attached to the radiator and you MUST replace the radiator along with the sensor to solve this issues. You are right there Op. Go for it & GL.
Appreciate 0
      09-19-2009, 04:14 PM   #6
jmd_forest
Enlisted Member
0
Rep
45
Posts

 
Drives: 2008 328xi
Join Date: Jun 2009
Location: South NJ

iTrader: (0)

Thanks for the help. I'll be ordering the rad Monday. Tischer seems to have the best price, $440 vrs the $750 quote on RealOEM.com . Thats one expensive sensor.

jmd_forest
Appreciate 0
      09-19-2009, 04:22 PM   #7
StoneCold
Captain
8
Rep
614
Posts

 
Drives: BMW 2008 328i Coupe, Pro 02/08
Join Date: Mar 2008
Location: Vancouver, WA

iTrader: (1)

Quote:
Originally Posted by jmd_forest View Post
Thanks for the help. I'll be ordering the rad Monday. Tischer seems to have the best price, $440 vrs the $750 quote on RealOEM.com . Thats one expensive sensor.

jmd_forest
Yeah, I agreed. Due to the latest model, the sensor attached to the radiator and when it fails. You MUST be replaced both of them at one.
Appreciate 0
      09-28-2009, 05:33 PM   #8
jmd_forest
Enlisted Member
0
Rep
45
Posts

 
Drives: 2008 328xi
Join Date: Jun 2009
Location: South NJ

iTrader: (0)

I installed the new rad and EAC sensor today and cleared the faults. All seems well but the 2AD8 code seemed to crop up randomly. After a couple short test drives, there have been no faults logged.

I'll see how things work out over the next week or 2.

jmd_forest
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:55 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST