E90Post
 


E92-lighting
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > check engine soon, BMW says its =>



Reply
 
Thread Tools Search this Thread
      11-22-2009, 11:15 AM   #1
E92_328i_Boston
First Lieutenant
 
Drives: 2008 E92 328i
Join Date: Apr 2008
Location: Boston

Posts: 313
iTrader: (0)

check engine soon, BMW says its =>

"tank vent valve fault"

2008 328i coupe. 10,400 miles. never a single problem until the check engine soon light came on yesterday morning. no other symptoms whatsoever. just the light.

has anyone ever heard of this or experienced the same thing?

they recommended that a "reprogramming" be done, but they could not do that today (something about the computer/software being updated on Sundays).

any further info will be greatly appreciated! thank you in advance.

-A
E92_328i_Boston is offline   United_States
0
Reply With Quote
      11-22-2009, 01:35 PM   #2
bsamoul
Major General
 
bsamoul's Avatar
 
Drives: E90 325i
Join Date: Feb 2007
Location: Walnut Creek, California

Posts: 7,424
iTrader: (2)

Send a message via AIM to bsamoul
a gas tank valve sounds important.
__________________
-Brian
2X 2006 BMW 325i [Electric Red & Mystic Blue] | ZPP | V1 | Rear Fogs | M3 Lip Spoiler | EAS RemoteKey | BMS Powerbox | Projector90 Headlights w/ LED AE | LED plate lights | OEM Blacklines
http://www.tech-shine.com
bsamoul is offline   No_Country
0
Reply With Quote
      11-22-2009, 01:43 PM   #3
Marcumac
Lieutenant Colonel
 
Marcumac's Avatar
 
Drives: M Roadster
Join Date: May 2009
Location: Cincinnati

Posts: 1,526
iTrader: (6)

Garage List
Send a message via Skype™ to Marcumac
My first thought was that you maybe didn't screw on the gas cap tightly enough, if only it were that simple huh.
__________________

ZSP|ZPP|ZCW|PDC|19x9.5/10.5 Varrstoen ES 1.1.2|OEM Blacklines|LUX 5.1|Rear Euro fogs|Muffler delete|ECS kidneys|Gunsmoke Ambergones|Tinted JLevi sidemarkers|30% Llumar ATX|Corner Delete
Marcumac is offline   United_States
0
Reply With Quote
      11-22-2009, 07:30 PM   #4
E92_328i_Boston
First Lieutenant
 
Drives: 2008 E92 328i
Join Date: Apr 2008
Location: Boston

Posts: 313
iTrader: (0)

I first checked the cap before bringing it to BMW. They never once mentioned that the "tank vent valve" might actually/mechanically be in need of replacement. Rather, they led me to believe it was a software issue.

Any additional comments?

-A
E92_328i_Boston is offline   United_States
0
Reply With Quote
      11-22-2009, 08:08 PM   #5
waylap
Private
 
waylap's Avatar
 
Drives: 06 330i
Join Date: Jun 2009
Location: S. Florida

Posts: 67
iTrader: (0)

Second time this month mine has done it. First time, they had it 2 hours and said it was "loose gas cap".--- riiight, it's idiot proof and I'm sure it was on right. It came on a week later and I know damn well it isnt a loose cap. We'll see in the morning when I drop it off again. Had to wait a week for an apt with a loaner available.
__________________
2006 330i Titanium Silver
waylap is offline  
0
Reply With Quote
      11-22-2009, 08:27 PM   #6
dimabimmer
Lieutenant Colonel
 
dimabimmer's Avatar
 
Drives: '11 E92 M3 ZCP 6MT
Join Date: Apr 2009
Location: Brooklyn to SoHo NYC

Posts: 1,746
iTrader: (0)

I was driving my 335i hard in morning, "engine malfunction" came up. I stopped the car, turned engine off, restarted (its what i usualy do to bypass limp mode)...after restart all was fine, so I drove car hard again to see if error comes back...and it did,- "engine malfunction" came back. Again, stop, restart, drives fine, no "engine malfunction" but "sevice engine soon" came on... drove around little bit, had "start" "stop" several times since i needed to get out of car to do stuff...and was surprized "service engine soon" was gone. I have been driving this car like this for 3 years, since the day I got it, when car was new it bothered me at first.... "engine malfunction" was driving me crazy...took car to dealer back then...they couldnt fix it... so I took this 335i to another dealer and they replaced bad "solenoid", drove fine after that. But later on "engine malfunction" came back on...and has been coming back on....and keeps coming back on.... You just never know with this car, could drive it hard and all is fine, but other days you try to get away from some jerk on highway, smack it into 3rd gear, pulling out high rev...and BANG! car fails you with this wicked "engine malfunction",- have to pull over like an idiot to restart. I noticed,- "engine malfunction" is more likely to happen early morning (car is warmed up ofcourse)... This is lease, car is going back to BMWFS in 3 weeks... I am not going to get turbo egine again... M3V8 FTW!
dimabimmer is offline   United_States
0
Reply With Quote
      11-23-2009, 11:08 AM   #7
E92_328i_Boston
First Lieutenant
 
Drives: 2008 E92 328i
Join Date: Apr 2008
Location: Boston

Posts: 313
iTrader: (0)

Waylap, are you sure your code was matched to "tank vent valve fault." Please let me know what you learn today after dropping it off. Thanks!

-A
E92_328i_Boston is offline   United_States
0
Reply With Quote
      11-23-2009, 11:58 AM   #8
Healey3000
Second Lieutenant
 
Drives: 2008 328i, with 3 pedals
Join Date: Jan 2008
Location: San Francisco Bay Area, USA

Posts: 246
iTrader: (0)

Quote:
Originally Posted by E92_328i_Boston View Post
"tank vent valve fault"

2008 328i coupe. 10,400 miles. never a single problem until the check engine soon light came on yesterday morning. no other symptoms whatsoever. just the light.

has anyone ever heard of this or experienced the same thing?

they recommended that a "reprogramming" be done, but they could not do that today (something about the computer/software being updated on Sundays).

any further info will be greatly appreciated! thank you in advance.

-A
Hi,

I had perhaps the same problem. Apparently, there is a defective batch of filler hoses and vent valve assemblies on some cars. They replaced the hose neck, gas cap and filler tube assembly and maybe even the line to the charcoal canister.

Like you, the check engine light suddenly popped up for no reason, with no other symptoms. My car is also a 2008 but an E90. My dealer made no mention about reprogramming.

Regards,
Adnan
Healey3000 is offline  
0
Reply With Quote
      11-23-2009, 12:13 PM   #9
wrickem
doesn't really care
 
wrickem's Avatar
 
Drives: what he wants to
Join Date: Mar 2006
Location: lambertville nj

Posts: 2,296
iTrader: (0)

My '07 328xi had the same thing at 12,ooo miles. They cleared the fault, "fixed" something, sent me on my way. 31 miles later I got the check engine light again. The next day they replaced some part and the tank vent valve fault has stayed away so far.

They didn't reprogram anything on my car other than to reset the fault so the CE light was not on anymore.
__________________
______________________________________________
'14 528-xdrive - daily driver/winter beater, '06 Boxster - for fun, '07 M6- for even more fun.
wrickem is offline  
0
Reply With Quote
      11-23-2009, 12:29 PM   #10
E92_328i_Boston
First Lieutenant
 
Drives: 2008 E92 328i
Join Date: Apr 2008
Location: Boston

Posts: 313
iTrader: (0)

Thank you for the comments!

-A
E92_328i_Boston is offline   United_States
0
Reply With Quote
      11-23-2009, 12:29 PM   #11
E92_328i_Boston
First Lieutenant
 
Drives: 2008 E92 328i
Join Date: Apr 2008
Location: Boston

Posts: 313
iTrader: (0)

BTW, wrickem, do you know what they replaced, exactly? Any way to find out?

-A
E92_328i_Boston is offline   United_States
0
Reply With Quote
      11-23-2009, 12:57 PM   #12
waylap
Private
 
waylap's Avatar
 
Drives: 06 330i
Join Date: Jun 2009
Location: S. Florida

Posts: 67
iTrader: (0)

Quote:
Originally Posted by E92_328i_Boston View Post
Waylap, are you sure your code was matched to "tank vent valve fault." Please let me know what you learn today after dropping it off. Thanks!

-A
Will do, they've had it for 5 hours so far...longer than they usually have it. I'll post the outcome later today...hopefully.
__________________
2006 330i Titanium Silver
waylap is offline  
0
Reply With Quote
      11-23-2009, 01:08 PM   #13
Sh0cker
n00b
 
Sh0cker's Avatar
 
Drives: 335i
Join Date: Jul 2008
Location: NJ

Posts: 178
iTrader: (9)

Do you ever "top up" your car after the gas pump shuts off? I know for some cars you can damage the evaporative emissions control stuff by overfilling.
__________________
His: 08 E92 335i (sold), 99 Corolla beater car
Hers: 09 Tiguan
Previous: 09 e93 328i, 04 WRX, 07 S40, 03 E46 330xi, 04 F4i, 04 EX250
Sh0cker is offline  
0
Reply With Quote
      11-23-2009, 01:15 PM   #14
waylap
Private
 
waylap's Avatar
 
Drives: 06 330i
Join Date: Jun 2009
Location: S. Florida

Posts: 67
iTrader: (0)

I don't ever do it...I've been familiar with that system having BMW motorcycles..if you overfill, it goes to a charcoal canister meant to filter gas vapors from the fuel tank.
__________________
2006 330i Titanium Silver
waylap is offline  
0
Reply With Quote
      11-23-2009, 01:25 PM   #15
E92_328i_Boston
First Lieutenant
 
Drives: 2008 E92 328i
Join Date: Apr 2008
Location: Boston

Posts: 313
iTrader: (0)

Agreed. I usually only round it to the nearest tenth.

I look forward to hearing more details.

-A
E92_328i_Boston is offline   United_States
0
Reply With Quote
      11-23-2009, 04:31 PM   #16
waylap
Private
 
waylap's Avatar
 
Drives: 06 330i
Join Date: Jun 2009
Location: S. Florida

Posts: 67
iTrader: (0)

Just got it back. They said it was the "leak diagnostic pump" and replaced it and a new fuel cap.... The part # was 16137193479
__________________
2006 330i Titanium Silver
waylap is offline  
0
Reply With Quote
      11-23-2009, 06:11 PM   #17
wrickem
doesn't really care
 
wrickem's Avatar
 
Drives: what he wants to
Join Date: Mar 2006
Location: lambertville nj

Posts: 2,296
iTrader: (0)

Quote:
Originally Posted by E92_328i_Boston View Post
BTW, wrickem, do you know what they replaced, exactly? Any way to find out?

-A
I just pulled out my receipt ....

"tech found purge valve to be sticking at times, replaced purge valve. Cleared faults. Test drove"

the actual part listed that did the trick for me is
13-90-7-527-234 "fuel tank ventilati" (the rest cut off)

I hope this helps, I HATE that stupid vague CEL!
__________________
______________________________________________
'14 528-xdrive - daily driver/winter beater, '06 Boxster - for fun, '07 M6- for even more fun.
wrickem is offline  
0
Reply With Quote
      11-23-2009, 09:07 PM   #18
E92_328i_Boston
First Lieutenant
 
Drives: 2008 E92 328i
Join Date: Apr 2008
Location: Boston

Posts: 313
iTrader: (0)

Many thanks to you guys, wrickem and waylap!

-A
E92_328i_Boston is offline   United_States
0
Reply With Quote
      11-25-2009, 08:15 PM   #19
Healey3000
Second Lieutenant
 
Drives: 2008 328i, with 3 pedals
Join Date: Jan 2008
Location: San Francisco Bay Area, USA

Posts: 246
iTrader: (0)

Quote:
Originally Posted by E92_328i_Boston View Post
"tank vent valve fault"

2008 328i coupe. 10,400 miles. never a single problem until the check engine soon light came on yesterday morning. no other symptoms whatsoever. just the light.

has anyone ever heard of this or experienced the same thing?

they recommended that a "reprogramming" be done, but they could not do that today (something about the computer/software being updated on Sundays).

any further info will be greatly appreciated! thank you in advance.

-A
Hi,

I'm back with a second response to your original query. Talk about coincidences but just yesterday my car popped an SES light for no reason whatsoever.

I have the car back now from the dealer and guess what - the same exact vent valve failure, for the second time. Part number 13-90-7-572-234, the same as has been reported by others.

I find it hard to believe that a simple solenoid valve can fail like this. The first one went at 9,500 miles and now the second at 18,400 miles. Almost exactly the same failure interval.

Either BMW has a bad batch of these (like the HPFP on 335's) or something else is going on and this is just the symptom. I asked whether they tested the valve to confirm that it's defective and they said no. I suspect that the valves are fine but since that's what the code says, they blindly replace it.

Hope that helps,
Adnan
Healey3000 is offline  
0
Reply With Quote
      12-02-2009, 09:50 PM   #20
E92_328i_Boston
First Lieutenant
 
Drives: 2008 E92 328i
Join Date: Apr 2008
Location: Boston

Posts: 313
iTrader: (0)

Thank you for the additional info, Adrian.

-A
E92_328i_Boston is offline   United_States
0
Reply With Quote
      12-03-2009, 04:49 AM   #21
TurboFan
Ski bum
 
TurboFan's Avatar
 
Drives: sideways
Join Date: Aug 2007
Location: Knee deep in the pow

Posts: 6,207
iTrader: (8)

Quote:
Originally Posted by E92_328i_Boston View Post
"tank vent valve fault"

2008 328i coupe. 10,400 miles. never a single problem until the check engine soon light came on yesterday morning. no other symptoms whatsoever. just the light.

has anyone ever heard of this or experienced the same thing?

they recommended that a "reprogramming" be done, but they could not do that today (something about the computer/software being updated on Sundays).

any further info will be greatly appreciated! thank you in advance.

-A
do you smoke?
__________________

1999 e46 328i Ti Silver / Black[retired]
2007 e90 335xi Jet Black / Black[retired]
2011 e70 X5 35d Vermillion Red / Cinnamon
2011 e92 M3 LeMans / Fox Red extended
TurboFan is offline  
0
Reply With Quote
      12-03-2009, 12:08 PM   #22
E92_328i_Boston
First Lieutenant
 
Drives: 2008 E92 328i
Join Date: Apr 2008
Location: Boston

Posts: 313
iTrader: (0)

No, I don't smoke. Where did that come from?

-A
E92_328i_Boston is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:11 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST