E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > HPFP failure FAQ!



Reply
 
Thread Tools Search this Thread
      12-27-2009, 07:18 PM   #23
ucdbiendog
Private First Class
 
Drives: 2008 335xi 4dr
Join Date: Mar 2008
Location: Millbrae, ca

Posts: 184
iTrader: (0)

Well I got my HPFP replaced last week. It cured the long cranks and the engine malfunction lights. However, something new has cropped up. Now, sometimes while I am waiting at a light in neutral, I feel a slight shutter once in a while, as if the engine mis-fired or something. Doesn't seem serious, car still drives and starts fine, but I'm pretty sensitive to these things.
ucdbiendog is offline  
0
Reply With Quote
      12-27-2009, 08:53 PM   #24
chris b.
Brigadier General
 
chris b.'s Avatar
 
Drives: zmp e90
Join Date: Oct 2006
Location: White Plains NY

Posts: 3,225
iTrader: (1)

Garage List
2010 335i  [0.00]
if theres no c.e.l on be happy it runs and let it go. lmfao
__________________

Brentuning Cobb AP pro tune
2010 335i zmp fbo
465whp 513tq 50% E85
chris b. is offline   United_States
0
Reply With Quote
      12-27-2009, 09:58 PM   #25
quattr0
Second Lieutenant
 
Drives: 335i
Join Date: Oct 2008
Location: US

Posts: 247
iTrader: (0)

Quote:
Originally Posted by ucdbiendog View Post
Well I got my HPFP replaced last week. It cured the long cranks and the engine malfunction lights. However, something new has cropped up. Now, sometimes while I am waiting at a light in neutral, I feel a slight shutter once in a while, as if the engine mis-fired or something. Doesn't seem serious, car still drives and starts fine, but I'm pretty sensitive to these things.
I'm no expert but if you can't tell that engine misfires then you could go to the store and get a digital thermostat/reader and beam it at each core that taps to the engine (hope I say it right) and read the temparature for each core. If you have found one that has lower temp than the rest, that one is misfired.

Also misfires will throw code so if you have a bt scanner, scan it. If not, try the above.
quattr0 is offline  
0
Reply With Quote
      12-27-2009, 10:01 PM   #26
quattr0
Second Lieutenant
 
Drives: 335i
Join Date: Oct 2008
Location: US

Posts: 247
iTrader: (0)

Quote:
Originally Posted by kennykenaz View Post
CAN SOMEONE ELABORATE PLEASE?
8. With the HPFP failure like this why you guys/gals still have the car?

- BMW extends the warranty to 120k miles. The replacement takes only few hours and you're good to go. As of 12/21, MY 09 and 2010 users have not received letters to state the same extended warranty for 07 and 08 MY users.
It means if your car has passed the 4-year/50k miles warranty, BMW will still replace HPFP for nil until you will reach 120k miles.
quattr0 is offline  
0
Reply With Quote
      12-28-2009, 01:51 AM   #27
kennykenaz
New Member
 
Drives: 335i
Join Date: Dec 2009
Location: in the desert

Posts: 16
iTrader: (0)

Quote:
Originally Posted by quattr0 View Post
It means if your car has passed the 4-year/50k miles warranty, BMW will still replace HPFP for nil until you will reach 120k miles.
Cheers, all clear now.
kennykenaz is offline  
0
Reply With Quote
      01-01-2010, 01:01 PM   #28
investor27
Private First Class
 
Drives:
Join Date: Nov 2007

Posts: 137
iTrader: (0)

Not if yours is a 2009 or 2010 model?
investor27 is offline  
0
Reply With Quote
      01-02-2010, 10:31 AM   #29
quattr0
Second Lieutenant
 
Drives: 335i
Join Date: Oct 2008
Location: US

Posts: 247
iTrader: (0)

Quote:
Originally Posted by TrackRat View Post
I'd contact NHTSA to see why this matter hasn't been resolved on all years including 2009 onward.
NTSA already made a complaint to BMW and they replied that only, IIRC, lesser than 1% of stalled vehicles and not one scenario that caused fatality. BMW already extended the warranty to 120k miles for 07 & 08 folks so that's really all they could do. Here is the article http://www.e90post.com/forums/showth...=279731&page=2

If you need to know whether or not 09 and 2010 will receive the same warranty, contact your dealer.

I understand it really isn't acceptable for 50k's car to have repeatedly HPFP failures but as I mentioned in the FAQ, most users either stick with the car because of the joy of driving it or trade it in.
quattr0 is offline  
0
Reply With Quote
      01-02-2010, 09:23 PM   #30
SoYank
Major General
 
SoYank's Avatar
 
Drives: 2009 E90 335i MT
Join Date: Mar 2006
Location: Brighton, Colorado

Posts: 7,498
iTrader: (1)

Garage List
Send a message via Yahoo to SoYank Send a message via Skype™ to SoYank
Where's Ralph Nader when you need him?
__________________
2009 E90 335i Montego Blue Black Leather Burl Walnut 6MT US Spec
SatNav ZPP ZCW 6FL TPMS iDrive PDC HWS Xenons BMW Assist Power Rear Sunshade Logic 7
European Taillights Rear Foglamp OEM Alarm PicoTray DataToys XM-DVR Multi-view Processor
Quaife ATB LSD Short Shift Knob Hartge Anti-Roll Bars AP Racing Front Brakes 19" Style 269
SoYank is offline   United_States
0
Reply With Quote
      01-04-2010, 07:02 AM   #31
Bimmer335i
Major
 
Bimmer335i's Avatar
 
Drives: 07 Sparkling Graphite 335i Sed
Join Date: Jun 2007
Location: San Diego, CA US

Posts: 1,346
iTrader: (0)

Well guys, here i am, a "repeated" victim. My 07 died on me as i was leaving LAX and about to get on the freeway on Jan 2nd, 2010. Engine shuddered rattled and then died, 1/2 engine symbol popped up, Service Engine Soon light came on, and car died. Had to tow to nearest stealership for check...and this looks like to be my 2nd HPFP replacement, the third pump counting the original that came with the car.
__________________
Enjoy the ride!

Last edited by Bimmer335i; 01-04-2010 at 01:53 PM.
Bimmer335i is offline  
0
Reply With Quote
      01-06-2010, 01:37 PM   #32
335inSC
Private
 
Drives: 2007 335i
Join Date: Jan 2007
Location: Charlotte, NC

Posts: 91
iTrader: (0)

I currently have an '09 335 coupe and before that I had an '07 335 sedan.

My '07 lasted until about 40,000 miles before needing to get the HPFP replaced.

I got my '09 in October of 2009 and I've now had to have the HPFP replaced twice in that car.

I'm starting to get a little frustrated an annoyed with the situation. It's clear that they do not have a solution to the problem and I'm starting to wonder whether it is worth it to stick with this car even thought I love it. For me, it's just the principle of the matter. If you buy a $50K car then I don't think you should have to deal with these issues.

Luckily for me the service at my local dealership is excellent (Hendrick BMW in Charlotte, NC) and they've been nothing but exceptionally polite with me and they've always fully taken care of everything for me and this is probably the only reason I haven't completely flipped my lid by now.

I think, technically, if they have to try and fix my problem a third time that I could go the lemon law route with them but I really don't want to do that. I just want my car to work the way it's supposed to.

It's just an all around bad situation that BMW needs to get a grip on very quickly - I mean, it's been 3-4 years and they are still have the same problems!!
335inSC is offline  
0
Reply With Quote
      01-06-2010, 02:29 PM   #33
Bimmer335i
Major
 
Bimmer335i's Avatar
 
Drives: 07 Sparkling Graphite 335i Sed
Join Date: Jun 2007
Location: San Diego, CA US

Posts: 1,346
iTrader: (0)

Quote:
Originally Posted by 335inSC View Post
I currently have an '09 335 coupe and before that I had an '07 335 sedan.

My '07 lasted until about 40,000 miles before needing to get the HPFP replaced.

I got my '09 in October of 2009 and I've now had to have the HPFP replaced twice in that car.

I'm starting to get a little frustrated an annoyed with the situation. It's clear that they do not have a solution to the problem and I'm starting to wonder whether it is worth it to stick with this car even thought I love it. For me, it's just the principle of the matter. If you buy a $50K car then I don't think you should have to deal with these issues.

Luckily for me the service at my local dealership is excellent (Hendrick BMW in Charlotte, NC) and they've been nothing but exceptionally polite with me and they've always fully taken care of everything for me and this is probably the only reason I haven't completely flipped my lid by now.

I think, technically, if they have to try and fix my problem a third time that I could go the lemon law route with them but I really don't want to do that. I just want my car to work the way it's supposed to.

It's just an all around bad situation that BMW needs to get a grip on very quickly - I mean, it's been 3-4 years and they are still have the same problems!!
+1 Exactly how I feel about this whole situation...
__________________
Enjoy the ride!
Bimmer335i is offline  
0
Reply With Quote
      01-07-2010, 03:05 AM   #34
RUS0628
First Lieutenant
 
RUS0628's Avatar
 
Drives: e92 335
Join Date: Sep 2009
Location: SF Bay Area

Posts: 313
iTrader: (3)

I got my car in august already had 2 hpfp replaced. Today, getting into my car from gym. Start the car... took 2-3 seconds to start.....
After that I went to my gf house. Came out tried to start the car and again the long crank....
__________________
BSM e92 335i
JB3|5% Tint|Matte Grills|H&R Sport|230's
RUS0628 is offline   Russian Federation
0
Reply With Quote
      01-07-2010, 03:05 AM   #35
RUS0628
First Lieutenant
 
RUS0628's Avatar
 
Drives: e92 335
Join Date: Sep 2009
Location: SF Bay Area

Posts: 313
iTrader: (3)

pissed off
__________________
BSM e92 335i
JB3|5% Tint|Matte Grills|H&R Sport|230's
RUS0628 is offline   Russian Federation
0
Reply With Quote
      01-07-2010, 12:05 PM   #36
KRB_E90
Private First Class
 
Drives: Yes
Join Date: Jun 2009
Location: NJ

Posts: 127
iTrader: (0)

Quote:
Originally Posted by ucdbiendog View Post
Well I got my HPFP replaced last week. It cured the long cranks and the engine malfunction lights. However, something new has cropped up. Now, sometimes while I am waiting at a light in neutral, I feel a slight shutter once in a while, as if the engine mis-fired or something. Doesn't seem serious, car still drives and starts fine, but I'm pretty sensitive to these things.
I have this all the time since day one with the car. My pump is throwing code and having 8 sec cold morning cranks.... going to the dealer next week.
KRB_E90 is offline  
0
Reply With Quote
      01-08-2010, 08:43 PM   #37
Saintor
Colonel
 
Saintor's Avatar
 
Drives: E90
Join Date: Sep 2005
Location: MTL, Canada

Posts: 2,373
iTrader: (1)

According to Wiki

Quote:
As of late 2009, the low pressure fuel sensor has become suspected of causing some premature failures of the HPFP by engine tuners such as AMS and CP-E.
http://en.wikipedia.org/wiki/BMW_N54

Any specific on the root cause design or manufacturing wise? It is the pump that can no longer build pressure? Is it a an internal leak because of a seal is not strong enough or corrosion? Anybody has pics or drawings?

It boggles my mind that no root cause stands out at this point.
__________________
2007 E90 AW 323i Step | Lowered 1.25"/1" | BMW Performance Exhaust | Debadged | Scangauge II | Style 162 18" & 161 17" wheels & rear 15mm spacers
Saintor is online now  
0
Reply With Quote
      01-08-2010, 10:56 PM   #38
quattr0
Second Lieutenant
 
Drives: 335i
Join Date: Oct 2008
Location: US

Posts: 247
iTrader: (0)

Quote:
Originally Posted by Saintor View Post
According to Wiki



http://en.wikipedia.org/wiki/BMW_N54

Any specific on the root cause design or manufacturing wise? It is the pump that can no longer build pressure? Is it a an internal leak because of a seal is not strong enough or corrosion? Anybody has pics or drawings?

It boggles my mind that no root cause stands out at this point.
Not sure if I should be laughing as the exact same companies mentioned in the wiki are trying to make a better HPFP
quattr0 is offline  
0
Reply With Quote
      01-09-2010, 12:09 AM   #39
semaj
Private First Class
 
Drives: 135i Coupe
Join Date: May 2005
Location: USA

Posts: 107
iTrader: (0)

Garage List
2010 135i  [0.00]
Would a rough idle after sitting in the garage all night be considered a symptom of a future HPFP failure? To clarify, I do not experience long starts. My engine starts almost instantaneously.

I read that this is just a natural characteristic of the N54 engine, but I want to make sure.
semaj is offline  
0
Reply With Quote
      01-11-2010, 07:11 PM   #40
djamuh0219
Muhammad
 
Drives: 328i Coupe (E-92)
Join Date: Dec 2009
Location: Dallas, TX USA

Posts: 10
iTrader: (0)

does HPFP stand for high pressure fuel pump?

is this problem for the 335i only?
djamuh0219 is offline   United_States
0
Reply With Quote
      01-11-2010, 09:03 PM   #41
Bimmer335i
Major
 
Bimmer335i's Avatar
 
Drives: 07 Sparkling Graphite 335i Sed
Join Date: Jun 2007
Location: San Diego, CA US

Posts: 1,346
iTrader: (0)

Quote:
Originally Posted by djamuh0219 View Post
does HPFP stand for high pressure fuel pump?

is this problem for the 335i only?
Yes.
Yes.
__________________
Enjoy the ride!
Bimmer335i is offline  
0
Reply With Quote
      01-11-2010, 09:48 PM   #42
LagMode335i
Private First Class
 
Drives: 2008 335i DS2 but M OTW
Join Date: Dec 2008
Location: TN

Posts: 181
iTrader: (0)

Quote:
Originally Posted by Bimmer335i View Post
Yes.
Yes.
Nope. I believe it refers to N54 models. 135i, 335i, 535i and new Z4. No bigiies; they're all having fuel delivery issues. Just a matter of time.
LagMode335i is offline  
0
Reply With Quote
      01-12-2010, 09:28 AM   #43
Alpine Whiteboy
Jerry's Fault...
 
Alpine Whiteboy's Avatar
 
Drives: 2013 535xi M-Sport SGM
Join Date: Sep 2009
Location: Queens, N.Y.

Posts: 9,259
iTrader: (1)

Unhappy

Just got my 2010 in November. Yesterday coming home from work, half engine + service light came on. Car went into "limp" mode and I drove 30 mph all the way home. (Car died at the toll booth on the way home but when I let it sit for 2 mins it started right up and I drove off. 2 mins later it was in limp mode but luckily I made it home...) I'm just glad this didn't happen to me on Saturday while I was 2 hours away in Shawnee Mountain snowboarding. That would have REALLY sucked. I plan on getting it towed today after work so hopefully I'll have it back this weekend... FML...
Alpine Whiteboy is offline  
0
Reply With Quote
      01-12-2010, 02:22 PM   #44
Bimmer335i
Major
 
Bimmer335i's Avatar
 
Drives: 07 Sparkling Graphite 335i Sed
Join Date: Jun 2007
Location: San Diego, CA US

Posts: 1,346
iTrader: (0)

Quote:
Originally Posted by Alpine Whiteboy View Post
Just got my 2010 in November. Yesterday coming home from work, half engine + service light came on. Car went into "limp" mode and I drove 30 mph all the way home. (Car died at the toll booth on the way home but when I let it sit for 2 mins it started right up and I drove off. 2 mins later it was in limp mode but luckily I made it home...) I'm just glad this didn't happen to me on Saturday while I was 2 hours away in Shawnee Mountain snowboarding. That would have REALLY sucked. I plan on getting it towed today after work so hopefully I'll have it back this weekend... FML...
that's just absolutely UNSAT!!!
__________________
Enjoy the ride!
Bimmer335i is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:25 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST